summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-10-06 21:18:26 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-10-06 21:51:36 +0200
commit1dbb8ef709f77bc430ef5384ea32842541469fb3 (patch)
treed63205eb213d6de58916a44947192d93c05f385c
parentsys-apps/openrazer: bump to 3.9.0 (diff)
downloadgentoo-1dbb8ef709f77bc430ef5384ea32842541469fb3.tar.gz
gentoo-1dbb8ef709f77bc430ef5384ea32842541469fb3.tar.bz2
gentoo-1dbb8ef709f77bc430ef5384ea32842541469fb3.zip
sci-mathematics/easycrypt: bump to 2024.09
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--sci-mathematics/easycrypt/Manifest1
-rw-r--r--sci-mathematics/easycrypt/easycrypt-2024.09.ebuild50
-rw-r--r--sys-apps/openrazer/openrazer-3.9.0.ebuild2
3 files changed, 52 insertions, 1 deletions
diff --git a/sci-mathematics/easycrypt/Manifest b/sci-mathematics/easycrypt/Manifest
index 12d4362310fb..f3ed46c61173 100644
--- a/sci-mathematics/easycrypt/Manifest
+++ b/sci-mathematics/easycrypt/Manifest
@@ -1 +1,2 @@
DIST easycrypt-2024.01.tar.gz 1349695 BLAKE2B e9c43d43f2c07d75dcb5ee8edf46d1fcfc2a47497fd76c87ef13d52087144acbf3b80ae809c70164eebe046cfb5d585678811163a47cf30c3c55828c3278a4fc SHA512 331612b05f6c47b302f1ceb1d741f47476354bf2d4960c2f55e6bddf3187fea3d40aa687c278fc727bf8994fee95e7af444f109be9a0c9eb9ab455d5fcc7b97d
+DIST easycrypt-2024.09.tar.gz 1310681 BLAKE2B cfe81762d4f4567473fc1f98c889145ed8c42f0a48b9e8089de8eca6c15f088d36c4eb7f4b4c4889b6444323b38a2ab17d0703cf97470ddf3084094a37436d69 SHA512 ce1554046c87fbeb27763ffd7a40fb0d8abc8bdedce6884e864968c23b31aee2c66108e52233d4dd1cb408a48b2ac3cba3ef46aee0963a5c21f3c2d1a843c308
diff --git a/sci-mathematics/easycrypt/easycrypt-2024.09.ebuild b/sci-mathematics/easycrypt/easycrypt-2024.09.ebuild
new file mode 100644
index 000000000000..80d57075fb07
--- /dev/null
+++ b/sci-mathematics/easycrypt/easycrypt-2024.09.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Computer-Aided Cryptographic Proofs"
+HOMEPAGE="https://github.com/EasyCrypt/easycrypt/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/EasyCrypt/${PN}.git"
+else
+ SRC_URI="https://github.com/EasyCrypt/${PN}/archive/r${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-r${PV}"
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ <dev-ml/num-1.5:=
+ >=dev-lang/ocaml-4.08.0:=[ocamlopt?]
+ dev-ml/batteries:=
+ dev-ml/camlp-streams:=
+ dev-ml/camlzip:=
+ dev-ml/dune-build-info:=
+ dev-ml/dune-site:=
+ dev-ml/ocaml-inifiles:=
+ dev-ml/pcre-ocaml:=
+ dev-ml/yojson:=
+ dev-ml/zarith:=
+ sci-mathematics/why3:=
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+src_prepare() {
+ local theories="[\"$(ocamlc -where)/easycrypt/theories\"]"
+ sed -i "s|EcRelocate\.Sites\.theories|${theories}|g" src/ec.ml || die
+
+ default
+}
diff --git a/sys-apps/openrazer/openrazer-3.9.0.ebuild b/sys-apps/openrazer/openrazer-3.9.0.ebuild
index 878518347eef..847563f1745f 100644
--- a/sys-apps/openrazer/openrazer-3.9.0.ebuild
+++ b/sys-apps/openrazer/openrazer-3.9.0.ebuild
@@ -20,7 +20,7 @@ else
SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz
-> ${P}.tar.gz"
- KEYWORDS="amd64 ~x86"
+ KEYWORDS="~amd64 ~x86"
fi
LICENSE="GPL-2+"