summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2019-12-31 11:12:09 +0900
committerNaohiro Aota <naota@gentoo.org>2019-12-31 11:18:21 +0900
commit1dfb69d80745eb29ff5a506702eac5d8f9885d28 (patch)
treef200e3af96142f2dd01a0422763bda4acdd71941
parentdev-libs/protobuf: arm64 stable (bug #704250) (diff)
downloadgentoo-1dfb69d80745eb29ff5a506702eac5d8f9885d28.tar.gz
gentoo-1dfb69d80745eb29ff5a506702eac5d8f9885d28.tar.bz2
gentoo-1dfb69d80745eb29ff5a506702eac5d8f9885d28.zip
dev-util/global: version bump
Closes: https://bugs.gentoo.org/701376 Signed-off-by: Naohiro Aota <naota@gentoo.org>
-rw-r--r--dev-util/global/Manifest1
-rw-r--r--dev-util/global/global-6.6.4.ebuild96
2 files changed, 97 insertions, 0 deletions
diff --git a/dev-util/global/Manifest b/dev-util/global/Manifest
index dca545d4d393..902af58d5dc5 100644
--- a/dev-util/global/Manifest
+++ b/dev-util/global/Manifest
@@ -1,2 +1,3 @@
DIST global-6.3.1.tar.gz 1369634 BLAKE2B 8d93222ccbb4a45c0b9f114cd84b342b3f6ab99f7e0bbc18bfe00912ecd53f606be9d32fce1570e027009fd1fbe4752f03dd19c183dfda438d67a329808a6b45 SHA512 83becd6cda06f8da17ea0c701bb135523ff48cec73b233d24566387d11a35c0b42f410b62753838e2b364a5a485cac033b4aef1159cc6f4cdeca4a7b6c5bb4d6
DIST global-6.5.7.tar.gz 2940567 BLAKE2B e0c692e09f9f7ea64ecbe47e18691efd3c641f28826e19751fb812690cd9d64a53af03055de9ec8199637da46dbd6084fec16380d7f295c83ed77553a8e301fd SHA512 0d33f718839e5e00bdd6d042b415a69c5e1f232d843610870505f8f20635b445810149b1b84ea8b77881f5f64814783ebe3cdcab2f84b8a085223b64293a9045
+DIST global-6.6.4.tar.gz 2988969 BLAKE2B 784087537094d27c10d1f2bc992e799c35ab6ce3b86e041c31279e6954b203e80676b3158ba95e7957456b75a213d70998aae9047836cd4d388212236f05a081 SHA512 cb4ed451d3aaf47c4c59cdc3f74c97d3171108177d4846b5dac843589710e66d87c9d7bbe080c3770329e8e40105ac52dcafb4609257347593cca4d94711f483
diff --git a/dev-util/global/global-6.6.4.ebuild b/dev-util/global/global-6.6.4.ebuild
new file mode 100644
index 000000000000..e45daf3d4f7d
--- /dev/null
+++ b/dev-util/global/global-6.6.4.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools elisp-common
+
+DESCRIPTION="tag system to find an object location in various sources"
+HOMEPAGE="https://www.gnu.org/software/global/global.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc emacs vim"
+
+RDEPEND="
+ sys-libs/ncurses
+ emacs? ( >=app-editors/emacs-23.1:* )
+ vim? ( || (
+ app-editors/vim
+ app-editors/gvim
+ )
+ )
+ || (
+ dev-libs/libltdl:0
+ sys-devel/libtool:2
+ )"
+
+DEPEND="${DEPEND}
+ doc? (
+ app-text/texi2html
+ sys-apps/texinfo
+ )"
+
+SITEFILE="50gtags-gentoo.el"
+
+PATCHES=( "${FILESDIR}/${PN}-6.2.9-tinfo.patch" )
+
+DOCS=( AUTHORS FAQ NEWS README THANKS )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ "$(use_with emacs lispdir "${SITELISP}/${PN}")"
+}
+
+src_compile() {
+ if use doc; then
+ texi2pdf -q -o doc/global.pdf doc/global.texi
+ texi2html -o doc/global.html doc/global.texi
+ fi
+
+ if use emacs; then
+ elisp-compile *.el
+ fi
+
+ emake
+}
+
+src_install() {
+ default
+
+ insinto /etc
+ doins gtags.conf
+
+ if use vim; then
+ insinto /usr/share/vim/vimfiles/plugin
+ doins gtags.vim
+ fi
+
+ if use emacs; then
+ elisp-install ${PN} *.{el,elc}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+
+ if use doc; then
+ # doc/global.pdf is generated if tex executable (e.g. /usr/bin/tex) is available.
+ [[ -f doc/global.pdf ]] && DOCS+=( doc/global.pdf )
+ fi
+
+ einstalldocs
+ find "${ED}" -name '*.la' -type f -delete || die
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}