summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-01-01 21:07:01 +0100
committerDavid Seifert <soap@gentoo.org>2022-01-01 21:07:01 +0100
commit1e98c9bec0e4c672586d70da046dcb24579c253b (patch)
tree680cc04b0e4805b40bd2fc0754db49a64fea0104
parentdev-db/postgresql: remove uclibc (diff)
downloadgentoo-1e98c9bec0e4c672586d70da046dcb24579c253b.tar.gz
gentoo-1e98c9bec0e4c672586d70da046dcb24579c253b.tar.bz2
gentoo-1e98c9bec0e4c672586d70da046dcb24579c253b.zip
dev-lang/perl: remove uclibc
Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--dev-lang/perl/perl-5.34.0-r3.ebuild5
-rw-r--r--dev-lang/perl/perl-5.34.0-r5.ebuild5
-rw-r--r--dev-lang/perl/perl-5.34.0-r6.ebuild3
3 files changed, 5 insertions, 8 deletions
diff --git a/dev-lang/perl/perl-5.34.0-r3.ebuild b/dev-lang/perl/perl-5.34.0-r3.ebuild
index 4f15c0a9e41f..8f3eb1ad8b3f 100644
--- a/dev-lang/perl/perl-5.34.0-r3.ebuild
+++ b/dev-lang/perl/perl-5.34.0-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -533,7 +533,7 @@ src_configure() {
[[ ${COLUMNS:-1} -ge 1 ]] || unset COLUMNS # bug #394091
# Perl has problems compiling with -Os in your flags with glibc
- use elibc_uclibc || replace-flags "-Os" "-O2"
+ replace-flags "-Os" "-O2"
# xlocale.h is going away in glibc-2.26, so it's counterproductive
# if we use it and include it in CORE/perl.h ... Perl builds just
@@ -742,7 +742,6 @@ src_test() {
ewarn "Test fails with a sandbox error (#328793) if run as root. Skipping tests..."
return 0
fi
- use elibc_uclibc && export MAKEOPTS+=" -j1"
TEST_JOBS="$(makeopts_jobs)" make test_harness || die "test failed"
}
diff --git a/dev-lang/perl/perl-5.34.0-r5.ebuild b/dev-lang/perl/perl-5.34.0-r5.ebuild
index e066689b21b8..effe3c01df9a 100644
--- a/dev-lang/perl/perl-5.34.0-r5.ebuild
+++ b/dev-lang/perl/perl-5.34.0-r5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -518,7 +518,7 @@ src_configure() {
[[ ${COLUMNS:-1} -ge 1 ]] || unset COLUMNS # bug #394091
# Perl has problems compiling with -Os in your flags with glibc
- use elibc_uclibc || replace-flags "-Os" "-O2"
+ replace-flags "-Os" "-O2"
# xlocale.h is going away in glibc-2.26, so it's counterproductive
# if we use it and include it in CORE/perl.h ... Perl builds just
@@ -727,7 +727,6 @@ src_test() {
ewarn "Test fails with a sandbox error (#328793) if run as root. Skipping tests..."
return 0
fi
- use elibc_uclibc && export MAKEOPTS+=" -j1"
TEST_JOBS="$(makeopts_jobs)" make test_harness || die "test failed"
}
diff --git a/dev-lang/perl/perl-5.34.0-r6.ebuild b/dev-lang/perl/perl-5.34.0-r6.ebuild
index 41c48de8d309..e25c16f697b7 100644
--- a/dev-lang/perl/perl-5.34.0-r6.ebuild
+++ b/dev-lang/perl/perl-5.34.0-r6.ebuild
@@ -525,7 +525,7 @@ src_configure() {
[[ ${COLUMNS:-1} -ge 1 ]] || unset COLUMNS # bug #394091
# Perl has problems compiling with -Os in your flags with glibc
- use elibc_uclibc || replace-flags "-Os" "-O2"
+ replace-flags "-Os" "-O2"
# xlocale.h is going away in glibc-2.26, so it's counterproductive
# if we use it and include it in CORE/perl.h ... Perl builds just
@@ -736,7 +736,6 @@ src_test() {
ewarn "Test fails with a sandbox error (#328793) if run as root. Skipping tests..."
return 0
fi
- use elibc_uclibc && export MAKEOPTS+=" -j1"
TEST_JOBS="$(makeopts_jobs)" make test_harness || die "test failed"
}