summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-01-25 19:49:09 +0100
committerManuel Rüger <mrueg@gentoo.org>2018-01-25 19:51:30 +0100
commit1ef670ac35412791e58e250a6f4e77fbdd80f1e9 (patch)
tree3d834972a6b7329e892ca7fa453975b68c34128f
parentapp-portage/gemato: Remove 10.2 (diff)
downloadgentoo-1ef670ac35412791e58e250a6f4e77fbdd80f1e9.tar.gz
gentoo-1ef670ac35412791e58e250a6f4e77fbdd80f1e9.tar.bz2
gentoo-1ef670ac35412791e58e250a6f4e77fbdd80f1e9.zip
app-emulation/cadvisor: Fix build and issues with init file
Package-Manager: Portage-2.3.19, Repoman-2.3.6
-rw-r--r--app-emulation/cadvisor/cadvisor-0.28.3-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-emulation/cadvisor/cadvisor-0.28.3-r1.ebuild b/app-emulation/cadvisor/cadvisor-0.28.3-r1.ebuild
new file mode 100644
index 000000000000..a9f0af88b2da
--- /dev/null
+++ b/app-emulation/cadvisor/cadvisor-0.28.3-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN="github.com/google/cadvisor"
+
+inherit user golang-build golang-vcs-snapshot
+SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+COMMIT="1e567c2"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Analyzes resource usage and performance characteristics of running containers"
+HOMEPAGE="https://github.com/google/cadvisor"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 /dev/null ${PN}
+}
+
+src_prepare() {
+ sed -i -e "/go get/d" src/${EGO_PN}/build/assets.sh || die
+ sed -i -e "s/git describe.*/echo ${PV} )/"\
+ -e "s/git rev-parse --short HEAD.*/echo ${COMMIT} )/"\
+ src/${EGO_PN}/build/build.sh || die
+ default
+}
+
+src_compile() {
+ pushd "src/${EGO_PN}"
+ GO_FLAGS="-v -work -x" VERBOSE="true" GOPATH="${S}:$(get_golibdir_gopath)" emake build
+ popd || die
+}
+
+src_install() {
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ dobin src/${EGO_PN}/${PN}
+ keepdir /var/log/${PN}
+ fowners ${PN}:${PN} /var/log/${PN}
+}