summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2018-11-06 20:56:07 +0100
committerLouis Sautier <sbraz@gentoo.org>2018-11-06 21:03:50 +0100
commit1f22b2eec0723c5359ec20c03bccf9fdc0d8510f (patch)
tree9bc1f33b081bb4a0b32529afbe0b381de78372c2
parentnet-wireless/unifi: bump to 5.9.32, drop old (diff)
downloadgentoo-1f22b2eec0723c5359ec20c03bccf9fdc0d8510f.tar.gz
gentoo-1f22b2eec0723c5359ec20c03bccf9fdc0d8510f.tar.bz2
gentoo-1f22b2eec0723c5359ec20c03bccf9fdc0d8510f.zip
dev-python/ipython: enforce dependency on < prompt_toolkit-2
Closes: https://bugs.gentoo.org/669926 Signed-off-by: Louis Sautier <sbraz@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
-rw-r--r--dev-python/ipython/ipython-5.4.1-r1.ebuild3
-rw-r--r--dev-python/ipython/ipython-5.8.0.ebuild3
2 files changed, 4 insertions, 2 deletions
diff --git a/dev-python/ipython/ipython-5.4.1-r1.ebuild b/dev-python/ipython/ipython-5.4.1-r1.ebuild
index 787088fd8d6..39d2a6d696d 100644
--- a/dev-python/ipython/ipython-5.4.1-r1.ebuild
+++ b/dev-python/ipython/ipython-5.4.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -23,6 +23,7 @@ CDEPEND="
dev-python/pexpect[${PYTHON_USEDEP}]
dev-python/pickleshare[${PYTHON_USEDEP}]
>=dev-python/prompt_toolkit-1.0.4[${PYTHON_USEDEP}]
+ <dev-python/prompt_toolkit-2[${PYTHON_USEDEP}]
dev-python/pyparsing[${PYTHON_USEDEP}]
dev-python/simplegeneric[${PYTHON_USEDEP}]
>=dev-python/traitlets-4.2.1[${PYTHON_USEDEP}]
diff --git a/dev-python/ipython/ipython-5.8.0.ebuild b/dev-python/ipython/ipython-5.8.0.ebuild
index 8f191191e87..7d8b1e5a7f1 100644
--- a/dev-python/ipython/ipython-5.8.0.ebuild
+++ b/dev-python/ipython/ipython-5.8.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -24,6 +24,7 @@ CDEPEND="
dev-python/pexpect[${PYTHON_USEDEP}]
dev-python/pickleshare[${PYTHON_USEDEP}]
>=dev-python/prompt_toolkit-1.0.4[${PYTHON_USEDEP}]
+ <dev-python/prompt_toolkit-2[${PYTHON_USEDEP}]
dev-python/pyparsing[${PYTHON_USEDEP}]
dev-python/simplegeneric[${PYTHON_USEDEP}]
>=dev-python/traitlets-4.2.1[${PYTHON_USEDEP}]