summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2022-10-13 21:58:36 +0100
committerJames Le Cuirot <chewi@gentoo.org>2022-10-13 21:58:36 +0100
commit1f9899c6fcd6abbfab180cbe5f3822f8e3e7f5c8 (patch)
tree6505c9f934add41557a07df703439bb8b6d12c63
parentwww-client/chromium: Stabilize 106.0.5249.119 arm64, #876871 (diff)
downloadgentoo-1f9899c6fcd6abbfab180cbe5f3822f8e3e7f5c8.tar.gz
gentoo-1f9899c6fcd6abbfab180cbe5f3822f8e3e7f5c8.tar.bz2
gentoo-1f9899c6fcd6abbfab180cbe5f3822f8e3e7f5c8.zip
games-util/sc-controller: Version bump to 0.4.8.9
Closes: https://bugs.gentoo.org/876733 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
-rw-r--r--games-util/sc-controller/Manifest1
-rw-r--r--games-util/sc-controller/sc-controller-0.4.8.9.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/games-util/sc-controller/Manifest b/games-util/sc-controller/Manifest
index 44645c2ec9c7..cb4dcb8a51f7 100644
--- a/games-util/sc-controller/Manifest
+++ b/games-util/sc-controller/Manifest
@@ -1 +1,2 @@
DIST sc-controller-0.4.8.6_p20211211.tar.gz 2527489 BLAKE2B e04e2a9d617b6cfb3b0709f37bbbbb7384ac0c516f1f30a23547f1132c562cafeb8972f23e9cc93967187c881fd78fe6e6d102451aa5afc4bf8fce619e86820b SHA512 9d1030ed2766b9a0984852eafc343e265768489f3d01833e6633019276c0559cb4265d72013c0bc2ecb57ac35c95791ee8e2285f8c45917695ea92826bca6dc3
+DIST sc-controller-0.4.8.9.tar.gz 2541647 BLAKE2B f4e4ebcd15f8c32f292293ea21a0c30655fedefba310991082ece3b9159b52700178a31da4b3e7a172e40fde4e718403c0945387f3781628e09fa1fc086eee93 SHA512 e0848d366f6f80c36670adcda717b792b6993e7383c01e969c0478cf187bcdb891ea9c434271f24e7f5dfc96d8f321f953f610bb8efeb6ed843b7cd069b9b18f
diff --git a/games-util/sc-controller/sc-controller-0.4.8.9.ebuild b/games-util/sc-controller/sc-controller-0.4.8.9.ebuild
new file mode 100644
index 000000000000..48016b53a7df
--- /dev/null
+++ b/games-util/sc-controller/sc-controller-0.4.8.9.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1 linux-info xdg
+
+DESCRIPTION="User-mode driver and GTK-based GUI for Steam Controllers and others"
+HOMEPAGE="https://github.com/Ryochan7/sc-controller/"
+SRC_URI="https://github.com/Ryochan7/sc-controller/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2 BSD CC-BY-3.0 CC0-1.0 LGPL-2.1 MIT PSF-2 ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+udev wayland"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/pygobject[${PYTHON_USEDEP},cairo]
+ dev-python/pylibacl[${PYTHON_USEDEP}]
+ dev-python/python-evdev[${PYTHON_USEDEP}]
+ dev-python/vdf[${PYTHON_USEDEP}]')
+ gnome-base/librsvg[introspection]
+ virtual/libusb
+ x11-libs/gtk+:3[introspection]
+ udev? ( games-util/game-device-udev-rules )
+ wayland? ( gui-libs/gtk-layer-shell[introspection(+)] )
+"
+
+distutils_enable_tests pytest
+
+pkg_setup() {
+ local CONFIG_CHECK="~INPUT_UINPUT"
+
+ linux-info_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ # This test fails. Don't know why but seems unimportant.
+ rm -v tests/test_glade.py || die
+}
+
+src_install() {
+ distutils-r1_src_install
+ rm -r "${ED}"/usr/lib/udev/ || die
+}