summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-02 20:01:15 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-02 20:03:49 +0100
commit2052aaf95237bc2e68d0154b0569a8df0e0bfbf3 (patch)
treeecfcd109e4b1efbe256522518e3372d2f45957d3
parentdev-python/numpy: Bump to 1.19.4 (diff)
downloadgentoo-2052aaf95237bc2e68d0154b0569a8df0e0bfbf3.tar.gz
gentoo-2052aaf95237bc2e68d0154b0569a8df0e0bfbf3.tar.bz2
gentoo-2052aaf95237bc2e68d0154b0569a8df0e0bfbf3.zip
xfce-base/xfdesktop: Bump to 4.14.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--xfce-base/xfdesktop/Manifest1
-rw-r--r--xfce-base/xfdesktop/xfdesktop-4.14.3.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/xfce-base/xfdesktop/Manifest b/xfce-base/xfdesktop/Manifest
index d89e1b61523b..68612c011f2c 100644
--- a/xfce-base/xfdesktop/Manifest
+++ b/xfce-base/xfdesktop/Manifest
@@ -1,2 +1,3 @@
DIST xfdesktop-4.14.2.tar.bz2 1513121 BLAKE2B afe5dad03ed4d084bd7578074f91fbc8dc121bf67b8f4793ca5c6abb67dea4f61cfa484404d79d14cf2abf64227cee883bc8f36af05802071f5b9f79300704d4 SHA512 8515fc1c048da50c8c2986ea8590144203fdf3107b81e2d2dd44ee408938fb71281abe52cc098508dc2ae20ef2cbc31903086941206c0cbbc92a661dbfb2c472
+DIST xfdesktop-4.14.3.tar.bz2 1549953 BLAKE2B 338d80d8acf50235c0763e9de9dfe6fd933769b7f46ffa322eabca252761b13c5024c780aaec8e87e1d1ff08ce21e63e6ae871ad030daa0cedbd7734dbd94613 SHA512 30e5ce74468f8f56b78144bea9dca620af19aef031c86968eb40b0a804a7a767f3cf817994bbdc6ed096b4558fab3e59062fb832d79f7dc3455df9b5540577f8
DIST xfdesktop-4.15.0.tar.bz2 1509639 BLAKE2B fe63ba8731095622e8b5701c30a5cc786c1b8cc7bff5cb66cc477281198749887879f001fdc4652d86d01765543d4474ce52170d318af6e43124a7d7208f97ee SHA512 cb5266ab7edc5a068756ec30a3fd92af50150c3523575e2c727fc8d7eb8660259e6e8c5d59d7bc02ec85b052f779e332dcea55414fcc706f608b1eea8242897a
diff --git a/xfce-base/xfdesktop/xfdesktop-4.14.3.ebuild b/xfce-base/xfdesktop/xfdesktop-4.14.3.ebuild
new file mode 100644
index 000000000000..c0250e01fe7a
--- /dev/null
+++ b/xfce-base/xfdesktop/xfdesktop-4.14.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="Desktop manager for the Xfce desktop environment"
+HOMEPAGE="https://www.xfce.org/projects/"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug libnotify +thunar"
+
+RDEPEND=">=x11-libs/cairo-1.12
+ >=dev-libs/glib-2.42
+ >=x11-libs/gtk+-3.22:3
+ >=x11-libs/libwnck-3.14:3
+ x11-libs/libX11
+ >=xfce-base/exo-0.11:=
+ >=xfce-base/garcon-0.6:=
+ >=xfce-base/libxfce4ui-4.13:=
+ >=xfce-base/libxfce4util-4.13:=
+ >=xfce-base/xfconf-4.12.1:=
+ libnotify? ( >=x11-libs/libnotify-0.7:= )
+ thunar? ( >=xfce-base/thunar-1.7:= )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ $(use_enable thunar file-icons)
+ $(use_enable thunar thunarx)
+ $(use_enable libnotify notifications)
+ )
+
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}