summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-09-27 11:11:57 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-09-27 12:29:04 +0300
commit2168ed9a66472ddb40a65122db1be743f560057e (patch)
tree88e31973af25f0c21a8a69fee47eeecf73958cb1
parentdev-python/flufl-i18n: mark ALLARCHES (diff)
downloadgentoo-2168ed9a66472ddb40a65122db1be743f560057e.tar.gz
gentoo-2168ed9a66472ddb40a65122db1be743f560057e.tar.bz2
gentoo-2168ed9a66472ddb40a65122db1be743f560057e.zip
dev-python/nose2: enable py3.10
- cleanup dependencies - use more verbose testing - fix missing dep for doc generation - tests (and package itself) need coverage dep. Without it we get the same failure reported in the bug. - enable py3.10 Closes: https://bugs.gentoo.org/723576 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/nose2/nose2-0.10.0.ebuild26
1 files changed, 6 insertions, 20 deletions
diff --git a/dev-python/nose2/nose2-0.10.0.ebuild b/dev-python/nose2/nose2-0.10.0.ebuild
index 78d73e088364..868ec6bfc4c7 100644
--- a/dev-python/nose2/nose2-0.10.0.ebuild
+++ b/dev-python/nose2/nose2-0.10.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Next generation unittest with plugins"
@@ -13,29 +13,15 @@ SRC_URI="https://github.com/nose-devs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE="doc"
-# Failures need investigating
-RESTRICT="test"
-BDEPEND="
- doc? ( >=dev-python/sphinx-1.0.5 )
-"
-DEPEND="
+RDEPEND="
>=dev-python/coverage-4.4.1[${PYTHON_USEDEP}]
- >=dev-python/six-1.1[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
"
-RDEPEND="${DEPEND}"
-python_compile_all() {
- use doc && emake -C docs html
-}
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme
python_test() {
- "${PYTHON}" -m nose2.__main__ || die "tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
-
- distutils-r1_python_install_all
+ "${EPYTHON}" -m nose2.__main__ -vv || die "tests failed under ${EPYTHON}"
}