summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-18 11:43:05 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-18 13:17:34 +0200
commit21d1703827eec76298a00dd6f48c5643f476892c (patch)
treebc5ebac747bed623376156e2aba8dfe1c6e56731
parentdev-util/sysprof: bump to 3.24.1 (diff)
downloadgentoo-21d1703827eec76298a00dd6f48c5643f476892c.tar.gz
gentoo-21d1703827eec76298a00dd6f48c5643f476892c.tar.bz2
gentoo-21d1703827eec76298a00dd6f48c5643f476892c.zip
dev-ml/fmt: Bump to 0.8.3
Package-Manager: Portage-2.3.5, Repoman-2.3.2
-rw-r--r--dev-ml/fmt/Manifest1
-rw-r--r--dev-ml/fmt/fmt-0.8.3.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-ml/fmt/Manifest b/dev-ml/fmt/Manifest
index ba10cd5732d8..052475a9c1a1 100644
--- a/dev-ml/fmt/Manifest
+++ b/dev-ml/fmt/Manifest
@@ -1 +1,2 @@
DIST fmt-0.8.2.tbz 13668 SHA256 11a1b12037aea444b1ead54143bd0abde43752a57e1ac77dfeab98cac8f91808 SHA512 38f567a988176bb4628665e6f5e47dba4917a2f65310d222dcd7f14809a38fbd824e9ee05ba4de97a20aa2c57a813541c587c8c438b2ac1f93199dddaa441ae0 WHIRLPOOL 159c7d9dfe389707e6a566ae75c52cf4fb890d253c978baecb2ae9d93d03a06094e4e3098141bea9c6686143c53445449bc07bfec35922374cd3ae9774cccd98
+DIST fmt-0.8.3.tbz 13918 SHA256 b942f20b42d8e10812843995bfef504e7eae3f605908c2d00cd59cf91d5e3aec SHA512 9c63c9a3ae72e5d18041fc1ed03d36f4cdf66847aa960014e682bd7d576df516db9638d9d9df6fcfcaa863d243d37044c4f74dcf9e2518bd4ce6be0fa3994aea WHIRLPOOL 436d8248d6d2266f98ba353672d0c4b5b189a5b031ba69284004ec35d93e51bd2913343651611132dcc72bfe633e42754684c1d1f4ed39eaf34164283edd5011
diff --git a/dev-ml/fmt/fmt-0.8.3.ebuild b/dev-ml/fmt/fmt-0.8.3.ebuild
new file mode 100644
index 000000000000..8e0f58572e56
--- /dev/null
+++ b/dev-ml/fmt/fmt-0.8.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit findlib
+
+DESCRIPTION="Combinators to devise OCaml Format pretty-printing functions"
+HOMEPAGE="http://erratique.ch/software/fmt https://github.com/dbuenzli/fmt"
+SRC_URI="http://erratique.ch/software/fmt/releases/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="dev-ml/result:=[ocamlopt]
+ dev-lang/ocaml:=[ocamlopt]
+ dev-ml/uchar:=[ocamlopt]
+ dev-ml/cmdliner:=[ocamlopt]"
+DEPEND="${RDEPEND}
+ dev-ml/opam
+ >=dev-ml/topkg-0.9
+ dev-ml/ocamlbuild
+ dev-ml/findlib"
+
+src_compile() {
+ ocaml pkg/pkg.ml build --tests $(usex test 'true' 'false') || die
+}
+
+src_test() {
+ ocaml pkg/pkg.ml test || die
+}
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+ dodoc CHANGES.md README.md
+}