summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2015-08-10 14:30:15 -0500
committerWilliam Hubbs <williamh@gentoo.org>2015-08-10 14:30:15 -0500
commit21e43f18e43f1dfeef70d9c81cb6b84fcbd81774 (patch)
tree8e9f87512ba6a91a168ec0821db0510b523751e6
parentdev-go/go-eapache-queue: convert to use the go eclasses (diff)
downloadgentoo-21e43f18e43f1dfeef70d9c81cb6b84fcbd81774.tar.gz
gentoo-21e43f18e43f1dfeef70d9c81cb6b84fcbd81774.tar.bz2
gentoo-21e43f18e43f1dfeef70d9c81cb6b84fcbd81774.zip
dev-go/go-resiliency: convert to use go eclasses
-rw-r--r--dev-go/go-resiliency/go-resiliency-1.0.0.ebuild35
1 files changed, 1 insertions, 34 deletions
diff --git a/dev-go/go-resiliency/go-resiliency-1.0.0.ebuild b/dev-go/go-resiliency/go-resiliency-1.0.0.ebuild
index 3f06a6bdf2cd..ac53b2b8be62 100644
--- a/dev-go/go-resiliency/go-resiliency-1.0.0.ebuild
+++ b/dev-go/go-resiliency/go-resiliency-1.0.0.ebuild
@@ -12,6 +12,7 @@ if [[ ${PV} = *9999* ]]; then
else
KEYWORDS="~amd64"
SRC_URI="https://${EGO_SRC}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ inherit golang-vcs-snapshot
fi
inherit golang-build
@@ -22,37 +23,3 @@ SLOT="0/${PV}"
IUSE=""
DEPEND=""
RDEPEND=""
-
-if [[ ${PV} != *9999* ]]; then
-src_unpack() {
- local f
-
- for f in ${A}
- do
- case "${f}" in
- *.tar|*.tar.gz|*.tar.bz2|*.tar.xz)
- local destdir=${WORKDIR}/${P}/src/${EGO_SRC}
-
- debug-print "${FUNCNAME}: unpacking ${f} to ${destdir}"
-
- # XXX: check whether the directory structure inside is
- # fine? i.e. if the tarball has actually a parent dir.
- mkdir -p "${destdir}" || die
- tar -C "${destdir}" -x --strip-components 1 \
- -f "${DISTDIR}/${f}" || die
- ;;
- *)
- debug-print "${FUNCNAME}: falling back to unpack for ${f}"
-
- # fall back to the default method
- unpack "${f}"
- ;;
- esac
- done
-}
-fi
-
-src_install() {
- rm -rf src/${EGO_SRC}/.git* || die
- golang-build_src_install
-}