summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2017-12-18 19:00:30 +0100
committerThomas Deutschmann <whissi@gentoo.org>2017-12-18 19:15:09 +0100
commit21f375df742472e4e4fa17f58de3ba16a1aaa813 (patch)
tree025b7e1f142727fc0a5534a35487a10e95b32748
parentapp-i18n/man-pages-de: Remove old (diff)
downloadgentoo-21f375df742472e4e4fa17f58de3ba16a1aaa813.tar.gz
gentoo-21f375df742472e4e4fa17f58de3ba16a1aaa813.tar.bz2
gentoo-21f375df742472e4e4fa17f58de3ba16a1aaa813.zip
dev-libs/libfastjson: Bump to v0.99.8
Package-Manager: Portage-2.3.19, Repoman-2.3.6
-rw-r--r--dev-libs/libfastjson/Manifest1
-rw-r--r--dev-libs/libfastjson/libfastjson-0.99.8.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-libs/libfastjson/Manifest b/dev-libs/libfastjson/Manifest
index 8bf6f60cf18d..37f2f9c8f2d2 100644
--- a/dev-libs/libfastjson/Manifest
+++ b/dev-libs/libfastjson/Manifest
@@ -2,3 +2,4 @@ DIST libfastjson-0.99.2.tar.gz 366602 BLAKE2B 99674f5914974ba8c1df6cef5203c46de7
DIST libfastjson-0.99.4.tar.gz 424989 BLAKE2B c6c3c6ad81bf4363d70623be2171cffa9b169dc2c7139c097a934cfe97cff861dd7a6d6048702822e786ea7838c0fee6d80329ade1831249b47e54ef8ffacf5b SHA512 b38f01469021093f21b43550e7574d2bad7b57a28b62f27cb1d2a57e33d2cb29208d20d978bdebe5a82a9736dfcfd7ec0a0fa945762702f4389d69850c2cfeb3
DIST libfastjson-0.99.6.tar.gz 431066 BLAKE2B 0611e8998cf59d988ab75ddbb38b264266da141d088380986081206e7840f393797a47b4a23a32a947f7c720da907c8cb48b9886d6a673cd74f8ab4135392909 SHA512 b3b4a5ba959723ffbf8d8218c97c696ccbb781e8c2563ede6ffd7bcbdfcf75495deba5c2b8952c6c215b78dd9cfa728c95cf56bde9b1cfa7ebd6ba68b5b8f166
DIST libfastjson-0.99.7.tar.gz 433298 BLAKE2B a97bb7ee704cf0e6b669cb16ec382150df9831c48679c352efb0c9cd44abae040d1d4e48f257292b05be11298cbe9e6ddca7792183befec59552d5a92956806c SHA512 e33942dd90af1dffaf328d2db03951dcb7aabf4f7ed499116a5986516af6971a5e2a244a1a2a72d5ee6c496c9a27e7ace165fb0337706c649b1d97c8f0d2f75d
+DIST libfastjson-0.99.8.tar.gz 433819 BLAKE2B f988c01de8e7becc5a848825c18151fec2b80f81eb5b50e459b1a3bb535f5521fb63e9350eb133eb984f57f42c5f529220a0c9461eb4689e1421ad815c4c4d87 SHA512 1e7eb7eaae2c6ccb78b77ac883808e1d311b03bad083dc72ab7712765a2ed139accd762850d60f54c6fe0ad48c4385714818fd2c8ed76700ce3546e5aff1c823
diff --git a/dev-libs/libfastjson/libfastjson-0.99.8.ebuild b/dev-libs/libfastjson/libfastjson-0.99.8.ebuild
new file mode 100644
index 000000000000..684987488e61
--- /dev/null
+++ b/dev-libs/libfastjson/libfastjson-0.99.8.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit autotools
+
+DESCRIPTION="Fork of the json-c library, which is optimized for liblognorm processing"
+HOMEPAGE="http://www.rsyslog.com/tag/libfastjson/"
+SRC_URI="http://download.rsyslog.com/${PN}/${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0/4.2.0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~sparc ~x86"
+IUSE="static-libs"
+
+DEPEND=">=sys-devel/autoconf-archive-2015.02.04"
+RDEPEND=""
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-compile-warnings=yes
+ $(use_enable static-libs static)
+ --disable-rdrand
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ local DOCS=( AUTHORS ChangeLog )
+ default
+
+ find "${ED}"usr/lib* -name '*.la' -delete || die
+}