summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-15 02:40:12 +0000
committerSam James <sam@gentoo.org>2021-03-15 02:40:12 +0000
commit22413496c251e08a425785b4e83e6ce6587b3ce6 (patch)
treeec56e7c4033ca5fa8ac403ed8a7ec79a4b3e5a12
parentdev-python/aiosmtpd: mark ALLARCHES (diff)
downloadgentoo-22413496c251e08a425785b4e83e6ce6587b3ce6.tar.gz
gentoo-22413496c251e08a425785b4e83e6ce6587b3ce6.tar.bz2
gentoo-22413496c251e08a425785b4e83e6ce6587b3ce6.zip
dev-python/aiofiles: add 0.6.0
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-python/aiofiles/Manifest1
-rw-r--r--dev-python/aiofiles/aiofiles-0.6.0.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/aiofiles/Manifest b/dev-python/aiofiles/Manifest
index 2c0b011998d8..a54b334c38e2 100644
--- a/dev-python/aiofiles/Manifest
+++ b/dev-python/aiofiles/Manifest
@@ -1 +1,2 @@
DIST aiofiles-0.5.0.tar.gz 13332 BLAKE2B ccd044ce9fcd74b2a6419b4f0e9e3977086c9685741dbb734a7f9222ab96dca58b5330ad0d0cd9f10fce03ee123add7101825f047451344fc451c40a4352674e SHA512 89eb1af506bdf5f3f2e9c3afe90f17d521ada1cdeb449dcdc800d4faa4edc1c9ca93811915aa059d8c5a1b0a3aaa40231a46b3d041ca745e071628293bddf1b7
+DIST aiofiles-0.6.0.tar.gz 13585 BLAKE2B 4b81e8369f91b0406c9bd5025c4b5da91418dc810065f1979ec862299fd16976105b89282b22a3ae2e0151cc550c927524795d3c5d69c82809faeb4e16179b8d SHA512 2cf9e340eccfef3934bbd86338a235368b99a10e34526e8267232cef14b12e3d79d40350d82874841d5bf7fd0acf779b663288c57d150096f1275586d51583c4
diff --git a/dev-python/aiofiles/aiofiles-0.6.0.ebuild b/dev-python/aiofiles/aiofiles-0.6.0.ebuild
new file mode 100644
index 000000000000..abe5dc248060
--- /dev/null
+++ b/dev-python/aiofiles/aiofiles-0.6.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="File support for asyncio"
+HOMEPAGE="https://github.com/Tinche/aiofiles"
+SRC_URI="https://github.com/Tinche/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest