summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-03-10 17:44:37 +0100
committerThomas Deutschmann <whissi@gentoo.org>2020-03-10 17:45:27 +0100
commit22aa1d20b8c219facc5c051c4791b4b7b15b9ded (patch)
treebed7cd992e87c7c905352375c060a0f2dca2803a
parentwww-client/firefox: bump to v68.6.0 (diff)
downloadgentoo-22aa1d20b8c219facc5c051c4791b4b7b15b9ded.tar.gz
gentoo-22aa1d20b8c219facc5c051c4791b4b7b15b9ded.tar.bz2
gentoo-22aa1d20b8c219facc5c051c4791b4b7b15b9ded.zip
www-client/firefox: allow CLANG/LLVM slot 10
Package-Manager: Portage-2.3.91, Repoman-2.3.20 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-rw-r--r--www-client/firefox/firefox-68.6.0.ebuild20
-rw-r--r--www-client/firefox/firefox-74.0.ebuild11
2 files changed, 20 insertions, 11 deletions
diff --git a/www-client/firefox/firefox-68.6.0.ebuild b/www-client/firefox/firefox-68.6.0.ebuild
index 55cb0402f54e..3b50e7317723 100644
--- a/www-client/firefox/firefox-68.6.0.ebuild
+++ b/www-client/firefox/firefox-68.6.0.ebuild
@@ -38,7 +38,7 @@ if [[ "${PV}" == *_rc* ]]; then
MOZ_SRC_URI="${MOZ_HTTP_URI}/source/${PN}-${MOZ_PV}.source.tar.xz -> $P.tar.xz"
fi
-LLVM_MAX_SLOT=9
+LLVM_MAX_SLOT=10
inherit check-reqs eapi7-ver flag-o-matic toolchain-funcs eutils \
gnome2-utils llvm mozcoreconf-v6 pax-utils xdg-utils \
@@ -131,6 +131,15 @@ DEPEND="${CDEPEND}
sys-apps/findutils
|| (
(
+ sys-devel/clang:10
+ !clang? ( sys-devel/llvm:10 )
+ clang? (
+ =sys-devel/lld-10*
+ sys-devel/llvm:10[gold]
+ pgo? ( =sys-libs/compiler-rt-sanitizers-10*[profile] )
+ )
+ )
+ (
sys-devel/clang:9
!clang? ( sys-devel/llvm:9 )
clang? (
@@ -157,15 +166,6 @@ DEPEND="${CDEPEND}
pgo? ( =sys-libs/compiler-rt-sanitizers-7*[profile] )
)
)
- (
- sys-devel/clang:6
- !clang? ( sys-devel/llvm:6 )
- clang? (
- =sys-devel/lld-6*
- sys-devel/llvm:6[gold]
- pgo? ( =sys-libs/compiler-rt-sanitizers-6*[profile] )
- )
- )
)
pulseaudio? ( media-sound/pulseaudio )
>=virtual/rust-1.34.0
diff --git a/www-client/firefox/firefox-74.0.ebuild b/www-client/firefox/firefox-74.0.ebuild
index 3f9a0983c941..30bb87c2dd0b 100644
--- a/www-client/firefox/firefox-74.0.ebuild
+++ b/www-client/firefox/firefox-74.0.ebuild
@@ -38,7 +38,7 @@ if [[ "${PV}" == *_rc* ]]; then
MOZ_SRC_URI="${MOZ_HTTP_URI}/source/${PN}-${MOZ_PV}.source.tar.xz -> $P.tar.xz"
fi
-LLVM_MAX_SLOT=9
+LLVM_MAX_SLOT=10
inherit check-reqs eapi7-ver flag-o-matic toolchain-funcs eutils \
gnome2-utils llvm mozcoreconf-v6 pax-utils xdg-utils \
@@ -132,6 +132,15 @@ DEPEND="${CDEPEND}
sys-apps/findutils
|| (
(
+ sys-devel/clang:10
+ !clang? ( sys-devel/llvm:10 )
+ clang? (
+ =sys-devel/lld-10*
+ sys-devel/llvm:10[gold]
+ pgo? ( =sys-libs/compiler-rt-sanitizers-10*[profile] )
+ )
+ )
+ (
sys-devel/clang:9
!clang? ( sys-devel/llvm:9 )
clang? (