summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-06-18 21:23:06 +0200
committerMarek Szuba <marecki@gentoo.org>2020-06-18 21:27:09 +0200
commit22cceffb61a7dabca058068511f7242740d25e88 (patch)
tree2ab3a31abbd23e26b9eee620f8f46c07bdd22e6d
parentsys-devel/binutils: add USE=vanilla to skip live patches (diff)
downloadgentoo-22cceffb61a7dabca058068511f7242740d25e88.tar.gz
gentoo-22cceffb61a7dabca058068511f7242740d25e88.tar.bz2
gentoo-22cceffb61a7dabca058068511f7242740d25e88.zip
media-gfx/darktable: only test the toolchain if [[ ${MERGE_TYPE} != binary ]]
Again, not touching 2.6.2. Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--media-gfx/darktable/darktable-3.0.2-r1.ebuild18
-rw-r--r--media-gfx/darktable/darktable-3.0.2.ebuild18
-rw-r--r--media-gfx/darktable/darktable-9999.ebuild16
3 files changed, 29 insertions, 23 deletions
diff --git a/media-gfx/darktable/darktable-3.0.2-r1.ebuild b/media-gfx/darktable/darktable-3.0.2-r1.ebuild
index 56221e9d71d2..a27d9ec520c6 100644
--- a/media-gfx/darktable/darktable-3.0.2-r1.ebuild
+++ b/media-gfx/darktable/darktable-3.0.2-r1.ebuild
@@ -78,14 +78,16 @@ PATCHES=(
S="${WORKDIR}/${P/_/~}"
pkg_pretend() {
- # Bug #695658
- if tc-is-gcc; then
- test-flags-CC -floop-block &> /dev/null || \
- die "Please switch to a gcc version built with USE=graphite"
- fi
-
- if use openmp ; then
- tc-has-openmp || die "Please switch to an openmp compatible compiler"
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ # Bug #695658
+ if tc-is-gcc; then
+ test-flags-CC -floop-block &> /dev/null || \
+ die "Please switch to a gcc version built with USE=graphite"
+ fi
+
+ if use openmp ; then
+ tc-has-openmp || die "Please switch to an openmp compatible compiler"
+ fi
fi
}
diff --git a/media-gfx/darktable/darktable-3.0.2.ebuild b/media-gfx/darktable/darktable-3.0.2.ebuild
index a6af926b8350..1584653803c3 100644
--- a/media-gfx/darktable/darktable-3.0.2.ebuild
+++ b/media-gfx/darktable/darktable-3.0.2.ebuild
@@ -77,14 +77,16 @@ PATCHES=(
S="${WORKDIR}/${P/_/~}"
pkg_pretend() {
- # Bug #695658
- if tc-is-gcc; then
- test-flags-CC -floop-block &> /dev/null || \
- die "Please switch to a gcc version built with USE=graphite"
- fi
-
- if use openmp ; then
- tc-has-openmp || die "Please switch to an openmp compatible compiler"
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ # Bug #695658
+ if tc-is-gcc; then
+ test-flags-CC -floop-block &> /dev/null || \
+ die "Please switch to a gcc version built with USE=graphite"
+ fi
+
+ if use openmp ; then
+ tc-has-openmp || die "Please switch to an openmp compatible compiler"
+ fi
fi
}
diff --git a/media-gfx/darktable/darktable-9999.ebuild b/media-gfx/darktable/darktable-9999.ebuild
index 8efe45349c4c..422d45185bb7 100644
--- a/media-gfx/darktable/darktable-9999.ebuild
+++ b/media-gfx/darktable/darktable-9999.ebuild
@@ -69,14 +69,16 @@ PATCHES=(
)
pkg_pretend() {
- # Bug #695658
- if tc-is-gcc; then
- test-flags-CC -floop-block &> /dev/null || \
- die "Please switch to a gcc version built with USE=graphite"
- fi
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ # Bug #695658
+ if tc-is-gcc; then
+ test-flags-CC -floop-block &> /dev/null || \
+ die "Please switch to a gcc version built with USE=graphite"
+ fi
- if use openmp ; then
- tc-has-openmp || die "Please switch to an openmp compatible compiler"
+ if use openmp ; then
+ tc-has-openmp || die "Please switch to an openmp compatible compiler"
+ fi
fi
}