summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2017-12-27 16:31:55 -0800
committerRobin H. Johnson <robbat2@gentoo.org>2017-12-28 15:00:21 -0800
commit22f93ac5d1fbb5a500d13631a9abc7c8f3caf8cc (patch)
tree5ce71b0a982dd3877cd5a2ebff7b8c169432a2f7
parentdev-ruby/hiera-eyaml-plaintext: bump for ruby targets (diff)
downloadgentoo-22f93ac5d1fbb5a500d13631a9abc7c8f3caf8cc.tar.gz
gentoo-22f93ac5d1fbb5a500d13631a9abc7c8f3caf8cc.tar.bz2
gentoo-22f93ac5d1fbb5a500d13631a9abc7c8f3caf8cc.zip
dev-ruby/hiera-eyaml: bump for ruby targets
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> Package-Manager: Portage-2.3.16, Repoman-2.3.6
-rw-r--r--dev-ruby/hiera-eyaml/hiera-eyaml-2.1.0-r2.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-ruby/hiera-eyaml/hiera-eyaml-2.1.0-r2.ebuild b/dev-ruby/hiera-eyaml/hiera-eyaml-2.1.0-r2.ebuild
new file mode 100644
index 000000000000..007f7adf8e8e
--- /dev/null
+++ b/dev-ruby/hiera-eyaml/hiera-eyaml-2.1.0-r2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md CHANGES.md PLUGINS.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Encrypted YAML backend for hiera"
+HOMEPAGE="https://github.com/TomPoulton/hiera-eyaml"
+SRC_URI="https://github.com/TomPoulton/hiera-eyaml/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+ruby_add_rdepend ">=dev-ruby/highline-1.6.19"
+ruby_add_rdepend "dev-ruby/trollop:2"
+
+ruby_add_bdepend "test? ( dev-util/cucumber ~dev-util/aruba-0.6.2 app-admin/puppet dev-ruby/hiera-eyaml-plaintext )"
+
+all_ruby_prepare() {
+ # Fix highline dependency to be compatible with more versions.
+ sed -i -e '/highline/ s/~>/>=/' \
+ -e '/gem.files/d' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ sed -i -e 's:/tmp:'${T}':' \
+ features/sandbox/puppet/environments/local/modules/test/manifests/init.pp \
+ features/sandbox/puppet-hiera-merge/environments/local/modules/test/manifests/init.pp \
+ features/puppet.feature
+}
+
+each_ruby_prepare() {
+ # Run tests with the correct ruby interpreter
+ sed -i -e 's:I run `eyaml:I run `'${RUBY}' '${S}'/bin/eyaml:' features/*.feature || die
+
+}
+
+each_ruby_test() {
+ ${RUBY} -S cucumber --format progress features || die
+}