summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2021-10-04 00:36:39 +0300
committerMart Raudsepp <leio@gentoo.org>2021-10-04 00:41:28 +0300
commit23c5e2ab1154b82697e9701162c193f0b5fb27e1 (patch)
tree087e863e3dc27a052ede9447577050124299e1ed
parentapp-editors/vim-core: sync live (diff)
downloadgentoo-23c5e2ab1154b82697e9701162c193f0b5fb27e1.tar.gz
gentoo-23c5e2ab1154b82697e9701162c193f0b5fb27e1.tar.bz2
gentoo-23c5e2ab1154b82697e9701162c193f0b5fb27e1.zip
dev-util/devhelp: bump to 41.2
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
-rw-r--r--dev-util/devhelp/Manifest1
-rw-r--r--dev-util/devhelp/devhelp-41.2.ebuild83
-rw-r--r--dev-util/devhelp/files/41.2-optional-introspection.patch47
-rw-r--r--dev-util/devhelp/files/41.2-webkitgtk40.patch38
4 files changed, 169 insertions, 0 deletions
diff --git a/dev-util/devhelp/Manifest b/dev-util/devhelp/Manifest
index b3f2105aa476..189093efe28e 100644
--- a/dev-util/devhelp/Manifest
+++ b/dev-util/devhelp/Manifest
@@ -1,2 +1,3 @@
DIST devhelp-40.0.tar.xz 318076 BLAKE2B 05345f422e0ec906855c139306020165277daefea2c85229092be57c98f96459c33ab0fdf847a7135fa1b329c76edea71f7da0342c6673a828efe26298d26bdf SHA512 b8dd5fbb12558845f7f5794dad56ef0ffc1dbd60d5a6a28029dc8acea241e8deb1b68cd0abe9d620a512931a1c5f6db12fc594cd4597758c8d4904fb64e6ade7
DIST devhelp-40.1.tar.xz 318172 BLAKE2B 83f71b66538b700790961e3dd3c7c7a75199f499a1fb32eb01e62fd5d11e72ae4e860bcfab2615bd4d417d5c57b89dad7eb2f1de4930e39e544d42b57a193b97 SHA512 4c541db9a2222dce4064f401c1d0a9f3233e2dbab17206358dfcce360286f69698248d08172fb236a692b125d8cd3a5bb76b6377b01b52c3d096fa4528400acd
+DIST devhelp-41.2.tar.xz 1455736 BLAKE2B c531af6cded6c9624581e4d14fb4d7713afbdcf173ec2a82e49789af1752568790dc346cc0293eddc68c0943fec4f742de726953de34441771711a938ba858fa SHA512 99a75ff19bf1b4613c312921452f190334e3e2036c28cda070169e3d1d352a5d2e7a56a393326efd679076257412e281dc94b628429119fcad58060d1a88ea98
diff --git a/dev-util/devhelp/devhelp-41.2.ebuild b/dev-util/devhelp/devhelp-41.2.ebuild
new file mode 100644
index 000000000000..4657f906fe7b
--- /dev/null
+++ b/dev-util/devhelp/devhelp-41.2.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit gnome.org gnome2-utils meson python-single-r1 xdg
+
+DESCRIPTION="An API documentation browser for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Devhelp"
+
+LICENSE="GPL-3+ CC-BY-SA-4.0"
+SLOT="0/3-6" # subslot = 3-(libdevhelp-3 soname version)
+KEYWORDS="~amd64 ~arm ~ppc64 ~sparc ~x86"
+IUSE="+gedit gtk-doc +introspection"
+REQUIRED_USE="gedit? ( ${PYTHON_REQUIRED_USE} ) gtk-doc? ( introspection )"
+
+DEPEND="
+ >=dev-libs/glib-2.64:2
+ >=x11-libs/gtk+-3.22:3[introspection?]
+ >=net-libs/webkit-gtk-2.26:4[introspection?]
+ gnome-base/gsettings-desktop-schemas
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+RDEPEND="${DEPEND}
+ gedit? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ app-editors/gedit[introspection(+),python,${PYTHON_SINGLE_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ )
+"
+# libxml2 required for glib-compile-resources
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/libxml2:2
+ dev-util/glib-utils
+ dev-util/itstool
+ gtk-doc? ( >=dev-util/gi-docgen-2021.6 )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-optional-introspection.patch
+ "${FILESDIR}"/${PV}-webkitgtk40.patch
+)
+
+pkg_setup() {
+ use gedit && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dflatpak_build=false
+ $(meson_use gtk-doc gtk_doc)
+ $(meson_use introspection)
+ -Dplugin_emacs=true
+ $(meson_use gedit plugin_gedit)
+ -Dplugin_vim=true
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ if use gtk-doc; then
+ mkdir -p "${ED}"/usr/share/gtk-doc/html/ || die
+ mv "${ED}"/usr/share/doc/devhelp-3 "${ED}"/usr/share/gtk-doc/html/ || die
+ fi
+ use gedit && python_optimize "${ED}"/usr/$(get_libdir)/gedit/plugins
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}
diff --git a/dev-util/devhelp/files/41.2-optional-introspection.patch b/dev-util/devhelp/files/41.2-optional-introspection.patch
new file mode 100644
index 000000000000..7fb4e719cbff
--- /dev/null
+++ b/dev-util/devhelp/files/41.2-optional-introspection.patch
@@ -0,0 +1,47 @@
+From 0e2e1de8015abc77ead34e25d9822a183b1f214d Mon Sep 17 00:00:00 2001
+From: Mart Raudsepp <leio@gentoo.org>
+Date: Sun, 3 Oct 2021 23:51:25 +0300
+Subject: [PATCH] build: Add optionality for introspection build
+
+---
+ devhelp/meson.build | 2 ++
+ meson_options.txt | 6 ++++++
+ 2 files changed, 8 insertions(+)
+
+diff --git a/devhelp/meson.build b/devhelp/meson.build
+index 010e563f..fac15888 100644
+--- a/devhelp/meson.build
++++ b/devhelp/meson.build
+@@ -120,6 +120,7 @@ PKG_CONFIG.generate(
+ requires_private: LIBDEVHELP_PRIVATE_DEPS
+ )
+
++if get_option('introspection')
+ libdevhelp_gir = GNOME.generate_gir(
+ libdevhelp_shared_lib,
+ export_packages: 'libdevhelp-@0@'.format(LIBDEVHELP_API_VERSION_FULL),
+@@ -140,3 +141,4 @@ libdevhelp_gir = GNOME.generate_gir(
+ '--quiet',
+ ],
+ )
++endif
+diff --git a/meson_options.txt b/meson_options.txt
+index 17dc85f5..c69a2906 100644
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -10,6 +10,12 @@ option(
+ description: 'Build the API reference'
+ )
+
++option(
++ 'introspection',
++ type: 'boolean', value: true,
++ description: 'Build GObject Introspection data'
++)
++
+ option(
+ 'plugin_emacs',
+ type: 'boolean', value: false,
+--
+2.32.0
+
diff --git a/dev-util/devhelp/files/41.2-webkitgtk40.patch b/dev-util/devhelp/files/41.2-webkitgtk40.patch
new file mode 100644
index 000000000000..967d276bfa83
--- /dev/null
+++ b/dev-util/devhelp/files/41.2-webkitgtk40.patch
@@ -0,0 +1,38 @@
+From 7b0ef55edd63c71be209aa3b57e2190d4ce4fb90 Mon Sep 17 00:00:00 2001
+From: Mart Raudsepp <leio@gentoo.org>
+Date: Sun, 3 Oct 2021 23:52:27 +0300
+Subject: [PATCH] build: Don't automagically depend on webkit2gtk-4.1
+
+That's the libsoup3 using webkit-gtk SLOT that we don't have. Patch it out,
+so it wouldn't be picked up automagically once it's added or comes from some
+overlay.
+
+This reverts commit f9d52aad23914df9dcb404723d1c99cf7b4e1eca.
+---
+ meson.build | 7 +------
+ 1 file changed, 1 insertion(+), 6 deletions(-)
+
+diff --git a/meson.build b/meson.build
+index e57e466e..492aafed 100644
+--- a/meson.build
++++ b/meson.build
+@@ -46,15 +46,10 @@ lt_revision = 3
+ lt_age = 0
+ LIBDEVHELP_LT_VERSION = '@0@.@1@.@2@'.format(lt_current, lt_revision, lt_age)
+
+-webkit_dep = dependency('webkit2gtk-4.1', required : false)
+-if not webkit_dep.found()
+- webkit_dep = dependency('webkit2gtk-4.0')
+-endif
+-
+ LIBDEVHELP_PUBLIC_DEPS = [
+ dependency('gio-2.0', version: '>= 2.64'),
+ dependency('gtk+-3.0', version: '>= 3.22'),
+- webkit_dep,
++ dependency('webkit2gtk-4.0', version: '>= 2.26'),
+ ]
+ LIBDEVHELP_PRIVATE_DEPS = [
+ dependency('gsettings-desktop-schemas'),
+--
+2.32.0
+