summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-15 07:17:24 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-15 08:16:14 +0100
commit2425dcaa5285453e641255e11d2e3da0526ae59f (patch)
tree25e9503d12c4fa0f975cafc61fc133aea9e5cfe8
parentdev-python/botocore: Bump to 1.29.71 (diff)
downloadgentoo-2425dcaa5285453e641255e11d2e3da0526ae59f.tar.gz
gentoo-2425dcaa5285453e641255e11d2e3da0526ae59f.tar.bz2
gentoo-2425dcaa5285453e641255e11d2e3da0526ae59f.zip
dev-python/boto3: Bump to 1.26.71
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.26.71.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index c530a906e29a..0a9b03ea4f3f 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -2,3 +2,4 @@ DIST boto3-1.26.59.gh.tar.gz 594565 BLAKE2B 90c5fe950da7fabc46a4c34e0a77997cfc64
DIST boto3-1.26.64.gh.tar.gz 597913 BLAKE2B f3dc63388cf4055c58610eaf980c10ff4d297c6f00f89fe0b46e6b764fba502b7fd85b71421a9d21f1930b668f95aaf2fa174389e5067901d749babf582a8033 SHA512 17ed0e655706f29ed34e1d60a9913d74ab0098ba8085ea76bafb5fcd1bfde91c2efd95d2f3f3e6bcd1b6ef7bed85f9001ba484c01a0251219ea879543a8f2b47
DIST boto3-1.26.69.gh.tar.gz 600296 BLAKE2B 8c37d9c818e29617defed964271436be2ffa54f8a634661d6a9fc665d1b77a041d83bcba153d5c0dffe90c4185e0a163e9141880cd8147964f7ed479b975ecb2 SHA512 8635afb8c20c3534c36551eb6004676ebcee987836e494b8a67673ae16f4dee8d8efb83e632c6df2e0f07827965bcc9b8e72c159657ff72f1c9c1f52ccd49a16
DIST boto3-1.26.70.gh.tar.gz 600798 BLAKE2B b55125e70865f73b8ba5e7945eca6a975f47cf5e80ee876bb757adb72f611a2a18a33dbc619fe8f76c40e63cadaf5f6ea923c8310225b4f662c5c2e300aef375 SHA512 80961a68437a32cb0d7bbfd3e24942fa939d0e8a62884d525e4cea6cc9e152749b1481d0c8cc832ec26407cb2dc46a1a40eec81539e7c55c635c810c595108d5
+DIST boto3-1.26.71.gh.tar.gz 601272 BLAKE2B ca2feb8c8a733033338ae50a7a9bac3779afc233fbd8e55c75a1e9bb87e224c789d22b940b68e1f90405886cceef60f860c33f7d99a64b288a29f8377eaa8815 SHA512 ca4eeaa29f0d025a6e0d7e55680f8c6ca231cd8616a373ca60a84d51f271750b05640b71ea97bebd539e762efe7a714f86e1f3c142620996240df02ef7cfac48
diff --git a/dev-python/boto3/boto3-1.26.71.ebuild b/dev-python/boto3/boto3-1.26.71.ebuild
new file mode 100644
index 000000000000..9523f65d5fb9
--- /dev/null
+++ b/dev-python/boto3/boto3-1.26.71.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}