summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2022-02-02 00:38:00 +0300
committerMikle Kolyada <zlogene@gentoo.org>2022-02-02 00:38:51 +0300
commit24dac981edb5af5548a43c5d5d71a6f65148ec36 (patch)
treec189a8fc5c1dc2e1a93fd6344e1ea914a0c0808a
parentgames-util/higan-purify: treeclean (diff)
downloadgentoo-24dac981edb5af5548a43c5d5d71a6f65148ec36.tar.gz
gentoo-24dac981edb5af5548a43c5d5d71a6f65148ec36.tar.bz2
gentoo-24dac981edb5af5548a43c5d5d71a6f65148ec36.zip
sys-apps/pcsc-lite: Version bump (v1.9.5)
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
-rw-r--r--sys-apps/pcsc-lite/Manifest1
-rw-r--r--sys-apps/pcsc-lite/pcsc-lite-1.9.5.ebuild104
2 files changed, 105 insertions, 0 deletions
diff --git a/sys-apps/pcsc-lite/Manifest b/sys-apps/pcsc-lite/Manifest
index 0b748160b60f..3dcd4b4da5fc 100644
--- a/sys-apps/pcsc-lite/Manifest
+++ b/sys-apps/pcsc-lite/Manifest
@@ -1,3 +1,4 @@
DIST pcsc-lite-1.9.0.tar.bz2 755963 BLAKE2B 30d027ac61aba1f57224c88ffc4ec8568dcc2747f3f7e24be07e7ce52bd23ad7a71b6a2f78d912f827a4c02a22c13ff16bc1450c02bafd92bc87ac0e34a2bbcb SHA512 35c85b15ab54c14403a080d6671b3d986910372651d46a5477111172d42c6d2cf58f4a3ce95427e7a84f6b4d3bee30ea57bf69b855f753160a3c6e72f93e34f3
DIST pcsc-lite-1.9.1.tar.bz2 763525 BLAKE2B b85364f5e2a92450b020bfc28439774c6a6ffb9016ea4072d1925fbc1cef76cd370b298c0b414ba322205d859018308bd7101ef89c5b6f96b97e4f223035ac35 SHA512 4f59ea6acb5b258092018f10609987e12b8e601049e6ffed4b4b82abd3c4b35c38a60e1cda28fdc884202e694d1bc3a3b5d930c5b1e9c1b9c309bd17ef463e63
DIST pcsc-lite-1.9.4.tar.bz2 776581 BLAKE2B fb870fab3bfc7ae372a62c678a0321445f14c36c84c4fff8b7bf4e17f14b64575128fdcf7c8642cd03cb3586d6846845196a93d02b037090f49b88bbee896caa SHA512 d812fd4c6e906f277a73863c4170d96c30245c5fd0a8329e78923533320d71c6591b3f282695bcd69823c8cc381d8d438736bb7ab2262ab24c9d89434368659e
+DIST pcsc-lite-1.9.5.tar.bz2 775736 BLAKE2B 2e42fa3864ec68725f90338ae981c758328c3129278739bb7bd0e8d62f0cd984dfe2bc0268226614110833db7c0ba48f7c2cd3808a505d836e95cd9709938170 SHA512 0315c2cf97cc9da0f5faf115f24e523b5a1746cea250a4fe6c4d5d7b2fbfc7c3ea0f068611072ca84866c672eb679e8067101437573148ccd1ac5ad26b18cd78
diff --git a/sys-apps/pcsc-lite/pcsc-lite-1.9.5.ebuild b/sys-apps/pcsc-lite/pcsc-lite-1.9.5.ebuild
new file mode 100644
index 000000000000..0f45e4dc5bb1
--- /dev/null
+++ b/sys-apps/pcsc-lite/pcsc-lite-1.9.5.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python{3_8,3_9,3_10} )
+
+inherit python-single-r1 systemd udev multilib-minimal
+
+DESCRIPTION="PC/SC Architecture smartcard middleware library"
+HOMEPAGE="https://pcsclite.apdu.fr https://github.com/LudovicRousseau/PCSC"
+
+SRC_URI="https://pcsclite.apdu.fr/files/${P}.tar.bz2"
+
+# GPL-2 is there for the init script; everything else comes from
+# upstream.
+LICENSE="BSD ISC MIT GPL-3+ GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+# This is called libusb so that it doesn't fool people in thinking that
+# it is _required_ for USB support. Otherwise they'll disable udev and
+# that's going to be worse.
+IUSE="doc embedded libusb policykit selinux systemd +udev"
+
+REQUIRED_USE="^^ ( udev libusb ) ${PYTHON_REQUIRED_USE}"
+
+# No dependencies need the MULTILIB_DEPS because the libraries are actually
+# standalone, the deps are only needed for the daemon itself.
+DEPEND="libusb? ( virtual/libusb:1 )
+ udev? ( virtual/libudev:= )
+ policykit? ( >=sys-auth/polkit-0.111 )
+ acct-group/openct
+ acct-group/pcscd
+ acct-user/pcscd
+ ${PYTHON_DEPS}"
+
+RDEPEND="${DEPEND}
+ selinux? ( sec-policy/selinux-pcscd )"
+
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.8.11-polkit-pcscd.patch
+)
+
+DOCS=( AUTHORS HELP README SECURITY ChangeLog )
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ --disable-maintainer-mode \
+ --enable-usbdropdir="${EPREFIX}/usr/$(get_libdir)/readers/usb" \
+ --enable-ipcdir=/run/pcscd \
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)" \
+ $(use_enable doc documentation) \
+ $(multilib_native_use_enable embedded) \
+ $(multilib_native_use_enable systemd libsystemd) \
+ $(multilib_native_use_enable udev libudev) \
+ $(multilib_native_use_enable libusb) \
+ $(multilib_native_use_enable policykit polkit)
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ newinitd "${FILESDIR}"/pcscd-init.7 pcscd
+
+ if use udev; then
+ exeinto "$(get_udevdir)"
+ newexe "${FILESDIR}"/pcscd-udev pcscd.sh
+
+ insinto "$(get_udevdir)"/rules.d
+ newins "${FILESDIR}"/99-pcscd-hotplug-r1.rules 99-pcscd-hotplug.rules
+ fi
+
+ python_fix_shebang "${ED}"/usr/bin/pcsc-spy
+
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ elog "Starting from version 1.6.5, pcsc-lite will start as user nobody in"
+ elog "the pcscd group, to avoid running as root."
+ elog ""
+ elog "This also means you need the newest drivers available so that the"
+ elog "devices get the proper owner."
+ elog ""
+ elog "Furthermore, a conf.d file is no longer installed by default, as"
+ elog "the default configuration does not require one. If you need to"
+ elog "pass further options to pcscd, create a file and set the"
+ elog "EXTRA_OPTS variable."
+ elog ""
+ if use udev; then
+ elog "Hotplug support is provided by udev rules."
+ elog "When using OpenRC you additionally need to tell it to hotplug"
+ elog "pcscd by setting this variable in /etc/rc.conf:"
+ elog ""
+ elog " rc_hotplug=\"pcscd\""
+ fi
+}