summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-10-01 00:06:05 +0200
committerMichał Górny <mgorny@gentoo.org>2018-10-22 17:02:16 +0200
commit250ae4edac101ca41670e8a738072481a4722d6c (patch)
tree6e2273d8bb70ca12742b8cba90867c4abc96513e
parentnet-irc/irssi: revbump to fix libressl-2.7/2.8 bulding (diff)
downloadgentoo-250ae4edac101ca41670e8a738072481a4722d6c.tar.gz
gentoo-250ae4edac101ca41670e8a738072481a4722d6c.tar.bz2
gentoo-250ae4edac101ca41670e8a738072481a4722d6c.zip
app-portage/eix: Bump to 0.33.5
Closes: https://bugs.gentoo.org/667640 Closes: https://github.com/gentoo/gentoo/pull/10029 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-portage/eix/Manifest1
-rw-r--r--app-portage/eix/eix-0.33.5.ebuild109
2 files changed, 110 insertions, 0 deletions
diff --git a/app-portage/eix/Manifest b/app-portage/eix/Manifest
index 8ad89de180c4..e603e9a03773 100644
--- a/app-portage/eix/Manifest
+++ b/app-portage/eix/Manifest
@@ -1,3 +1,4 @@
DIST eix-0.32.9.tar.xz 599072 BLAKE2B 40fd86520e5c98e4a7cf6710fcd16ce685cc14fbafa417f6694134702b61b83d8d47cfc908c5621d77ba827f7449c985de7dc16650358a8ccad2ab4b48644e38 SHA512 1a7c3d5f371150f5990fe1f1c4cadb0e3ee0a5810011702904aabd58ca250c10f820d6c64e7182096e0b7e2aa001cf573c5f2e83499ceb350cc59b599ec2ca5b
DIST eix-0.33.0.tar.xz 610600 BLAKE2B 484d70c3efcceebf54f2a2e0af69b701716d6c6c45aa867a8cc372b135db29bb1bf23cf0efa6d3d2a19224255113229fa30cdd40ab4d64f226eafa73991daa96 SHA512 6fd4ca253ee908eb192ee35c4228bea0fa8a04030070b35489bddc639053c2e3f6a2faf32f539ffd2c7d9da0c664ff5f29ac0d732d9a47b6c9976a65dd402de2
DIST eix-0.33.2.tar.xz 614192 BLAKE2B dcbbdb9b9ccf6f780d89c791c34cc588700720b7f015fb0db7ea86dd78a383892266b0e96c49282fdea58e78293c69e8acc153cea631443c35d3ee29dd4c016f SHA512 28ca4cc57e5c7ef81feb37fa90d598e681e192c442c7446c93a442908d2a9744340f7a93c71135ec3083fb85c48a65638c8929b6e1e632464132f4320225d637
+DIST eix-0.33.5.tar.xz 626628 BLAKE2B 2bb102279084f6bb6871bb4bbe55100708866337501c6043508ee13bdb92064c3a4a41d067b9d4c03af1a5ffbece53d9c66cf89639adf0c555a9511cae3d702f SHA512 7a71a411d4428ee491b9aee0f414e038a08f2195db58466db9b96f0d80edca7eaa153e63534c832c71e1b488e21fbd869a96bd10a21e06a93ce7eba1f808b684
diff --git a/app-portage/eix/eix-0.33.5.ebuild b/app-portage/eix/eix-0.33.5.ebuild
new file mode 100644
index 000000000000..507d7acf722a
--- /dev/null
+++ b/app-portage/eix/eix-0.33.5.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools bash-completion-r1 flag-o-matic tmpfiles
+
+DESCRIPTION="Search and query ebuilds"
+HOMEPAGE="https://github.com/vaeth/eix/"
+SRC_URI="https://github.com/vaeth/eix/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="debug doc nls sqlite"
+
+BOTHDEPEND="nls? ( virtual/libintl )
+ sqlite? ( >=dev-db/sqlite-3:= )"
+RDEPEND="${BOTHDEPEND}
+ >=app-shells/push-2.0-r1
+ >=app-shells/quoter-3.0_p2-r1"
+DEPEND="${BOTHDEPEND}
+ app-arch/xz-utils
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ # remove stale cache file to prevent collisions
+ local old_cache=${EROOT%/}/var/cache/${PN}
+ if [[ -f ${old_cache} ]]; then
+ rm "${old_cache}" || die
+ fi
+}
+
+src_prepare() {
+ default
+ sed -i -e "s:/:${EPREFIX}/:" tmpfiles.d/eix.conf || die
+
+ sed -e "/eixf_source=/s:push.sh:cat \"${EROOT}usr/share/push/push.sh\":" \
+ -e "/eixf_source=/s:quoter_pipe.sh:cat \"${EROOT}usr/share/quoter/quoter_pipe.sh\":" \
+ -i src/eix-functions.sh.in || die
+ sed -e "s:'\$(bindir)/eix-functions.sh':cat \\\\\"${EROOT}usr/share/eix/eix-functions\\\\\":" \
+ -i src/Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ $(use_enable debug paranoic-asserts)
+ $(use_enable nls)
+ $(use_with doc extra-doc)
+ $(use_with sqlite)
+
+ # default configuration
+ $(use_with prefix always-accept-keywords)
+ --with-dep-default
+ --with-required-use-default
+
+ # paths
+ --with-portage-rootpath="${ROOTPATH}"
+ --with-eprefix-default="${EPREFIX}"
+
+ # build a single executable with symlinks
+ --disable-separate-binaries
+ --disable-separate-tools
+
+ # used purely to control/disrespect *FLAGS
+ --disable-debugging
+ --disable-new_dialect
+ --disable-optimization
+ --disable-strong-optimization
+ --disable-security
+ --disable-nopie-security
+ --disable-strong-security
+ )
+
+ # https://github.com/vaeth/eix/issues/35
+ append-cxxflags -std=c++14
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ dobashcomp bash/eix
+ dotmpfiles tmpfiles.d/eix.conf
+
+ rm -r "${ED%/}"/usr/bin/eix-functions.sh || die
+
+ keepdir /var/cache/eix
+}
+
+pkg_postinst() {
+ if ! use prefix; then
+ # note: if this is done in src_install(), portage:portage
+ # ownership may be reset to root
+ tmpfiles_process eix.conf
+ fi
+
+ local obs=${EROOT%/}/var/cache/eix.previous
+ if [[ -f ${obs} ]]; then
+ ewarn "Found obsolete ${obs}, please remove it"
+ fi
+}
+
+pkg_postrm() {
+ if [[ ! -n ${REPLACED_BY_VERSION} ]]; then
+ rm -rf "${EROOT%/}/var/cache/${PN}" || die
+ fi
+}