summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2018-09-11 08:54:59 -0400
committerAaron W. Swenson <titanofold@gentoo.org>2018-09-11 08:54:59 -0400
commit251b0e8b14855c89fc579536774198fbcf0dda63 (patch)
treee3be519314a00a6718a76760cddb865936bd0d09
parentnet-libs/nodejs: Old. (diff)
downloadgentoo-251b0e8b14855c89fc579536774198fbcf0dda63.tar.gz
gentoo-251b0e8b14855c89fc579536774198fbcf0dda63.tar.bz2
gentoo-251b0e8b14855c89fc579536774198fbcf0dda63.zip
sci-libs/geos: Bump to 3.7.0
Package-Manager: Portage-2.3.40, Repoman-2.3.9
-rw-r--r--sci-libs/geos/Manifest1
-rw-r--r--sci-libs/geos/geos-3.7.0.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/sci-libs/geos/Manifest b/sci-libs/geos/Manifest
index 2d2fa32b75e4..352df3624216 100644
--- a/sci-libs/geos/Manifest
+++ b/sci-libs/geos/Manifest
@@ -1 +1,2 @@
DIST geos-3.6.2.tar.bz2 2030705 BLAKE2B f23cf1fc080fb7b353fb6292900d84811ace04a5364200bfea19f79d7b09a795d36e30cd6e4dbb7acd8417245bc2ce644298dc1b4140ef70495e4f7d71fc522b SHA512 515d8700b8a28282678e481faee355e3a43d7b70160472a63335b8d7225d9ba10437be782378f18f31a15288118126d411a2d862f01ce35d27c96f6bc0a73016
+DIST geos-3.7.0.tar.bz2 2028814 BLAKE2B 17385d9be831d4812391a30627e13989d3ca099ca9b0a719a92cdb2503dadff3693d4b3d320652764185db05782b33760ca14d155365d87167bb4ef6d6c2463c SHA512 fcca5e503efa32bb388376b2a06b9ca5c74fbcddba750cce6b3b4109eb2eb122058aead12b9462cdd881f425cd75d7241645ab344f25ce022bc0659954560742
diff --git a/sci-libs/geos/geos-3.7.0.ebuild b/sci-libs/geos/geos-3.7.0.ebuild
new file mode 100644
index 000000000000..230e09c56c97
--- /dev/null
+++ b/sci-libs/geos/geos-3.7.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1
+
+DESCRIPTION="Geometry engine library for Geographic Information Systems"
+HOMEPAGE="http://trac.osgeo.org/geos/"
+SRC_URI="http://download.osgeo.org/geos/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris"
+IUSE="doc python ruby static-libs"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ python? ( ${PYTHON_DEPS} )
+ ruby? ( dev-lang/ruby:* )
+"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ python? ( dev-lang/swig:0 )
+ ruby? ( dev-lang/swig:0 )
+"
+
+PATCHES=( "${FILESDIR}"/3.4.2-solaris-isnan.patch )
+
+RESTRICT="test"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ echo "#!${EPREFIX}/bin/bash" > py-compile
+}
+
+src_configure() {
+ econf \
+ $(use_enable python) \
+ $(use_enable ruby) \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ default
+ use doc && emake -C "${S}/doc" doxygen-html
+}
+
+src_install() {
+ use doc && HTML_DOCS=( doc/doxygen_docs/html/. )
+ default
+ use python && python_optimize "${D}$(python_get_sitedir)"/geos/
+
+ find "${D}" -name '*.la' -delete || die
+}