summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2022-12-21 11:05:41 +0100
committerFlorian Schmaus <flow@gentoo.org>2022-12-21 11:07:02 +0100
commit2558ddaebc75727e79645d718aa3bb7113941e9d (patch)
tree67983a2d15d2f0d2a39380b6f822a79e1a57121a
parentx11-wm/marco: drop 1.24.2 (diff)
downloadgentoo-2558ddaebc75727e79645d718aa3bb7113941e9d.tar.gz
gentoo-2558ddaebc75727e79645d718aa3bb7113941e9d.tar.bz2
gentoo-2558ddaebc75727e79645d718aa3bb7113941e9d.zip
x11-misc/xsnow: install xscreensaver hack
Signed-off-by: Florian Schmaus <flow@gentoo.org>
-rw-r--r--x11-misc/xsnow/xsnow-3.6.0-r1.ebuild (renamed from x11-misc/xsnow/xsnow-3.6.0.ebuild)14
1 files changed, 14 insertions, 0 deletions
diff --git a/x11-misc/xsnow/xsnow-3.6.0.ebuild b/x11-misc/xsnow/xsnow-3.6.0-r1.ebuild
index c8462ed48e95..b1390bb2529c 100644
--- a/x11-misc/xsnow/xsnow-3.6.0.ebuild
+++ b/x11-misc/xsnow/xsnow-3.6.0-r1.ebuild
@@ -38,3 +38,17 @@ src_prepare() {
default
eautoreconf
}
+
+src_install() {
+ default
+
+ # Install xscreensaver hack, which calls xsnow with the correct
+ # arguments. xscreensaver calls all hacks with --root, however xsnow
+ # only understands -root and will exit with an error if an unknown
+ # argument (--root) is provided.
+ exeinto usr/$(get_libdir)/misc/xscreensaver
+ newexe - xsnow <<-EOF
+ #/usr/bin/env bash
+ exec "${EPREFIX}/usr/bin/xsnow" -nomenu -root
+EOF
+}