summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWANG Xuerui <xen0n@gentoo.org>2023-01-16 14:37:43 +0800
committerWANG Xuerui <xen0n@gentoo.org>2023-01-16 14:37:43 +0800
commit258a8abc6dcae426fab29c81044a4d938d455d9a (patch)
tree839d33cb8167e251ce5cf2b23067d9437ca7f48c
parentsys-fs/erofs-utils: stabilize 1.5 for amd64 (diff)
downloadgentoo-258a8abc6dcae426fab29c81044a4d938d455d9a.tar.gz
gentoo-258a8abc6dcae426fab29c81044a4d938d455d9a.tar.bz2
gentoo-258a8abc6dcae426fab29c81044a4d938d455d9a.zip
sys-fs/erofs-utils: add 1.5-r1, add support for USE=lzma
Signed-off-by: WANG Xuerui <xen0n@gentoo.org>
-rw-r--r--sys-fs/erofs-utils/erofs-utils-1.5-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/sys-fs/erofs-utils/erofs-utils-1.5-r1.ebuild b/sys-fs/erofs-utils/erofs-utils-1.5-r1.ebuild
new file mode 100644
index 000000000000..bae100e2e3a3
--- /dev/null
+++ b/sys-fs/erofs-utils/erofs-utils-1.5-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Userspace tools for EROFS"
+HOMEPAGE="https://git.kernel.org/pub/scm/linux/kernel/git/xiang/erofs-utils.git"
+LICENSE="GPL-2+"
+
+SRC_URI="https://git.kernel.org/pub/scm/linux/kernel/git/xiang/${PN}.git/snapshot/${P}.tar.gz"
+KEYWORDS="~amd64 ~loong"
+
+SLOT="0"
+IUSE="fuse +lz4 +lzma selinux +uuid"
+
+RDEPEND="
+ fuse? ( sys-fs/fuse:0 )
+ lz4? ( app-arch/lz4:0= )
+ lzma? ( >=app-arch/xz-utils-5.4.0:0= )
+ selinux? ( sys-libs/libselinux:0= )
+ uuid? ( sys-apps/util-linux )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-werror
+ $(use_enable fuse)
+ $(use_enable lz4)
+ $(use_enable lzma)
+ $(use_with selinux)
+ $(use_with uuid)
+ )
+
+ econf "${myeconfargs[@]}"
+}