summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz@gentoo.org>2024-09-03 17:23:01 -0400
committerEli Schwartz <eschwartz@gentoo.org>2024-09-05 00:07:44 -0400
commit25c2cc32eaa4dee3d227ffb0665a1f1ac83c9249 (patch)
tree80bf34cb87b2bc8fcb0474bc271cca7e7ed74d8c
parentsci-libs/coinor-dylp: make sure to run elibtoolize, drop .la files (diff)
downloadgentoo-25c2cc32eaa4dee3d227ffb0665a1f1ac83c9249.tar.gz
gentoo-25c2cc32eaa4dee3d227ffb0665a1f1ac83c9249.tar.bz2
gentoo-25c2cc32eaa4dee3d227ffb0665a1f1ac83c9249.zip
sci-libs/coinor-dylp: mark as LTO-unsafe
It fails to compile correctly, tests fail, and the resulting library fails to link when other packages try to use it. The reason is because it checks for a SunOS symbol using an ancient autotools version that relies on UB to detect whether it exists, then tries to link to it. Upgrading autotools is complicated and the software is deprecated and in maintenance mode, so no telling when it may be released. There are commits in git master to update it but they are intermingled with updating to unreleased dependency versions? Closes: https://bugs.gentoo.org/862696 Closes: https://bugs.gentoo.org/878141 Closes: https://bugs.gentoo.org/878143 Signed-off-by: Eli Schwartz <eschwartz@gentoo.org>
-rw-r--r--sci-libs/coinor-dylp/coinor-dylp-1.10.4-r1.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/sci-libs/coinor-dylp/coinor-dylp-1.10.4-r1.ebuild b/sci-libs/coinor-dylp/coinor-dylp-1.10.4-r1.ebuild
index 2fb4758ebad7..35272e786648 100644
--- a/sci-libs/coinor-dylp/coinor-dylp-1.10.4-r1.ebuild
+++ b/sci-libs/coinor-dylp/coinor-dylp-1.10.4-r1.ebuild
@@ -5,7 +5,7 @@ EAPI=8
MY_PN=DyLP
-inherit libtool
+inherit flag-o-matic libtool
DESCRIPTION="COIN-OR dynamic simplex linear program solver"
HOMEPAGE="https://github.com/coin-or/DyLP/"
@@ -49,6 +49,11 @@ src_prepare() {
}
src_configure() {
+ # heavily vintage autotools relies on UB to detect SunOS
+ # https://bugs.gentoo.org/878143
+ # https://github.com/coin-or/DyLP/issues/27
+ filter-lto
+
local myeconfargs=(
--enable-dependency-linking
--with-coin-instdir="${ED}"/usr