summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-05-01 11:35:33 +0200
committerPacho Ramos <pacho@gentoo.org>2018-05-01 21:31:42 +0200
commit273d211a2c23c704aec973b4b8b74cd4e791008d (patch)
tree31385a308bf3778bbcb8022f5bd51be4873375cb
parentgames-fps/worldofpadman: Drop old (diff)
downloadgentoo-273d211a2c23c704aec973b4b8b74cd4e791008d.tar.gz
gentoo-273d211a2c23c704aec973b4b8b74cd4e791008d.tar.bz2
gentoo-273d211a2c23c704aec973b4b8b74cd4e791008d.zip
games-kids/memonix: Stop using games.eclass
Package-Manager: Portage-2.3.31, Repoman-2.3.9
-rw-r--r--games-kids/memonix/memonix-1.6-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/games-kids/memonix/memonix-1.6-r1.ebuild b/games-kids/memonix/memonix-1.6-r1.ebuild
new file mode 100644
index 000000000000..72187823716e
--- /dev/null
+++ b/games-kids/memonix/memonix-1.6-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit cmake-utils eutils
+
+DESCRIPTION="Brain teasers, puzzle and memory games for kid's in one pack"
+HOMEPAGE="http://www.viewizard.com/memonix/"
+SRC_URI="http://www.viewizard.com/download/${PN}_${PV}_src.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ media-libs/libsdl:0[sound,opengl,video,X]
+ media-libs/sdl-image[jpeg]
+ media-libs/sdl-mixer[vorbis]
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/MemonixSourceCode"
+
+src_install() {
+ exeinto /usr/"$(get_libdir)"
+ doexe ../${P}_build/Memonix
+
+ insinto "/usr/share/${PN}"
+ doins ../gamedata.vfs
+
+ make_wrapper ${PN} /usr/"$(get_libdir)"/Memonix /usr/share/${PN}
+
+ newicon ../icon48.png ${PN}.png
+ make_desktop_entry ${PN}
+
+ dodoc ReadMe.txt
+}