summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2020-06-03 22:31:43 +0200
committerPatrice Clement <monsieurp@gentoo.org>2020-06-03 22:54:05 +0200
commit2771878d049c1715202d3c23c84ff647325d03c6 (patch)
tree86ece56ae3487d3f02a11c05f4d6697ab9781b16
parentapp-misc/ttyload: honor CC, CFLAGS and LDFLAGS. (diff)
downloadgentoo-2771878d049c1715202d3c23c84ff647325d03c6.tar.gz
gentoo-2771878d049c1715202d3c23c84ff647325d03c6.tar.bz2
gentoo-2771878d049c1715202d3c23c84ff647325d03c6.zip
net-misc/spiped: honor CC, CFLAGS and LDFLAGS.
Closes: https://bugs.gentoo.org/725230 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
-rw-r--r--net-misc/spiped/spiped-1.6.0-r1.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/net-misc/spiped/spiped-1.6.0-r1.ebuild b/net-misc/spiped/spiped-1.6.0-r1.ebuild
index b3ab508eb627..7820531c9cd9 100644
--- a/net-misc/spiped/spiped-1.6.0-r1.ebuild
+++ b/net-misc/spiped/spiped-1.6.0-r1.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+inherit toolchain-funcs
+
DESCRIPTION="secure pipe daemon"
HOMEPAGE="http://www.tarsnap.com/spiped.html"
SRC_URI="http://www.tarsnap.com/${PN}/${P}.tgz"
@@ -23,6 +25,10 @@ RDEPEND="
${DEPEND}
!net-mail/qlogtools"
+src_compile() {
+ emake CC=$(tc-getCC) CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
src_install() {
dobin "${MY_PN}/${MY_PN}"
dosbin "${PN}/${PN}"