summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-18 09:46:13 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-18 09:46:41 +0100
commit27a71a9bf8be06af918654196f325d58cb67f45f (patch)
tree55ac70cb12eb265f0df58f2e351fe3f6d41c3cda
parentdev-python/pillow: Keyword 9.0.0-r1 alpha, #831270 (diff)
downloadgentoo-27a71a9bf8be06af918654196f325d58cb67f45f.tar.gz
gentoo-27a71a9bf8be06af918654196f325d58cb67f45f.tar.bz2
gentoo-27a71a9bf8be06af918654196f325d58cb67f45f.zip
dev-python/installer: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/installer/Manifest1
-rw-r--r--dev-python/installer/installer-0.4.0.ebuild47
2 files changed, 0 insertions, 48 deletions
diff --git a/dev-python/installer/Manifest b/dev-python/installer/Manifest
index c8357cc23f43..def27fbb1e8f 100644
--- a/dev-python/installer/Manifest
+++ b/dev-python/installer/Manifest
@@ -1,4 +1,3 @@
DIST installer-0.4.0-py2.py3-none-any.whl.zip 451433 BLAKE2B 933b7e63b3d0306213789d493d4df112df26b432d63ecd1f8f21449520c34bd2ad542aac25069043fbb535c44f988dca927625eafd0a5a20489fc3ce2bcf84a2 SHA512 cf303bb422e329a36007b361034144a232ba021d4013bb8678dc7c326544e74ec9a3b3fe8b9d3696433dbbe90d2ce4a0ae8967fb054bd5ed49321d470be729a8
-DIST installer-0.4.0.gh.tar.gz 466643 BLAKE2B 635854b3461995cda3b7afa507ca3fe35cae8210e79de0bbd46938c8f103d7840ceca8bb388c2c9533efc78150691f980c478485ee33bafe0bae6c08a6aef8c4 SHA512 13537c479bc8ead8f8b45c8e5c5182e8b1b32c2889df8015be7f517f390a9efbea6fa167e0886dfade6621a8a2d822bfd662ee0238d3d86689619ca4d5483b26
DIST installer-0.4.0_p20220115-cli.patch 14552 BLAKE2B 6632c1472ae0a578f6c7ed0acf1bb0d89ece924626b68c0daa28d9a7d93826837adaf6b0d40f048c4f5c2986b4328ca565340137e7b7fa7f407f62ebddc70275 SHA512 f8c6369955e0bde2bff0b935c39748d02659bc6ca0341af405e2c1026cf145479ba0b908bd769cdc05f3cc920f881b894b6a5eb7ace643951e05250ec0486b80
DIST installer-0.4.0_p20220115.gh.tar.gz 466532 BLAKE2B 6dea3f4bacb52c4983e111d420495ee157076342a823b7062c6e5b3e4d3b70e6b2e9cb024d0c7baba6f88ed70f4303ab071d1882bc9d8dd0726f82a3e406056f SHA512 fbb0d4c8642fa2cbe2fd3be2eef7044a0353f04c67ecce20aafed33a0d7877ff55872ca5ad51390ae7e02cdb7af5dbd57b662085b60d425be95da6643b061eaa
diff --git a/dev-python/installer/installer-0.4.0.ebuild b/dev-python/installer/installer-0.4.0.ebuild
deleted file mode 100644
index fb0baf656345..000000000000
--- a/dev-python/installer/installer-0.4.0.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_SETUPTOOLS=manual
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-inherit distutils-r1
-
-DESCRIPTION="A library for installing Python wheels"
-HOMEPAGE="
- https://pypi.org/project/installer/
- https://github.com/pradyunsg/installer/
- https://installer.readthedocs.io/en/latest/
-"
-SRC_URI="
- https://github.com/pradyunsg/installer/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
- https://files.pythonhosted.org/packages/py2.py3/${PN::1}/${PN}/${P}-py2.py3-none-any.whl
- -> ${P}-py2.py3-none-any.whl.zip
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-
-# NB: newer git doesn't use mock anymore
-BDEPEND="
- app-arch/unzip
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-# do not use any build system to avoid circular deps
-python_compile() { :; }
-
-python_test() {
- local -x PYTHONPATH=src
- epytest
-}
-
-python_install() {
- python_domodule src/installer "${WORKDIR}"/*.dist-info
-}