summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-29 06:10:07 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-29 06:58:33 +0200
commit27ba0b62663cbfcfdaa11110abdd7880f8424f4f (patch)
tree068fc726554714a62d2cc5f0d3f7c61bdc08e236
parentdev-python/botocore: Bump to 1.29.123 (diff)
downloadgentoo-27ba0b62663cbfcfdaa11110abdd7880f8424f4f.tar.gz
gentoo-27ba0b62663cbfcfdaa11110abdd7880f8424f4f.tar.bz2
gentoo-27ba0b62663cbfcfdaa11110abdd7880f8424f4f.zip
dev-python/boto3: Bump to 1.26.123
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.26.123.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 7e27385f7aba..032919a30d6a 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -4,3 +4,4 @@ DIST boto3-1.26.119.gh.tar.gz 640125 BLAKE2B c2a1e954c09b4322d6d369205a11013e5b8
DIST boto3-1.26.120.gh.tar.gz 639240 BLAKE2B 835fb02e44ccdb7d2b7aa2604d3605db9efa454ca455a52e67861b218523acc6737260c9d860639195a4d4181f4be9eaab0acf2b80e33416274cd99d65a74c80 SHA512 426aed9ba45cdc0d584fa0a571104b6f17dfb32c78da17a85b0dbe9f6c77c84a70533b4affa4728758a9d3a339d5d72b54186eb08dc2bd319b3d1e75374adbd0
DIST boto3-1.26.121.gh.tar.gz 639340 BLAKE2B 3f8224aa4659d6b0581ce1b6f48367f15ba6d69520462251c5ee88922afa8af661471ad5058ea54bf75871081dce5feec027050f09222f63168362e3db05dcd1 SHA512 d0e4ada1ddd1198d1d964cb2c4a629c72f7931d35b27d8a0c71c04d605b750b725e31b3713047df817b3b12ad090e33e8b3ece650e0a87041261df5534ce4a90
DIST boto3-1.26.122.gh.tar.gz 640221 BLAKE2B dce152282f7639e162dbfe1e83335de9d42297ba46d9b11e3048ae6a2e8f201e865c1f64e0a927656a4c61d916e803165fbde35214cabe4e538fc21fea66ff6a SHA512 884e0e0cc18d2d03a9d3b52ce006ed322c972a02ffa6c370dd53df879950e5e7ac1c1b55e0d9261024396ad8ef864b1d7148a75ac3734ea26d5f9a490a1184d5
+DIST boto3-1.26.123.gh.tar.gz 640741 BLAKE2B a4d46a9995ce2c496a1cc0a4f9835474546a2a3b2252793cb80ad08e879afc3b69cc3bd6d6661d52c9812e9bec3f7dc66e5bfeae7761cd1a2f122762abf1f247 SHA512 2640c057a7beda8bafb5aa59af387d368bbf04f9e7a8bbe2ca5fd3adb82eb0480ba3e0b2580331a057ede010a6945397cf056fac210aced4a7c981dfa96c4e85
diff --git a/dev-python/boto3/boto3-1.26.123.ebuild b/dev-python/boto3/boto3-1.26.123.ebuild
new file mode 100644
index 000000000000..2a4a7643203e
--- /dev/null
+++ b/dev-python/boto3/boto3-1.26.123.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}