summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-27 07:59:52 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-27 09:00:17 +0200
commit27d46460c7cc26ffb0642f8cd55b31ae4503c390 (patch)
tree3ffc3e05416bbef2aa09a35648d6818c7ad25380
parentdev-python/diskcache: Bump to 5.0.2 (diff)
downloadgentoo-27d46460c7cc26ffb0642f8cd55b31ae4503c390.tar.gz
gentoo-27d46460c7cc26ffb0642f8cd55b31ae4503c390.tar.bz2
gentoo-27d46460c7cc26ffb0642f8cd55b31ae4503c390.zip
dev-python/pytest-mock: Bump to 3.3.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pytest-mock/Manifest1
-rw-r--r--dev-python/pytest-mock/pytest-mock-3.3.1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pytest-mock/Manifest b/dev-python/pytest-mock/Manifest
index 26f81da22ca0..3291def45692 100644
--- a/dev-python/pytest-mock/Manifest
+++ b/dev-python/pytest-mock/Manifest
@@ -2,3 +2,4 @@ DIST pytest-mock-1.11.2.tar.gz 22825 BLAKE2B d6843d1cb1afc0d5a242103ec4900d56418
DIST pytest-mock-2.0.0.tar.gz 24665 BLAKE2B 31a3464e8bff5a2109716e95492ce1d59f2555769e69cccf4012bc268f88c5eeca99924006bdc78cc5e20cf227860d845bead9656aba1c081da58effb38ea100 SHA512 8bd7f634afebeae628470270c81f0198647bf8cd5b0fac438891d881d9823e40e814d598670bb9c9722b864990958e69d385c7c6a6e2adc81d2adcb303fbe0b0
DIST pytest-mock-3.2.0.tar.gz 25569 BLAKE2B e6a1ab23142cf3d7ac9385ac221bfce680c7b982cb489306557b60ca81563718cb9b7fcbb149cccb2cf6f06de5c3fa737d28b0711a3197fbbc86e432c5f4e614 SHA512 1ff442e26339ac41414a8678303fbc7eab573964661c664ef029c3b3377df4ab40173976316ef99e49dd208dc1e3c7cd0a0090f5453865343090cc9439f85fa9
DIST pytest-mock-3.3.0.tar.gz 27139 BLAKE2B bd7295b00ef78f6a4c73eb732faa3573c668bf95884a23c6753d6674f082cbcc565e84c5598e6015c60323f6fba2b3d344c63009c353c5db84ade2b339d83970 SHA512 6ce63495e326101942d1808fe937547cca781dccbdf0845a6a70bb7c990f443ae16f870169c9c8c32084cf6d8ce7cd17f74f90504bd505a7f916c9376b75ac5a
+DIST pytest-mock-3.3.1.tar.gz 27551 BLAKE2B 9e3602b988c0e27caa295d42d7400cbe7e3e30392511e662fa6ec16ec9fa4ef776d3e64b63b0345d1b520f753c6776103f507f91f0bad022544bfccc510b7e6b SHA512 ffd53974f82f725cf3bdbe750c1deb568ad1a12a67532eca93ff28d80b1cbcd8ebf709985f5473717c9d54345b251c1627c0567821e9e8b9e102db5c16cf7421
diff --git a/dev-python/pytest-mock/pytest-mock-3.3.1.ebuild b/dev-python/pytest-mock/pytest-mock-3.3.1.ebuild
new file mode 100644
index 000000000000..a646df8a08aa
--- /dev/null
+++ b/dev-python/pytest-mock/pytest-mock-3.3.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Thin-wrapper around the mock package for easier use with pytest"
+HOMEPAGE="https://github.com/pytest-dev/pytest-mock/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/pytest-5[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ if has_version dev-python/mock; then
+ # test fails when standalone mock is installed
+ sed -e 's|^\(def \)\(test_standalone_mock(\)|\1_\2|' -i tests/test_pytest_mock.py || die
+ fi
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ distutils_install_for_testing
+ pytest --assert=plain -vv || die "Tests fail with ${EPYTHON}"
+}