summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-10-08 13:49:18 -0500
committerTim Harder <radhermit@gentoo.org>2017-10-08 13:49:18 -0500
commit27fad63ca57936fe78fb6baaa1825dc4b08e6159 (patch)
treeddc84ad15304b79f1d7b39673428c71d0b03c700
parentnet-mail/getmail: version bump to 5.4 (diff)
downloadgentoo-27fad63ca57936fe78fb6baaa1825dc4b08e6159.tar.gz
gentoo-27fad63ca57936fe78fb6baaa1825dc4b08e6159.tar.bz2
gentoo-27fad63ca57936fe78fb6baaa1825dc4b08e6159.zip
net-mail/offlineimap: version bump to 7.1.3
-rw-r--r--net-mail/offlineimap/Manifest1
-rw-r--r--net-mail/offlineimap/offlineimap-7.1.3.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/net-mail/offlineimap/Manifest b/net-mail/offlineimap/Manifest
index d96bb6d35502..39fa94eaa4a9 100644
--- a/net-mail/offlineimap/Manifest
+++ b/net-mail/offlineimap/Manifest
@@ -4,3 +4,4 @@ DIST offlineimap-7.0.14.tar.gz 698081 SHA256 19494ecad4d7234ac69480abb7462d0cdcf
DIST offlineimap-7.1.0.tar.gz 698600 SHA256 dc998d1032f0e4f944cae0e584a146b70ea732422fc52c909eebe6e8f95b1ae4 SHA512 9e9d5ea2b58dc212c9b69adb701fb4cd1ac1a7c8af90623dcfba3115ee7e1f63cc8569c352bae8f1fe09eb8c9255c39d0bf947dfb5d683ee4b03c0c822cb192d WHIRLPOOL dbf33188c790b43e4b7756a1be6c1c7950bb192e079ba729a8ec159fb3d07a505e5892dc08b2cf8b7b55e2d3dc998f74354339e1c8ed6d3a0e190a5e904bbfdc
DIST offlineimap-7.1.1.tar.gz 701776 SHA256 a624f8a77eae664dd458be47c5306c28911d4a1f788ff5641d7bb37e01ecb703 SHA512 a04a8bdbd2b22f8b74681707faa4fcd768a11abd4eeab1e3b6fd7e7851d97c5c7f7db56c7e7e4809a7cb661a357c38941ea320d9bcb0fc509b3f79b223a0c602 WHIRLPOOL 8fe84b4cd82c5e9d8816b4dce6aafae88ad718375927f6aa7cd08fd9b010ea0550a420045ad8f0c376102a0926c1c9ff404802b528d20cf3bf2587ab508f247d
DIST offlineimap-7.1.2.tar.gz 708014 SHA256 7203435e34f73e90d1833b72c49a859decf7b5828384a2648ee4b2d1ef3bdc66 SHA512 14bf6c561ad9cde72f71651970b98380139a016b689c75ed150027f8b71d9f1a646f6738e8fd74d6328103b25c17985ac494d9929568f90bb4be37b71a4de22d WHIRLPOOL 961dcdf759266f90a9f1831ef8b2b85457488bbd75fd548d4ba43a8c8be7df3c62a3dd5fea7874c21882cd58a5697ab2faac4f70661f322b48445591634ca9ac
+DIST offlineimap-7.1.3.tar.gz 710766 SHA256 02fc106904ddeb3fb64b3e17d3838ed2223e5ade0018900751b1ba8111b45f45 SHA512 bf24be740b0e7607a1b53df7e872b5dd4b4c720601d99bd88a7ac8add078e5512b62b18c12177e28a00f510aaa8a48e25be82decfdd7ae2da76b671d44071e4a WHIRLPOOL 5a676d6e8ccf887c4a8d903ae969144d42d6652ed85327fcc2fc27c260f41bbdbd03d4d0e8dbc91b20908d1ae409d6d7d0aa847a6eed037237915c5ca2acb3a9
diff --git a/net-mail/offlineimap/offlineimap-7.1.3.ebuild b/net-mail/offlineimap/offlineimap-7.1.3.ebuild
new file mode 100644
index 000000000000..3258d1bf16b5
--- /dev/null
+++ b/net-mail/offlineimap/offlineimap-7.1.3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# Normally you need only one version of this.
+DISTUTILS_SINGLE_IMPL=1
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="threads,sqlite,ssl?"
+
+inherit distutils-r1
+
+DESCRIPTION="Powerful IMAP/Maildir synchronization and reader support"
+HOMEPAGE="http://offlineimap.org"
+SRC_URI="https://github.com/OfflineIMAP/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc ssl"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="doc? ( app-text/asciidoc )"
+
+# see http://pogma.com/2009/09/09/snow-leopard-and-offlineimap/ and bug 284925
+PATCHES=(
+ "${FILESDIR}/${PN}-7.0.3-darwin10.patch"
+)
+
+src_compile() {
+ distutils-r1_src_compile
+ use doc && emake -C docs man
+}
+
+src_install() {
+ distutils-r1_src_install
+ dodoc offlineimap.conf offlineimap.conf.minimal
+ use doc && doman docs/{offlineimap.1,offlineimapui.7}
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "You will need to configure offlineimap by creating ~/.offlineimaprc"
+ elog "Sample configurations are in /usr/share/doc/${PF}/"
+ elog ""
+ elog "If you connect via ssl/tls and don't use CA cert checking, it will"
+ elog "display the server's cert fingerprint and require you to add it to the"
+ elog "configuration file to be sure it connects to the same server every"
+ elog "time. This serves to help fixing CVE-2010-4532 (offlineimap doesn't"
+ elog "check SSL server certificate) in cases where you have no CA cert."
+ fi
+}