summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2022-12-03 01:28:55 +0100
committerLouis Sautier <sbraz@gentoo.org>2022-12-03 01:31:59 +0100
commit2808d34525c885edc18ad281d0cdc8cf5010176b (patch)
treea5813ad6bbc60ae895efa29a588604addee268e9
parentwww-apps/airdcpp-webui: add 2.11.4, drop 2.11.3 (diff)
downloadgentoo-2808d34525c885edc18ad281d0cdc8cf5010176b.tar.gz
gentoo-2808d34525c885edc18ad281d0cdc8cf5010176b.tar.bz2
gentoo-2808d34525c885edc18ad281d0cdc8cf5010176b.zip
net-p2p/airdcpp-webclient: add 2.11.3
Signed-off-by: Louis Sautier <sbraz@gentoo.org>
-rw-r--r--net-p2p/airdcpp-webclient/Manifest1
-rw-r--r--net-p2p/airdcpp-webclient/airdcpp-webclient-2.11.3.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/net-p2p/airdcpp-webclient/Manifest b/net-p2p/airdcpp-webclient/Manifest
index 83e81d7f5062..cb381b8e41a5 100644
--- a/net-p2p/airdcpp-webclient/Manifest
+++ b/net-p2p/airdcpp-webclient/Manifest
@@ -1 +1,2 @@
DIST airdcpp-webclient-2.11.2.tar.gz 978294 BLAKE2B cb15e02dc5381cc5f0ecb1b4d65cdd1c4a3d007f3ea1e78a159b8a62af03831318b8f6d8c0692c5a9145dda616627ea97f4bd3eeb1270a7452c7d78bf01d147f SHA512 281d4a9da88f23a4c02eef7f09c4fc2c91c44ac93d932ea4bfe097029b45dbd12a8d04d4ef8b493d261f5dade15b62ed4d564197fbfb2d9d98b9dfcc9a9e6379
+DIST airdcpp-webclient-2.11.3.tar.gz 957277 BLAKE2B fd80433e6c8138c4f60758e4813a056a59586b4f51048a7b717114781fa7b11e5ef0a4cf4fee8441bce6bebc3889acd0ae597c07850da50776454d9ba8230f19 SHA512 59b6189021411fdd3c75ec4744fdb03eb6e6b39b08c1ca9da9519998546a5be5218b4ff2eea7f2d3894fd9146693e807d2cc2396f0f03c074f45cbb4403fe326
diff --git a/net-p2p/airdcpp-webclient/airdcpp-webclient-2.11.3.ebuild b/net-p2p/airdcpp-webclient/airdcpp-webclient-2.11.3.ebuild
new file mode 100644
index 000000000000..51a43500c666
--- /dev/null
+++ b/net-p2p/airdcpp-webclient/airdcpp-webclient-2.11.3.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit cmake python-any-r1 systemd
+
+DESCRIPTION="Cross-platform Direct Connect client"
+HOMEPAGE="https://airdcpp-web.github.io/"
+SRC_URI="https://github.com/airdcpp-web/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~riscv ~x86"
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="debug nat-pmp +tbb +webui"
+
+RDEPEND="
+ acct-user/airdcppd
+ acct-group/airdcppd
+ app-arch/bzip2
+ dev-cpp/websocketpp
+ dev-libs/boost:=
+ dev-libs/leveldb:=
+ dev-libs/libmaxminddb:=
+ dev-libs/openssl:0=[-bindist(-)]
+ net-libs/miniupnpc:=
+ sys-libs/zlib
+ virtual/libiconv
+ nat-pmp? ( net-libs/libnatpmp:= )
+ tbb? ( dev-cpp/tbb:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ ${PYTHON_DEPS}
+"
+PDEPEND="webui? ( www-apps/airdcpp-webui )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_NATPMP=$(usex nat-pmp)
+ -DENABLE_TBB=$(usex tbb)
+ -DINSTALL_WEB_UI=OFF
+ )
+ CMAKE_BUILD_TYPE=$(usex debug Debug Gentoo) cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ newconfd "${FILESDIR}/airdcppd.confd" airdcppd
+ newinitd "${FILESDIR}/airdcppd.initd" airdcppd
+ systemd_dounit "${FILESDIR}/airdcppd.service"
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "Run 'airdcppd --configure' to set up ports and authentication"
+ fi
+}