summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Whyman <thev00d00@gentoo.org>2021-04-11 13:05:35 +0100
committerIan Whyman <thev00d00@gentoo.org>2021-04-11 13:05:49 +0100
commit2827da221de1ce426c9f905a2f9d7568885a0c57 (patch)
treefcd253de3936accb55c1311a9203c91904c4719e
parentprofiles/updates: Shove old pyicu rename under the carpet (diff)
downloadgentoo-2827da221de1ce426c9f905a2f9d7568885a0c57.tar.gz
gentoo-2827da221de1ce426c9f905a2f9d7568885a0c57.tar.bz2
gentoo-2827da221de1ce426c9f905a2f9d7568885a0c57.zip
net-libs/libupnp: Bump to 1.14.5
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Ian Whyman <thev00d00@gentoo.org>
-rw-r--r--net-libs/libupnp/Manifest1
-rw-r--r--net-libs/libupnp/libupnp-1.14.5.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/net-libs/libupnp/Manifest b/net-libs/libupnp/Manifest
index d18c6a3add9a..36e481b9fef5 100644
--- a/net-libs/libupnp/Manifest
+++ b/net-libs/libupnp/Manifest
@@ -1 +1,2 @@
DIST libupnp-1.14.0.tar.gz 788668 BLAKE2B 8e77f49c6eacbaff2d4194f281f73e882d282b1af400b2d8e08111b7cb0b89305f3f06b8e0ebdf8eab35de39bcd2cd30be3ecb575d560c652e96bd7831eade40 SHA512 d7cf50e168aff2ef3ad08b4c383108d5044e4c9d2923088bb93423ee5fc555c32f0254f307cb86ea7c18197612cf2d2c6c681f82d99a6f01a68f86a21c6eecb7
+DIST libupnp-1.14.5.tar.gz 782662 BLAKE2B 7b1a4f115d4fb545b26909d8f6feb0a017160876506f35a5932a0898e68104eb43d92f82872359bc7bccf27a05d41632296041bb450e8109758a0ff6b7dd8e58 SHA512 6a1587943fb76b860fa879b050ae46189cb9c6a514df3f00eefe8c3eaa268aa5c0307895b38cac22fac57a2918b925ecefde7c46b7c50f87cfcf86afd9ee180d
diff --git a/net-libs/libupnp/libupnp-1.14.5.ebuild b/net-libs/libupnp/libupnp-1.14.5.ebuild
new file mode 100644
index 000000000000..4d8eccaa915d
--- /dev/null
+++ b/net-libs/libupnp/libupnp-1.14.5.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic
+
+MY_PN="pupnp"
+
+DESCRIPTION="An Portable Open Source UPnP Development Kit"
+HOMEPAGE="http://pupnp.sourceforge.net/"
+SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/17"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux"
+IUSE="blocking-tcp debug doc ipv6 +reuseaddr samples static-libs"
+
+# bug 733750
+RESTRICT="test"
+
+DOCS="ChangeLog"
+
+S="${WORKDIR}/${MY_PN}-release-${PV}"
+
+src_prepare() {
+ default
+
+ # fix tests
+ chmod +x ixml/test/test_document.sh || die
+
+ eautoreconf
+}
+
+src_configure() {
+ use x86-fbsd && append-flags -O1
+ # w/o docdir to avoid sandbox violations
+ econf $(use_enable debug) \
+ $(use_enable blocking-tcp blocking-tcp-connections) \
+ $(use_enable ipv6) \
+ $(use_enable reuseaddr) \
+ $(use_enable static-libs static) \
+ $(use_enable samples)
+}
+
+src_install() {
+ default
+
+ if ! use static-libs ; then
+ find "${D}" -name '*.la' -delete || die
+ fi
+}