summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2020-07-08 14:10:26 +0300
committerSergey Popov <pinkbyte@gentoo.org>2020-07-08 14:12:06 +0300
commit287a7f706de2e53aafc0d81ef53639f35421ae8e (patch)
tree99fa5470c1f443ae433b3c43e65af9bb544fb263
parentnet-misc/yandex-disk: cleanup metadata.xml (diff)
downloadgentoo-287a7f706de2e53aafc0d81ef53639f35421ae8e.tar.gz
gentoo-287a7f706de2e53aafc0d81ef53639f35421ae8e.tar.bz2
gentoo-287a7f706de2e53aafc0d81ef53639f35421ae8e.zip
net-misc/yandex-disk: version bump
Fix QA warnings about precompressed manpages Reported-by: Agostino Sarubbo <ago@gentoo.org> Closes: https://bugs.gentoo.org/731684 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Sergey Popov <pinkbyte@gentoo.org>
-rw-r--r--net-misc/yandex-disk/Manifest2
-rw-r--r--net-misc/yandex-disk/yandex-disk-0.1.5.1039_p1.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/net-misc/yandex-disk/Manifest b/net-misc/yandex-disk/Manifest
index 1856f997aa63..97ee1d329704 100644
--- a/net-misc/yandex-disk/Manifest
+++ b/net-misc/yandex-disk/Manifest
@@ -1,2 +1,4 @@
+DIST yandex-disk-0.1.5.1039-1.fedora.i386.rpm 4556176 BLAKE2B 5ade043c21a13e678ca11b3074fb1392b99f461ef5a7bd7205b3d6ea984b20dec0ba086adb8b881eaf52888f04cf371dd63ce73432c3f82f31c895e03f31f073 SHA512 3c323e6aaa5fa669ef7efa80e4b899cd732a6b29235d81f635dce67d0ff59dafd01da8d9ea7b040242882f0e5e153f7cd623f4b993dfc390bc0a18d2811c1719
+DIST yandex-disk-0.1.5.1039-1.fedora.x86_64.rpm 4743384 BLAKE2B 626a7e921567640b88d33fd426cc230bb92846a252b0960c51da9367f300b8622104db14c8788749e0f5cb484dffd9c9407994568449be769c24d2730cd0936a SHA512 9128d59f426de44b8c953d61ad07ffe886b5e864c5f20ba7ab1a69a47ab3269e5d4e39f4b92675f0ccaea43db1711184892a5e3178694bc453bc96e932045fa9
DIST yandex-disk-0.1.5.978-1.fedora.i386.rpm 4353188 BLAKE2B 5d82bf72cf670754c6889e1b7f4c99c47426fe938f7131381bf06d1bb6d5e98d403d746b336624f958a75839fb0c73982b14ba86d4d3db581286ace31fac48f7 SHA512 59008f42463185fab2aed221b44283e57c279ef7fd0966732dc3b6a3f474104f2ca676d77e7d958f53bff38aac9c0f7ea82b25202fd9da5f0de62bb56a983319
DIST yandex-disk-0.1.5.978-1.fedora.x86_64.rpm 4534132 BLAKE2B 1e39bf6a9dab9c6d7bf1960214c23a9196347d7d757e014b22cd37a598f479e2576346ad1d38bc8986f7a1b30529db0e0e58b0fc20f51d4abcbdac028759678c SHA512 d4f22bf008767289abf95237aa86ae27b33b99c62ba89381c4ed73a510d8096c169c1c215274133cc7fdf885fb7d629e758cea5925f4afc5acf7b6d688bf0078
diff --git a/net-misc/yandex-disk/yandex-disk-0.1.5.1039_p1.ebuild b/net-misc/yandex-disk/yandex-disk-0.1.5.1039_p1.ebuild
new file mode 100644
index 000000000000..c7d82a5568d6
--- /dev/null
+++ b/net-misc/yandex-disk/yandex-disk-0.1.5.1039_p1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1 eutils rpm
+
+MY_P="${PN}-${PV/_p/-}"
+
+DESCRIPTION="CLI to access Yandex Disk file storage service"
+HOMEPAGE="https://disk.yandex.ru"
+SRC_URI="
+ amd64? ( https://repo.yandex.ru/yandex-disk/rpm/stable/x86_64/${MY_P}.fedora.x86_64.rpm )
+ x86? ( https://repo.yandex.ru/yandex-disk/rpm/stable/i386/${MY_P}.fedora.i386.rpm )
+"
+
+LICENSE="YDSLA"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+
+DEPEND="app-arch/gzip"
+RDEPEND="sys-libs/zlib"
+
+S="${WORKDIR}"
+
+QA_PREBUILT="opt/bin/yandex-disk"
+
+src_prepare() {
+ # bug #526312
+ sed -i \
+ -e '/have /d' \
+ -e 's/+o nospace/-o nospace/' \
+ -e '/^complete/s/-X //' \
+ etc/bash_completion.d/yandex-disk-completion.bash || die
+
+ # Uncompress man pages to prevent QA warnings, bug #731684
+ find usr/share/man -type f -name *.gz | xargs gunzip
+
+ eapply_user
+}
+
+src_install() {
+ exeinto /opt/bin
+ doexe usr/bin/yandex-disk
+ newbashcomp etc/bash_completion.d/yandex-disk-completion.bash "${PN}"
+ insinto /usr/share/man
+ doins -r usr/share/man/*
+ insinto /usr/share
+ doins -r usr/share/locale
+}