summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Laurantin <olivier.laurantin@laposte.net>2021-05-22 09:26:29 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-06-10 11:13:14 +0300
commit28eb9e592f7d8b96a7926e5db7a2a2cd751bf3ae (patch)
tree66851b5414cf837c02ac5208361823403b561114
parentnet-im/toxic: Bump to version 0.10.1 (diff)
downloadgentoo-28eb9e592f7d8b96a7926e5db7a2a2cd751bf3ae.tar.gz
gentoo-28eb9e592f7d8b96a7926e5db7a2a2cd751bf3ae.tar.bz2
gentoo-28eb9e592f7d8b96a7926e5db7a2a2cd751bf3ae.zip
net-wireless/blueberry: version bump to 1.4.2
Update to latest upstream version Add python 3.9 compatibility Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Olivier Laurantin <olivier.laurantin@laposte.net> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--net-wireless/blueberry/Manifest1
-rw-r--r--net-wireless/blueberry/blueberry-1.4.2.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/net-wireless/blueberry/Manifest b/net-wireless/blueberry/Manifest
index 7fc8166e5e64..84150d05c506 100644
--- a/net-wireless/blueberry/Manifest
+++ b/net-wireless/blueberry/Manifest
@@ -1 +1,2 @@
DIST blueberry-1.3.9.tar.gz 1411969 BLAKE2B 2a11b12428166dce5dbeb00cc3813e9dea96b61891456622833400f7a9bb69a61317e9d6bdc862edce2c39f64fd04950dc793724338cb266ae365b1d10abee49 SHA512 7ee5e33daf0ce3b41bc3827042aa14ed4de1b58f862e76a50934d6beae79bf7e68b657461370da2e309d15c7ff858c8fb18aa7e891e7bc70e70c171884c5bb57
+DIST blueberry-1.4.2.tar.gz 1414169 BLAKE2B cd55e2bb572efb2badeab1667324df67c35f5833c53755c76c0793c07e8427c7d4714135014dad90aeaddc806c798f2b89960a051a15f668d214bb95cc0943e3 SHA512 5c2fb94e842cd1229682305f0054061724b958406ea15a64495ca418aa7da73c38b45ddc43c27a193aef995ab860cad985e3369e3dac53d2098463e6e4250493
diff --git a/net-wireless/blueberry/blueberry-1.4.2.ebuild b/net-wireless/blueberry/blueberry-1.4.2.ebuild
new file mode 100644
index 000000000000..b028a7305853
--- /dev/null
+++ b/net-wireless/blueberry/blueberry-1.4.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit gnome2-utils python-single-r1 xdg-utils
+
+DESCRIPTION="A Bluetooth configuration tool"
+HOMEPAGE="https://github.com/linuxmint/blueberry"
+SRC_URI="https://github.com/linuxmint/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/dbus-python[${PYTHON_MULTI_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
+ dev-python/setproctitle[${PYTHON_MULTI_USEDEP}]
+ dev-python/xapp[${PYTHON_MULTI_USEDEP}]
+ ')
+ >=net-wireless/gnome-bluetooth-3.14[introspection]
+ net-wireless/bluez[obex]
+ net-wireless/bluez-tools
+ || (
+ >=sys-apps/util-linux-2.31_rc1
+ net-wireless/rfkill
+ )
+ x11-libs/libnotify[introspection]
+ x11-misc/wmctrl"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ python_fix_shebang usr/lib
+}
+
+src_install() {
+ doins -r etc
+ exeinto /usr/bin
+ doexe usr/bin/*
+ exeinto /usr/lib/blueberry
+ doexe usr/lib/blueberry/*
+ insinto /usr
+ doins -r usr/share
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+ xdg_icon_cache_update
+}