summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Davies <jpds@protonmail.com>2021-03-18 00:26:05 +0000
committerJason Zaman <perfinion@gentoo.org>2021-04-02 21:15:28 -0700
commit290a68c7ccea5267f465691b82b6552e13a8aa37 (patch)
tree0a3d56b2ed001f7d387eb4fa47eba28d0358bad9
parentsys-apps/selinux-python: Sync live ebuild. (diff)
downloadgentoo-290a68c7ccea5267f465691b82b6552e13a8aa37.tar.gz
gentoo-290a68c7ccea5267f465691b82b6552e13a8aa37.tar.bz2
gentoo-290a68c7ccea5267f465691b82b6552e13a8aa37.zip
sys-apps/semodule-utils: Version updated to 3.2.
Signed-off-by: Jonathan Davies <jpds@protonmail.com> Signed-off-by: Jason Zaman <perfinion@gentoo.org>
-rw-r--r--sys-apps/semodule-utils/Manifest1
-rw-r--r--sys-apps/semodule-utils/semodule-utils-3.2.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/sys-apps/semodule-utils/Manifest b/sys-apps/semodule-utils/Manifest
index 3d5fa71f4b31..278c76d9d880 100644
--- a/sys-apps/semodule-utils/Manifest
+++ b/sys-apps/semodule-utils/Manifest
@@ -1 +1,2 @@
DIST semodule-utils-3.1.tar.gz 14257 BLAKE2B c8c9a1ce7c9c4f53b1f4c728d16b149fdc284f4cff8b4fce0cb59b77d37d6d7e9bf2102c7177c4eaf94677af6147e42d8d0bd55c0bf3a358968d0162d5a6c65a SHA512 b92794bbfbce5834ee7f62fddb40b5506e9291e8fa7c5d669b2e281089b8f8dc40c4522ea287ac5deffdaee751442ba8e691e2ac45fdd378b60d5d6b2527d157
+DIST semodule-utils-3.2.tar.gz 14260 BLAKE2B 35c071c96071028d4a912a89b88d02672f1fb8c2d8d23c3cb472b607dad55acdf351ef870b4d52bb2bed7b816a199c18947afcd16e77b66268822288feb4af2a SHA512 f937647cc22f7ed719908bad64415d706fd97cf1dce484dbca2484b05b3295de40e31bec643b6caaf4e8be742b1f911428d393c5e2d1d0ae39a2a37fd3be9bc1
diff --git a/sys-apps/semodule-utils/semodule-utils-3.2.ebuild b/sys-apps/semodule-utils/semodule-utils-3.2.ebuild
new file mode 100644
index 000000000000..13fc0d86279e
--- /dev/null
+++ b/sys-apps/semodule-utils/semodule-utils-3.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit toolchain-funcs
+
+IUSE=""
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
+ S="${WORKDIR}/${P}/${PN}"
+else
+ SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
+fi
+
+DESCRIPTION="SELinux policy module utilities"
+HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=">=sys-libs/libsepol-${PV}:="
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ sed -i 's/-Werror//g' "${S}"/*/Makefile || die "Failed to remove Werror"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+}