summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2020-04-29 20:54:38 +0700
committerAndrey Grozin <grozin@gentoo.org>2020-04-29 20:54:38 +0700
commit292fb8972973b470847dcbf5b5d685ae4cee0cd5 (patch)
treebc9baf1b93e7dff571d1836b8e97de14b7eb0313
parentprofiles: cleanup (diff)
downloadgentoo-292fb8972973b470847dcbf5b5d685ae4cee0cd5.tar.gz
gentoo-292fb8972973b470847dcbf5b5d685ae4cee0cd5.tar.bz2
gentoo-292fb8972973b470847dcbf5b5d685ae4cee0cd5.zip
media-gfx/asymptote: bump to 2.65
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
-rw-r--r--media-gfx/asymptote/Manifest1
-rw-r--r--media-gfx/asymptote/asymptote-2.65.ebuild211
-rw-r--r--media-gfx/asymptote/files/asymptote-2.65-info.patch13
-rw-r--r--media-gfx/asymptote/files/asymptote-2.65-xdg-utils.patch22
4 files changed, 247 insertions, 0 deletions
diff --git a/media-gfx/asymptote/Manifest b/media-gfx/asymptote/Manifest
index 2d2db83edac3..59b62e428be4 100644
--- a/media-gfx/asymptote/Manifest
+++ b/media-gfx/asymptote/Manifest
@@ -1,2 +1,3 @@
DIST asymptote-2.61.src.tgz 4623504 BLAKE2B 8432f07ce21f630c5bdae609650c0bb2bcd237a121df68030dc19d1cae986f0bfa56dd0e241570809f9fcb202440e8b9b3c6d47a22eeaabe3eb9523360a166ca SHA512 34bb610360b4536da70ca9edf1e069ebbf0c9225948b92b3d59ea25e8684587364fa7bbb03909ba02617e6ee81d41a2e530c9ed639141e4cda42096143cab5f7
DIST asymptote-2.62.src.tgz 4625853 BLAKE2B 49a5c75f936149139576cc224b005e76d2465a6c813bcb152f2534e98e042685c1500eafb0954b9e53ac0e667b47ab88a8b3387f1627d58828008d0e4d4cc0c8 SHA512 f7e817cdbb3c079a10c5f6f56a1eb47b1aaf8230902c06870bc8feacfed5f7af3d8ed22e4c60cc7130828ced8d36ec035533de1074cb049d3de9006ee542ac2e
+DIST asymptote-2.65.src.tgz 4640419 BLAKE2B a508532b9697a0744d48f8109d5b04ca71eb1ee7a08f15eccd2b95d63c16c980621ef03d01a03917a767c774f14a239a13f8fe50ad98b154b092f710917af1ad SHA512 c6879689192c1646a318b389de222accc55c8d5e9df17fab3c88c37f627d2cff8133cdefe9e6dec2784cf72edf261e557ad83f7fac6e67fd49c483e9d8971026
diff --git a/media-gfx/asymptote/asymptote-2.65.ebuild b/media-gfx/asymptote/asymptote-2.65.ebuild
new file mode 100644
index 000000000000..4c2242fc1988
--- /dev/null
+++ b/media-gfx/asymptote/asymptote-2.65.ebuild
@@ -0,0 +1,211 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit autotools elisp-common latex-package python-r1
+
+DESCRIPTION="A vector graphics language that provides a framework for technical drawing"
+HOMEPAGE="http://asymptote.sourceforge.net/"
+SRC_URI="mirror://sourceforge/asymptote/${P}.src.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="+boehm-gc doc emacs examples fftw gsl +imagemagick latex offscreen +opengl python sigsegv svg test vim-syntax X"
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ offscreen? ( opengl )
+ doc? ( boehm-gc )"
+
+RDEPEND="
+ >=sys-libs/ncurses-5.4-r5:0=
+ >=sys-libs/readline-4.3-r5:0=
+ imagemagick? ( media-gfx/imagemagick[png] )
+ opengl? ( media-libs/mesa[X(+)] media-libs/freeglut media-libs/glew:0 media-libs/glm )
+ offscreen? ( media-libs/mesa[osmesa] )
+ svg? ( app-text/dvisvgm )
+ sigsegv? ( dev-libs/libsigsegv )
+ boehm-gc? ( >=dev-libs/boehm-gc-7.0[cxx,threads] )
+ fftw? ( >=sci-libs/fftw-3.0.1 )
+ gsl? ( sci-libs/gsl )
+ python? ( ${PYTHON_DEPS} )
+ X? (
+ ${PYTHON_DEPS}
+ dev-python/PyQt5[${PYTHON_USEDEP},gui,widgets,svg]
+ dev-python/numpy
+ dev-python/pycson
+ >=gnome-base/librsvg-2.40
+ )
+ latex? (
+ virtual/latex-base
+ >=dev-texlive/texlive-latexextra-2013
+ )
+ emacs? ( >=app-editors/emacs-23.1:* )
+ vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )"
+DEPEND="${RDEPEND}
+ doc? (
+ dev-lang/perl
+ media-gfx/imagemagick[png]
+ virtual/texi2dvi
+ virtual/latex-base
+ app-text/ghostscript-gpl )
+ test? ( app-text/ghostscript-gpl )"
+
+TEXMF=/usr/share/texmf-site
+
+PATCHES=(
+ # Changing pdf, ps, image viewers to xdg-open
+ "${FILESDIR}/${P}-xdg-utils.patch"
+
+ # Bug #322473
+ "${FILESDIR}/${P}-info.patch"
+)
+
+src_prepare() {
+ sed -e "s:Datadir/doc/asymptote:Datadir/doc/${PF}:" \
+ -i configure.ac \
+ || die "sed configure.ac failed"
+
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # for the CPPFLAGS see
+ # https://sourceforge.net/forum/forum.php?thread_id=1683277&forum_id=409349
+ econf \
+ CPPFLAGS=-DHAVE_SYS_TYPES_H \
+ CFLAGS="${CXXFLAGS}" \
+ --disable-gc-debug \
+ $(use_enable boehm-gc gc system) \
+ $(use_enable fftw) \
+ $(use_enable gsl) \
+ $(use_enable opengl gl) \
+ $(use_enable offscreen) \
+ $(use_enable sigsegv)
+}
+
+src_compile() {
+ default
+
+ cd doc || die
+ emake asy.1
+ if use doc; then
+ # info
+ einfo "Making info"
+ emake ${PN}.info
+ cd FAQ || die
+ emake
+ cd .. || die
+ # pdf
+ einfo "Making pdf docs"
+ export VARTEXFONTS="${T}"/fonts
+ # see bug #260606
+ emake -j1 asymptote.pdf
+ emake CAD.pdf
+ fi
+ cd .. || die
+
+ if use emacs; then
+ einfo "Compiling emacs lisp files"
+ elisp-compile base/*.el
+ fi
+}
+
+src_install() {
+ # the program
+ dobin asy
+
+ # .asy files
+ insinto /usr/share/${PN}
+ doins base/*.asy
+
+ # documentation
+ dodoc BUGS ChangeLog README ReleaseNotes TODO
+ doman doc/asy.1
+
+ # X GUI
+ if use X; then
+ insinto /usr/share/${PN}
+ doins -r GUI
+ chmod +x "${D}"/usr/share/${PN}/GUI/xasy.py
+ dosym ../share/${PN}/GUI/xasy.py /usr/bin/xasy
+ doman doc/xasy.1x
+ fi
+
+ # examples
+ if use examples; then
+ insinto /usr/share/${PN}/examples
+ doins \
+ examples/*.asy \
+ doc/*.asy \
+ doc/*.csv \
+ doc/*.dat \
+ doc/extra/*.asy
+ insinto /usr/share/${PN}/examples/animations
+ doins examples/animations/*.asy
+ fi
+
+ # LaTeX style
+ if use latex; then
+ cd doc || die
+ insinto "${TEXMF}"/tex/latex/${PN}
+ doins ${PN}.sty asycolors.sty
+ if use examples; then
+ insinto /usr/share/${PN}/examples
+ doins latexusage.tex
+ insinto /usr/share/${PN}/examples/animations
+ doins ../examples/animations/*.tex
+ fi
+ cd .. || die
+ fi
+
+ # asymptote.py
+ if use python; then
+ python_foreach_impl python_domodule base/${PN}.py
+ fi
+
+ # emacs mode
+ if use emacs; then
+ elisp-install ${PN} base/*.el base/*.elc
+ elisp-site-file-install "${FILESDIR}"/64${PN}-gentoo.el
+ fi
+
+ # vim syntax
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins base/asy.vim
+ insinto /usr/share/vim/vimfiles/ftdetect
+ doins "${FILESDIR}"/asy-ftd.vim
+ fi
+
+ # extra documentation
+ if use doc; then
+ cd doc || die
+ doinfo ${PN}.info*
+ dodoc ${PN}.pdf CAD.pdf
+ cd FAQ || die
+ dodoc asy-faq.ascii
+ doinfo asy-faq.info
+ docinto html/FAQ
+ dodoc asy-faq.html/*
+ fi
+}
+
+pkg_postinst() {
+ use latex && latex-package_rehash
+ use emacs && elisp-site-regen
+
+ elog 'Use the variable ASYMPTOTE_PSVIEWER to set the postscript viewer'
+ elog 'Use the variable ASYMPTOTE_PDFVIEWER to set the PDF viewer'
+}
+
+pkg_postrm() {
+ use latex && latex-package_rehash
+ use emacs && elisp-site-regen
+}
diff --git a/media-gfx/asymptote/files/asymptote-2.65-info.patch b/media-gfx/asymptote/files/asymptote-2.65-info.patch
new file mode 100644
index 000000000000..27d0e5ce868d
--- /dev/null
+++ b/media-gfx/asymptote/files/asymptote-2.65-info.patch
@@ -0,0 +1,13 @@
+Index: asymptote-2.65/doc/asymptote.texi
+===================================================================
+--- asymptote-2.65.orig/doc/asymptote.texi
++++ asymptote-2.65/doc/asymptote.texi
+@@ -23,7 +23,7 @@ file LICENSE in the top-level source dir
+
+ @dircategory Languages
+ @direntry
+-* asymptote: (asymptote/asymptote). Vector graphics language.
++* asymptote: (asymptote). Vector graphics language.
+ @end direntry
+
+ @titlepage
diff --git a/media-gfx/asymptote/files/asymptote-2.65-xdg-utils.patch b/media-gfx/asymptote/files/asymptote-2.65-xdg-utils.patch
new file mode 100644
index 000000000000..6f4fb6cbcf4f
--- /dev/null
+++ b/media-gfx/asymptote/files/asymptote-2.65-xdg-utils.patch
@@ -0,0 +1,22 @@
+Index: asymptote-2.65/settings.cc
+===================================================================
+--- asymptote-2.65.orig/settings.cc
++++ asymptote-2.65/settings.cc
+@@ -100,13 +100,13 @@ string defaultPSViewer="open";
+ string defaultPDFViewer="open";
+ string defaultHTMLViewer="open";
+ #else
+-string defaultPSViewer="gv";
+-string defaultPDFViewer="acroread";
+-string defaultHTMLViewer="google-chrome";
++string defaultPSViewer="xdg-open";
++string defaultPDFViewer="xdg-open";
++string defaultHTMLViewer="xdg-open";
+ #endif
+ string defaultGhostscript="gs";
+ string defaultGhostscriptLibrary="";
+-string defaultDisplay="display";
++string defaultDisplay="xdg-open";
+ string defaultAnimate="animate";
+ void queryRegistry() {}
+ const string dirsep="/";