summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-15 07:51:31 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-15 08:16:21 +0100
commit294d6a5aa82aecde3cf5e79cf64b29ce6c3824b0 (patch)
tree115dd13ed2ce447f40a42c02b2636a9c0fda42b7
parentdev-python/pygame: Bump to 2.1.3 (diff)
downloadgentoo-294d6a5aa82aecde3cf5e79cf64b29ce6c3824b0.tar.gz
gentoo-294d6a5aa82aecde3cf5e79cf64b29ce6c3824b0.tar.bz2
gentoo-294d6a5aa82aecde3cf5e79cf64b29ce6c3824b0.zip
dev-python/werkzeug: Bump to 2.2.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/werkzeug/Manifest1
-rw-r--r--dev-python/werkzeug/werkzeug-2.2.3.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/werkzeug/Manifest b/dev-python/werkzeug/Manifest
index 7e9551fb2a90..5144e4372843 100644
--- a/dev-python/werkzeug/Manifest
+++ b/dev-python/werkzeug/Manifest
@@ -1 +1,2 @@
DIST werkzeug-2.2.2.gh.tar.gz 844463 BLAKE2B 84da3dd89375d6925e7e7018701339ddfd2b608acf6b3f126bd56c2020056511de6ab157de9024069d1342f9bce4b481ba91a06089fff1a3b31f4a851af7f935 SHA512 cded6c7e0b00871366b70a41de45e31323c0fc09300413d0efca98f5a2f8207026fd77c7e5670fde727da377fd02b9b636f390a2524d2b5778e9e3bdbdfe3e3a
+DIST werkzeug-2.2.3.gh.tar.gz 847768 BLAKE2B 7d0b891a2b15e4fc469c3d331cfb2565f452ae77f772f7ab8e6254aedd172f9115cd3ebd9c82e951ea7505c0e58d6b6f07fb643a8e87af505e04686cccf56cd4 SHA512 3968e663f67e41da5148a4aa1d8e047ffd88416fa8df665e359bbe87992e4e723e1c915eed59ae86b53dd18817e41cdcef059483bce7aa8ed7b388dd4add1482
diff --git a/dev-python/werkzeug/werkzeug-2.2.3.ebuild b/dev-python/werkzeug/werkzeug-2.2.3.ebuild
new file mode 100644
index 000000000000..a9d4ea56708e
--- /dev/null
+++ b/dev-python/werkzeug/werkzeug-2.2.3.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of various utilities for WSGI applications"
+HOMEPAGE="
+ https://palletsprojects.com/p/werkzeug/
+ https://pypi.org/project/Werkzeug/
+ https://github.com/pallets/werkzeug/
+"
+SRC_URI="
+ https://github.com/pallets/werkzeug/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="test-rust"
+
+RDEPEND="
+ >=dev-python/markupsafe-2.1.1[${PYTHON_USEDEP}]
+"
+# NOTE: remove the loong mask after greenlet gains support for loong
+# see https://github.com/python-greenlet/greenlet/pull/257
+BDEPEND="
+ test? (
+ dev-python/ephemeral-port-reserve[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/pytest-xprocess[${PYTHON_USEDEP}]
+ dev-python/watchdog[${PYTHON_USEDEP}]
+ test-rust? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ )
+ !hppa? ( !ia64? ( !loong? (
+ $(python_gen_cond_dep '
+ dev-python/greenlet[${PYTHON_USEDEP}]
+ ' python3_{8..10})
+ ) ) )
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=()
+ if ! has_version "dev-python/cryptography[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ "tests/test_serving.py::test_server[https]"
+ tests/test_serving.py::test_ssl_dev_cert
+ tests/test_serving.py::test_ssl_object
+ )
+ fi
+
+ # the default portage tempdir is too long for AF_UNIX sockets
+ local -x TMPDIR=/tmp
+ epytest -p no:django -p no:httpbin tests
+}