summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2017-06-24 23:51:22 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2017-06-24 23:51:39 +0200
commit29a55234feb2ae2715401aec95897deac26f5e93 (patch)
tree326ad4e6fcbfa0b859957a8ba41ffbe9c6f9eb74
parentjava-virtuals/servlet-api: EAPI 6 bump. (diff)
downloadgentoo-29a55234feb2ae2715401aec95897deac26f5e93.tar.gz
gentoo-29a55234feb2ae2715401aec95897deac26f5e93.tar.bz2
gentoo-29a55234feb2ae2715401aec95897deac26f5e93.zip
media-video/sonic-snap: EAPI bump, bug 605728
Package-Manager: Portage-2.3.6, Repoman-2.3.2
-rw-r--r--media-video/sonic-snap/sonic-snap-1.7-r1.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/media-video/sonic-snap/sonic-snap-1.7-r1.ebuild b/media-video/sonic-snap/sonic-snap-1.7-r1.ebuild
new file mode 100644
index 000000000000..753cb9d0be30
--- /dev/null
+++ b/media-video/sonic-snap/sonic-snap-1.7-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils linux-info multilib toolchain-funcs
+
+DESCRIPTION="Webcam app for sn9c10x based camera controllers (with optional MPEG4 support)"
+HOMEPAGE="http://www.stolk.org/sonic-snap/"
+SRC_URI="http://www.stolk.org/${PN}/downloads/${P}.tar.gz"
+
+LICENSE="GPL-1"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="mpeg"
+
+DEPEND="
+ x11-libs/fltk:1
+ mpeg? ( >=media-libs/libfame-0.9.1 )
+ sys-libs/zlib
+ x11-libs/libXdmcp
+ x11-libs/libXau
+ x11-libs/libXrender
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXft
+"
+RDEPEND="${DEPEND}"
+
+CONFIG_CHECK="~USB_SN9C102"
+ERROR_USB_SN9C102="Please make sure the SN9C1xx PC Camera Controller driver is \
+enabled, under V4L USB devices, as a module in your kernel."
+
+src_prepare() {
+ # fix bad assumptions
+ sed -i \
+ -e "s|\$(HOME)/include|/usr/include|" \
+ -e "s|\$(HOME)/lib|/usr/$(get_libdir)|" \
+ -e "s|CFLAGS=|CFLAGS= ${CXXFLAGS} |" \
+ -e "s|LFLAGS=|LFLAGS= ${LDFLAGS} |" \
+ -e "s/g++-4.0 -O3/$(tc-getCXX)/" \
+ Makefile || die
+
+ use mpeg || sed -i -e "s?USE_FAME=1?USE_FAME=0?g" Makefile || die
+
+ default
+}
+
+src_compile() {
+ make || die '"make" failed.'
+}
+
+src_install() {
+ dodir /usr/bin
+ make DESTDIR="${D}" install || die '"make install" failed.'
+
+ dodoc ChangeLog README
+ doman debian/sonic-snap.1
+}
+
+pkg_postinst() {
+ elog
+ elog "This driver is V4L v2 only, so V4L v1 apps will not work."
+ elog "Finally, only a few image sensors are supported, eg, PAS106B"
+ elog "so (check dmesg or /var/log/messages for USB device info when"
+ elog "you plug the cam in)."
+ elog
+ elog "Now try sonic-snap-gui /dev/videoX (where X is 0, 1 , etc)."
+ elog
+}