summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmadeusz Żołnowski <aidecoe@gentoo.org>2017-03-12 13:07:11 +0000
committerAmadeusz Żołnowski <aidecoe@gentoo.org>2017-03-12 13:34:25 +0000
commit29f43aa2e5a14e3cb85c81734add15460245f713 (patch)
treef7eaa2567877d6ecc424247b9898862c635c3a4e
parentapp-vim/undotree: add 9999 ebuild. (diff)
downloadgentoo-29f43aa2e5a14e3cb85c81734add15460245f713.tar.gz
gentoo-29f43aa2e5a14e3cb85c81734add15460245f713.tar.bz2
gentoo-29f43aa2e5a14e3cb85c81734add15460245f713.zip
app-misc/timew: Add new package
Timewarrior is a sibling project to Taskwarrior. Package-Manager: Portage-2.3.4, Repoman-2.3.2
-rw-r--r--app-misc/timew/Manifest1
-rw-r--r--app-misc/timew/metadata.xml8
-rw-r--r--app-misc/timew/timew-1.0.0.ebuild25
3 files changed, 34 insertions, 0 deletions
diff --git a/app-misc/timew/Manifest b/app-misc/timew/Manifest
new file mode 100644
index 000000000000..0ac90441dfb5
--- /dev/null
+++ b/app-misc/timew/Manifest
@@ -0,0 +1 @@
+DIST timew-1.0.0.tar.gz 140539 SHA256 ac027910e1e8365bdd218a8b42389b26d017d38d3c96516c408db6d5a44e0bb5 SHA512 0539ff93b2375c154d126c39aa84f21b57b62f51c220c80b2e323a4d6aefd2eda6f87c04112e096222102b019ee3683a78b9ee9d6fbf6736d4a34c529f6152f5 WHIRLPOOL 77ede6c679203071c3da95f708326f626906266547301b9ce2f2c8ae768f6b4082fb32bcc325a22e7295f5894477786960632ff201771b3512d978bf8c379c75
diff --git a/app-misc/timew/metadata.xml b/app-misc/timew/metadata.xml
new file mode 100644
index 000000000000..674f5ad944f3
--- /dev/null
+++ b/app-misc/timew/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>aidecoe@gentoo.org</email>
+ <name>Amadeusz Żołnowski</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-misc/timew/timew-1.0.0.ebuild b/app-misc/timew/timew-1.0.0.ebuild
new file mode 100644
index 000000000000..b17148ed009a
--- /dev/null
+++ b/app-misc/timew/timew-1.0.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Tracks your time from the command line, and generates reports"
+HOMEPAGE="https://taskwarrior.org/news/news.20160821.html"
+SRC_URI="https://taskwarrior.org/download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ -DTIMEW_DOCDIR=share/doc/${PF}
+ )
+ cmake-utils_src_configure
+}