summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2019-12-31 20:47:36 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2019-12-31 20:49:08 -0800
commit2a65bfb72e82ecf9184130a6c627e11007663293 (patch)
tree5848d9bccf422d1a7501a7b20fe78a6877d71e63
parentdev-python/Babel: Bump to 2.8.0 (diff)
downloadgentoo-2a65bfb72e82ecf9184130a6c627e11007663293.tar.gz
gentoo-2a65bfb72e82ecf9184130a6c627e11007663293.tar.bz2
gentoo-2a65bfb72e82ecf9184130a6c627e11007663293.zip
app-emulation/vagrant: add virtualbox-6.1 support to 2.2.6
Closes: https://bugs.gentoo.org/704372 Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
-rw-r--r--app-emulation/vagrant/files/support-vbox-6.1.patch75
-rw-r--r--app-emulation/vagrant/vagrant-2.2.6-r1.ebuild (renamed from app-emulation/vagrant/vagrant-2.2.6.ebuild)4
2 files changed, 78 insertions, 1 deletions
diff --git a/app-emulation/vagrant/files/support-vbox-6.1.patch b/app-emulation/vagrant/files/support-vbox-6.1.patch
new file mode 100644
index 00000000000..59a54630279
--- /dev/null
+++ b/app-emulation/vagrant/files/support-vbox-6.1.patch
@@ -0,0 +1,75 @@
+From fb4e6985e142da56bad143d70600cd3695c91757 Mon Sep 17 00:00:00 2001
+From: Brian Cain <bcain@hashicorp.com>
+Date: Wed, 11 Dec 2019 13:25:11 -0800
+Subject: [PATCH] Fixes #11249: Add VirtualBox provider support for version
+ 6.1.x
+
+This commit adds support for VirtualBox version 6.1.x. It simply
+inherits from the base 6.0.x provider class.
+---
+ plugins/providers/virtualbox/driver/meta.rb | 1 +
+ .../providers/virtualbox/driver/version_6_1.rb | 16 ++++++++++++++++
+ plugins/providers/virtualbox/plugin.rb | 1 +
+ website/source/docs/virtualbox/index.html.md | 2 +-
+ 4 files changed, 19 insertions(+), 1 deletion(-)
+ create mode 100644 plugins/providers/virtualbox/driver/version_6_1.rb
+
+diff --git a/plugins/providers/virtualbox/driver/meta.rb b/plugins/providers/virtualbox/driver/meta.rb
+index 24547b4044..ed013737b0 100644
+--- a/plugins/providers/virtualbox/driver/meta.rb
++++ b/plugins/providers/virtualbox/driver/meta.rb
+@@ -64,6 +64,7 @@ def initialize(uuid=nil)
+ "5.1" => Version_5_1,
+ "5.2" => Version_5_2,
+ "6.0" => Version_6_0,
++ "6.1" => Version_6_1,
+ }
+
+ if @@version.start_with?("4.2.14")
+diff --git a/plugins/providers/virtualbox/driver/version_6_1.rb b/plugins/providers/virtualbox/driver/version_6_1.rb
+new file mode 100644
+index 0000000000..ebe417eb91
+--- /dev/null
++++ b/plugins/providers/virtualbox/driver/version_6_1.rb
+@@ -0,0 +1,16 @@
++require File.expand_path("../version_6_0", __FILE__)
++
++module VagrantPlugins
++ module ProviderVirtualBox
++ module Driver
++ # Driver for VirtualBox 6.1.x
++ class Version_6_1 < Version_6_0
++ def initialize(uuid)
++ super
++
++ @logger = Log4r::Logger.new("vagrant::provider::virtualbox_6_1")
++ end
++ end
++ end
++ end
++end
+diff --git a/plugins/providers/virtualbox/plugin.rb b/plugins/providers/virtualbox/plugin.rb
+index e058ec65ad..f2fbf47e55 100644
+--- a/plugins/providers/virtualbox/plugin.rb
++++ b/plugins/providers/virtualbox/plugin.rb
+@@ -59,6 +59,7 @@ module Driver
+ autoload :Version_5_1, File.expand_path("../driver/version_5_1", __FILE__)
+ autoload :Version_5_2, File.expand_path("../driver/version_5_2", __FILE__)
+ autoload :Version_6_0, File.expand_path("../driver/version_6_0", __FILE__)
++ autoload :Version_6_1, File.expand_path("../driver/version_6_1", __FILE__)
+ end
+
+ module Model
+diff --git a/website/source/docs/virtualbox/index.html.md b/website/source/docs/virtualbox/index.html.md
+index 558ef5f5d8..e9c1e79aad 100644
+--- a/website/source/docs/virtualbox/index.html.md
++++ b/website/source/docs/virtualbox/index.html.md
+@@ -13,7 +13,7 @@ Vagrant comes with support out of the box for [VirtualBox](https://www.virtualbo
+ a free, cross-platform consumer virtualization product.
+
+ The VirtualBox provider is compatible with VirtualBox versions 4.0.x, 4.1.x,
+-4.2.x, 4.3.x, 5.0.x, 5.1.x, 5.2.x, and 6.0.x. Other versions are unsupported and the provider
++4.2.x, 4.3.x, 5.0.x, 5.1.x, 5.2.x, 6.0.x, and 6.1.x. Other versions are unsupported and the provider
+ will display an error message. Please note that beta and pre-release versions
+ of VirtualBox are not supported and may not be well-behaved.
+
diff --git a/app-emulation/vagrant/vagrant-2.2.6.ebuild b/app-emulation/vagrant/vagrant-2.2.6-r1.ebuild
index d3796ed1651..db493d1a781 100644
--- a/app-emulation/vagrant/vagrant-2.2.6.ebuild
+++ b/app-emulation/vagrant/vagrant-2.2.6-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -52,6 +52,8 @@ ruby_add_bdepend "
>=dev-ruby/rake-10.5.0
"
+PATCHES="${FILESDIR}/support-vbox-6.1.patch"
+
all_ruby_prepare() {
# remove bundler support
sed -i '/[Bb]undler/d' Rakefile || die