summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-08-12 13:42:51 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-08-12 14:23:35 +0300
commit2aadd319fbff4a7d8c906ef0fd8fc32250a9c8c4 (patch)
treeb31c82e14a996767a5b8359ff724530d50599d68
parentdev-python/pyside2-tools: add 5.15.5 (diff)
downloadgentoo-2aadd319fbff4a7d8c906ef0fd8fc32250a9c8c4.tar.gz
gentoo-2aadd319fbff4a7d8c906ef0fd8fc32250a9c8c4.tar.bz2
gentoo-2aadd319fbff4a7d8c906ef0fd8fc32250a9c8c4.zip
dev-python/sentry-sdk: add 1.9.4
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/sentry-sdk/Manifest1
-rw-r--r--dev-python/sentry-sdk/sentry-sdk-1.9.4.ebuild96
2 files changed, 97 insertions, 0 deletions
diff --git a/dev-python/sentry-sdk/Manifest b/dev-python/sentry-sdk/Manifest
index 85cadc665780..edf21c530efc 100644
--- a/dev-python/sentry-sdk/Manifest
+++ b/dev-python/sentry-sdk/Manifest
@@ -5,3 +5,4 @@ DIST sentry-sdk-1.9.0.gh.tar.gz 290271 BLAKE2B fcb4c45c129faf23a1177167e2bdd567a
DIST sentry-sdk-1.9.1.gh.tar.gz 270398 BLAKE2B 66ee16816d312b38df737c5ecb0ecc4a2189c932c162bbedf165f2a153029e95c389372a4638d5f71f669ac780710769e4708c3e7673573d1b1e79a29cbf93c9 SHA512 5997252aeee900125e42d7275627359ca5382707162b93e45b238c11a181ac724fea327fa1b29deed63dbf800463d10c9d2a8e8943c32b907e4eac055e399297
DIST sentry-sdk-1.9.2.gh.tar.gz 270400 BLAKE2B 690e62c1b4f64677442ac46b15973173d96d587b71786f5c2e0a9e8d15aec7978b86b247a52ff15b6d0dc9665f8eafa4b1ad458d3aa3fca3447e7c9946503c69 SHA512 189916cf8b931df73eaa252bbc2f3beb53bf56529d50ebe79affd04e9684ffa89e1f66ec651b7dca6fbd5de641333ddd6f65512978ee06c2abb73617bd6f3ea2
DIST sentry-sdk-1.9.3.gh.tar.gz 270453 BLAKE2B e971c89ccdbe3831e49cf48db4673c54f4110878e45e92bf5f8142a876b8382fc714e9e3fc124c36495c8cda24efabad9486fc0cdb939a034c931a718e21c501 SHA512 4a31507635cbe3932ecb548273f32cfd6098d5ed4eed2771a37b79f98a4c97f12d50b89f63f357424355d5657bc2bdb3e49f0984db4e9c9ee7ee31b984d0367e
+DIST sentry-sdk-1.9.4.gh.tar.gz 271140 BLAKE2B 07ba10c72ec61c1bd6a54899712b5880ddf4c4f67ae9f127184d0251e93ae0a7374441ba77eb54c871684152613db55a582ca98f787884ef834f658d743abccd SHA512 2b0089b29da002e6236b93033f36bc0a6ba08d4643021f6bc2e30807a84867030dad088e1ff6b917f5b9dbc2da06305c3e58cdd9f9c10009df5063640cb8796a
diff --git a/dev-python/sentry-sdk/sentry-sdk-1.9.4.ebuild b/dev-python/sentry-sdk/sentry-sdk-1.9.4.ebuild
new file mode 100644
index 000000000000..9d1e2042e8f2
--- /dev/null
+++ b/dev-python/sentry-sdk/sentry-sdk-1.9.4.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python client for Sentry"
+HOMEPAGE="
+ https://sentry.io/
+ https://github.com/getsentry/sentry-python/
+ https://pypi.org/project/sentry-sdk/
+"
+SRC_URI="
+ https://github.com/getsentry/sentry-python/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/sentry-python-${PV}"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/asttokens[${PYTHON_USEDEP}]
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/executing[${PYTHON_USEDEP}]
+ dev-python/fakeredis[${PYTHON_USEDEP}]
+ dev-python/flask-login[${PYTHON_USEDEP}]
+ dev-python/gevent[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pyrsistent[${PYTHON_USEDEP}]
+ dev-python/pytest-aiohttp[${PYTHON_USEDEP}]
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/zope-event[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/eventlet[${PYTHON_USEDEP}]
+ ' python3_{8..9})
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # tests require Internet access
+ tests/integrations/httpx/test_httpx.py
+ tests/integrations/requests/test_requests.py
+ tests/integrations/stdlib/test_httplib.py
+ tests/integrations/flask/test_flask.py
+ tests/integrations/django/test_basic.py
+ # wtf is it supposed to do?!
+ tests/integrations/gcp/test_gcp.py
+ # broken by rq-1.10.1 (optional dep)
+ tests/integrations/rq/test_rq.py
+ # fastapi is not packaged
+ tests/integrations/asgi/test_fastapi.py
+ # TODO
+ tests/integrations/bottle
+ # requires python-multipart (TODO: package it)
+ tests/integrations/starlette
+)
+
+EPYTEST_DESELECT=(
+ # hangs
+ 'tests/test_transport.py::test_transport_works'
+ # TODO
+ 'tests/test_basics.py::test_auto_enabling_integrations_catches_import_error'
+ tests/test_client.py::test_databag_depth_stripping
+ tests/test_client.py::test_databag_string_stripping
+ tests/test_client.py::test_databag_breadth_stripping
+ tests/integrations/asgi/test_asgi.py::test_auto_session_tracking_with_aggregates
+ tests/integrations/asgi/test_asgi.py::test_websocket
+ tests/integrations/aiohttp/test_aiohttp.py::test_transaction_style
+ tests/integrations/aiohttp/test_aiohttp.py::test_traces_sampler_gets_request_object_in_sampling_context
+ # incompatible version?
+ tests/integrations/falcon/test_falcon.py
+ tests/integrations/sqlalchemy/test_sqlalchemy.py::test_too_large_event_truncated
+ # test_circular_references: apparently fragile
+ 'tests/integrations/threading/test_threading.py::test_circular_references'
+ # test for new feature, fails with IndexError
+ tests/integrations/wsgi/test_wsgi.py::test_session_mode_defaults_to_request_mode_in_wsgi_handler
+ # TODO
+ tests/integrations/wsgi/test_wsgi.py::test_auto_session_tracking_with_aggregates
+ tests/integrations/wsgi/test_wsgi.py::test_profile_sent_when_profiling_enabled
+)