summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-04-04 23:59:22 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2018-04-04 23:59:22 -0500
commit2b5e0c95f6393acdf25683dea6ef7c797721cde3 (patch)
treeea467e2e0a15987df09d169c010eb1ea513a50f7
parentapp-crypt/certbot-nginx: 0.23.0 bup (diff)
downloadgentoo-2b5e0c95f6393acdf25683dea6ef7c797721cde3.tar.gz
gentoo-2b5e0c95f6393acdf25683dea6ef7c797721cde3.tar.bz2
gentoo-2b5e0c95f6393acdf25683dea6ef7c797721cde3.zip
app-crypt/{acme,certbot,certbot-apache,certbot-nginx}: 0.20.0 cleanup
-rw-r--r--app-crypt/acme/acme-0.20.0.ebuild47
-rw-r--r--app-crypt/certbot-apache/certbot-apache-0.20.0.ebuild38
-rw-r--r--app-crypt/certbot-nginx/certbot-nginx-0.20.0.ebuild34
-rw-r--r--app-crypt/certbot/certbot-0.20.0.ebuild54
4 files changed, 0 insertions, 173 deletions
diff --git a/app-crypt/acme/acme-0.20.0.ebuild b/app-crypt/acme/acme-0.20.0.ebuild
deleted file mode 100644
index 91d9aa0f2d69..000000000000
--- a/app-crypt/acme/acme-0.20.0.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
-
-if [[ ${PV} == 9999* ]]; then
- EGIT_REPO_URI="https://github.com/certbot/certbot.git"
- inherit git-r3
- S=${WORKDIR}/${P}/${PN}
-else
- SRC_URI="https://github.com/certbot/certbot/archive/v${PV}.tar.gz -> certbot-${PV}.tar.gz"
- KEYWORDS="amd64 ~arm ~ppc64 x86"
- S=${WORKDIR}/certbot-${PV}/acme
-fi
-
-inherit distutils-r1
-
-DESCRIPTION="An implementation of the ACME protocol"
-HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="test"
-
-RDEPEND="
- >=dev-python/cryptography-0.8[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- >=dev-python/pyopenssl-0.13[${PYTHON_USEDEP}]
- dev-python/pyrfc3339[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- >=dev-python/requests-2.10[${PYTHON_USEDEP}]
- >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
- !dev-python/josepy[${PYTHON_USEDEP}]
-"
-DEPEND="
- test? (
- ${RDEPEND}
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- )
- >=dev-python/setuptools-1.0[${PYTHON_USEDEP}]
-"
-
-python_test() {
- nosetests -w ${PN} || die
-}
diff --git a/app-crypt/certbot-apache/certbot-apache-0.20.0.ebuild b/app-crypt/certbot-apache/certbot-apache-0.20.0.ebuild
deleted file mode 100644
index d49cea753975..000000000000
--- a/app-crypt/certbot-apache/certbot-apache-0.20.0.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
-
-if [[ ${PV} == 9999* ]]; then
- EGIT_REPO_URI="https://github.com/certbot/certbot.git"
- inherit git-r3
- S=${WORKDIR}/${P}/${PN}
-else
- SRC_URI="https://github.com/${PN%-apache}/${PN%-apache}/archive/v${PV}.tar.gz -> ${PN%-apache}-${PV}.tar.gz"
- KEYWORDS="amd64 x86"
- S=${WORKDIR}/${PN%-apache}-${PV}/${PN}
-fi
-
-inherit distutils-r1
-
-DESCRIPTION="Apache plugin for certbot (Let's Encrypt Client)"
-HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="test"
-
-RDEPEND="~app-crypt/certbot-${PV}[${PYTHON_USEDEP}]
- ~app-crypt/acme-${PV}[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/python-augeas[${PYTHON_USEDEP}]
- dev-python/zope-component[${PYTHON_USEDEP}]
- dev-python/zope-interface[${PYTHON_USEDEP}]"
-DEPEND="test? ( ${RDEPEND}
- dev-python/nose[${PYTHON_USEDEP}] )
- dev-python/setuptools[${PYTHON_USEDEP}]"
-
-python_test() {
- nosetests || die
-}
diff --git a/app-crypt/certbot-nginx/certbot-nginx-0.20.0.ebuild b/app-crypt/certbot-nginx/certbot-nginx-0.20.0.ebuild
deleted file mode 100644
index d8d4c6b6a24f..000000000000
--- a/app-crypt/certbot-nginx/certbot-nginx-0.20.0.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
-
-if [[ ${PV} == 9999* ]]; then
- EGIT_REPO_URI="https://github.com/certbot/certbot.git"
- inherit git-r3
- S=${WORKDIR}/${P}/${PN}
-else
- SRC_URI="https://github.com/${PN%-nginx}/${PN%-nginx}/archive/v${PV}.tar.gz -> ${PN%-nginx}-${PV}.tar.gz"
- KEYWORDS="amd64 ~arm x86"
- S=${WORKDIR}/${PN%-nginx}-${PV}/${PN}
-fi
-
-inherit distutils-r1
-
-DESCRIPTION="Nginx plugin for certbot (Let's Encrypt Client)"
-HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE=""
-
-CDEPEND=">=dev-python/setuptools-1.0[${PYTHON_USEDEP}]"
-RDEPEND="${CDEPEND}
- ~app-crypt/certbot-${PV}[${PYTHON_USEDEP}]
- ~app-crypt/acme-${PV}[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pyopenssl[${PYTHON_USEDEP}]
- >=dev-python/pyparsing-1.5.5[${PYTHON_USEDEP}]
- dev-python/zope-interface[${PYTHON_USEDEP}]"
-DEPEND="${CDEPEND}"
diff --git a/app-crypt/certbot/certbot-0.20.0.ebuild b/app-crypt/certbot/certbot-0.20.0.ebuild
deleted file mode 100644
index f67006191db9..000000000000
--- a/app-crypt/certbot/certbot-0.20.0.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
-
-if [[ ${PV} == 9999* ]]; then
- EGIT_REPO_URI="https://github.com/certbot/certbot.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 ~arm ~ppc64 x86"
-fi
-
-inherit distutils-r1
-
-DESCRIPTION="Let's encrypt client to automate deployment of X.509 certificates"
-HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="test"
-
-CDEPEND=">=dev-python/setuptools-1.0[${PYTHON_USEDEP}]"
-RDEPEND="
- ${CDEPEND}
- ~app-crypt/acme-${PV}[${PYTHON_USEDEP}]
- >=dev-python/configargparse-0.9.3[${PYTHON_USEDEP}]
- dev-python/configobj[${PYTHON_USEDEP}]
- >=dev-python/cryptography-1.2[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- >=dev-python/parsedatetime-1.3[${PYTHON_USEDEP}]
- dev-python/pyopenssl[${PYTHON_USEDEP}]
- dev-python/pyrfc3339[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/zope-component[${PYTHON_USEDEP}]
- dev-python/zope-interface[${PYTHON_USEDEP}]"
-DEPEND="
- ${CDEPEND}
- test? (
- >=dev-python/astroid-1.3.5[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/ipdb[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-cov[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- >=dev-python/pylint-1.4.2[${PYTHON_USEDEP}]
- dev-python/wheel[${PYTHON_USEDEP}]
- )"
-
-python_test() {
- nosetests -v ${PN} || die
-}