summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-12-12 16:41:35 +0100
committerAlexis Ballier <aballier@gentoo.org>2019-12-12 16:43:54 +0100
commit2b758e1f2575db36ed742c2f2fad4f622f374457 (patch)
tree5e53b4ac4540f8336134b7eda7210a5afb1dd2ba
parentdev-ros/ament_cmake_test: fix live ebuild (diff)
downloadgentoo-2b758e1f2575db36ed742c2f2fad4f622f374457.tar.gz
gentoo-2b758e1f2575db36ed742c2f2fad4f622f374457.tar.bz2
gentoo-2b758e1f2575db36ed742c2f2fad4f622f374457.zip
dev-ros/ament_cmake_version: fix deps and add live ebuild
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
-rw-r--r--dev-ros/ament_cmake_version/ament_cmake_version-0.8.1.ebuild23
-rw-r--r--dev-ros/ament_cmake_version/ament_cmake_version-9999.ebuild48
2 files changed, 66 insertions, 5 deletions
diff --git a/dev-ros/ament_cmake_version/ament_cmake_version-0.8.1.ebuild b/dev-ros/ament_cmake_version/ament_cmake_version-0.8.1.ebuild
index 927b7ae06922..771e21ca92e4 100644
--- a/dev-ros/ament_cmake_version/ament_cmake_version-0.8.1.ebuild
+++ b/dev-ros/ament_cmake_version/ament_cmake_version-0.8.1.ebuild
@@ -8,22 +8,35 @@ PYTHON_COMPAT=( python{3_6,3_7} )
inherit cmake-utils python-r1
ROS_PN="ament_cmake"
-DESCRIPTION="The core of the ament buildsystem in CMake"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ament/ament_cmake"
+ SRC_URI=""
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/ament/ament_cmake/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
+ S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+fi
+
+DESCRIPTION="Override the exported package version in the ament buildsystem"
HOMEPAGE="https://github.com/ament/ament_cmake"
-SRC_URI="https://github.com/ament/ament_cmake/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="~amd64"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
IUSE=""
DEPEND="
dev-ros/ament_cmake_core[${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}
"
RDEPEND="${DEPEND}"
-BDEPEND="${PYTHON_DEPS}"
+BDEPEND="${DEPEND}"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
src_configure() {
# This is a build tool that does not install python-related files
diff --git a/dev-ros/ament_cmake_version/ament_cmake_version-9999.ebuild b/dev-ros/ament_cmake_version/ament_cmake_version-9999.ebuild
new file mode 100644
index 000000000000..771e21ca92e4
--- /dev/null
+++ b/dev-ros/ament_cmake_version/ament_cmake_version-9999.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7} )
+
+inherit cmake-utils python-r1
+
+ROS_PN="ament_cmake"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ament/ament_cmake"
+ SRC_URI=""
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/ament/ament_cmake/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
+ S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+fi
+
+DESCRIPTION="Override the exported package version in the ament buildsystem"
+HOMEPAGE="https://github.com/ament/ament_cmake"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+IUSE=""
+
+DEPEND="
+ dev-ros/ament_cmake_core[${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}
+"
+RDEPEND="${DEPEND}"
+BDEPEND="${DEPEND}"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_configure() {
+ # This is a build tool that does not install python-related files
+ # ... but we need to propagate the deps and use python3 to build it.
+ local pyimpl="${PYTHON_COMPAT[0]}"
+ python_export "${pyimpl}" EPYTHON PYTHON
+ python_wrapper_setup
+ cmake-utils_src_configure
+}