summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-01-31 07:46:09 -0500
committerIonen Wolkens <ionen@gentoo.org>2023-01-31 08:44:46 -0500
commit2baf08ebb67f124cc965e4b63f6870825f5b7ef3 (patch)
tree1169b31d934ccd752b6b506326eef146093277d6
parentx11-terms/kitty-terminfo: add 0.27.0 (diff)
downloadgentoo-2baf08ebb67f124cc965e4b63f6870825f5b7ef3.tar.gz
gentoo-2baf08ebb67f124cc965e4b63f6870825f5b7ef3.tar.bz2
gentoo-2baf08ebb67f124cc965e4b63f6870825f5b7ef3.zip
x11-terms/kitty: add 0.27.0
As noted previously in live, adds Go requirement for /usr/bin/kitten. Drop ImageMagick optfeature, kitty now has its own methods for common image format using Go and ImageMagick is only a fallback. Move test deletions behind `use test` so that the live ebuild won't fail over this with USE=-test if something is moved around (e.g. the typo'ed tpmfile -> tmpfile). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--x11-terms/kitty/Manifest3
-rw-r--r--x11-terms/kitty/kitty-0.27.0.ebuild156
2 files changed, 159 insertions, 0 deletions
diff --git a/x11-terms/kitty/Manifest b/x11-terms/kitty/Manifest
index 12d34a7c8440..e8b07330c97a 100644
--- a/x11-terms/kitty/Manifest
+++ b/x11-terms/kitty/Manifest
@@ -1,2 +1,5 @@
DIST kitty-0.26.5.tar.xz 4749988 BLAKE2B 488969b4d7c6aed489a540a8e3bee183345fcfb7e05ae5604f4af40f0720ed931cff82cf389e2fa4015eed74762c0630481a99eeb9302c22c89c4f3e247170d4 SHA512 086ae03d0e382afbe3001e357ef51388c7a8e81fa5b4bf9ce8b123a7fc8bfff3bd68d074e926f540a1f2b83062baa831e44d29c017cabfe8221bebe49b64e808
DIST kitty-0.26.5.tar.xz.sig 566 BLAKE2B 377202d46e66854e0cf1998506e0fafca54b33d85264e47c13aa4b98d272c786809375f1e277ec169291e06809f11b5b061ec1243a708711fa2350243ad1eca2 SHA512 0c691d8becff2b0f24e09b941d7315efaac831beacfed6f66b9186bde9c502f2ae86289f4b0d8fa6a34624dce7a1e958ba2d0502fd87003ba08b07fa07c6ae17
+DIST kitty-0.27.0-vendor.tar.xz 696348 BLAKE2B cc20c2dec531907d50f796d2ee61e1468b66f02a37b1228cc1e0e3ef405342fcb8c027d96bb161d7b205384e179f1de1f45f5e39caafe8282a1811fdde905d5e SHA512 37dfac07238aac007938734fa8d7a3dd3cde3f064d5ab544f21230ad1feb733c4a39fa61a871275848f6dbfeeb66671b2a893e7f7b6a69f13e2fec16f348b77c
+DIST kitty-0.27.0.tar.xz 5067860 BLAKE2B 5c9126dd9e76afcd6d53aa025adc36912145129b16b0db60c9cb12736df895166d417cbce9198e1feddd3f07c216e557136a130853fa0ddd91833c67fe236c4e SHA512 8063008df261747a7089c69ad9ae3a3d3c24286014f02d04faee9f0b5b6f452172cf99ff8a520ca8e314ba0009e0009701292656db913c23d84b6a2311085813
+DIST kitty-0.27.0.tar.xz.sig 566 BLAKE2B d2b39e05e56e10eb3856a4aec105acfa1c3bd289eddab7ff9047e6a9743cf142c5b9b6aa85aa6196e7d6be7a168b475b96e2586ef57f66e29045744ca81c9fa7 SHA512 3f4a70659a17440d0d08d2f909b3279c5043adc981e075d9648892bfa2b7d617bfd520fac8571cd692833082e03b1d9997f9aaa75187318168dfbe6922ec389d
diff --git a/x11-terms/kitty/kitty-0.27.0.ebuild b/x11-terms/kitty/kitty-0.27.0.ebuild
new file mode 100644
index 000000000000..9d20478938f2
--- /dev/null
+++ b/x11-terms/kitty/kitty-0.27.0.ebuild
@@ -0,0 +1,156 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+inherit edo optfeature multiprocessing python-single-r1 toolchain-funcs xdg
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/kovidgoyal/kitty.git"
+else
+ inherit verify-sig
+ SRC_URI="
+ https://github.com/kovidgoyal/kitty/releases/download/v${PV}/${P}.tar.xz
+ https://dev.gentoo.org/~ionen/distfiles/${P}-vendor.tar.xz
+ verify-sig? ( https://github.com/kovidgoyal/kitty/releases/download/v${PV}/${P}.tar.xz.sig )"
+ VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}/usr/share/openpgp-keys/kovidgoyal.gpg"
+ KEYWORDS="~amd64 ~ppc64 ~riscv ~x86"
+fi
+
+DESCRIPTION="Fast, feature-rich, GPU-based terminal"
+HOMEPAGE="https://sw.kovidgoyal.net/kitty/"
+
+LICENSE="GPL-3 ZLIB"
+LICENSE+=" Apache-2.0 BSD MIT" # go
+SLOT="0"
+IUSE="+X test wayland"
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ || ( X wayland )
+ test? ( X wayland )"
+RESTRICT="!test? ( test )"
+
+# dlopen: fontconfig,libglvnd
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/openssl:=
+ media-libs/fontconfig
+ media-libs/harfbuzz:=
+ media-libs/lcms:2
+ media-libs/libglvnd[X?]
+ media-libs/libpng:=
+ net-libs/librsync:=
+ sys-apps/dbus
+ sys-libs/zlib:=
+ x11-libs/libxkbcommon[X?]
+ x11-misc/xkeyboard-config
+ ~x11-terms/kitty-shell-integration-${PV}
+ ~x11-terms/kitty-terminfo-${PV}
+ X? ( x11-libs/libX11 )
+ wayland? ( dev-libs/wayland )"
+DEPEND="
+ ${RDEPEND}
+ X? (
+ x11-base/xorg-proto
+ x11-libs/libXcursor
+ x11-libs/libXi
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ )
+ wayland? ( dev-libs/wayland-protocols )"
+BDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-lang/go-1.19
+ sys-libs/ncurses
+ virtual/pkgconfig
+ test? ( $(python_gen_cond_dep 'dev-python/pillow[${PYTHON_USEDEP}]') )
+ wayland? ( dev-util/wayland-scanner )"
+[[ ${PV} == 9999 ]] || BDEPEND+=" verify-sig? ( sec-keys/openpgp-keys-kovidgoyal )"
+
+QA_FLAGS_IGNORED="usr/bin/kitten" # written in Go
+
+src_unpack() {
+ if [[ ${PV} == 9999 ]]; then
+ git-r3_src_unpack
+ cd "${S}" || die
+ edo go mod vendor
+ else
+ use verify-sig &&
+ verify-sig_verify_detached "${DISTDIR}"/${P}.tar.xz{,.sig}
+ default
+ fi
+}
+
+src_prepare() {
+ default
+
+ # sed unfortunately feels easier on maintenance than patches here
+ local sedargs=(
+ -e "/num_workers =/s/=.*/= $(makeopts_jobs)/"
+ -e "s/cflags.append.*-O3.*/pass/" -e 's/-O3//'
+ -e "s/ld_flags.append('-[sw]')/pass/"
+ )
+
+ # kitty is often popular on wayland-only setups, try to allow this
+ use !X && sedargs+=( -e '/gl_libs =/s/=.*/= []/' ) #857918
+ use !X || use !wayland &&
+ sedargs+=( -e "s/'x11 wayland'/'$(usex X x11 wayland)'/" )
+
+ # skip docs for live version, missing dependencies
+ [[ ${PV} == 9999 ]] && sedargs+=( -e '/exists.*_build/,/docs(ddir)/d' )
+
+ sed -i setup.py "${sedargs[@]}" || die
+
+ local skiptests=(
+ # relies on 'who' command which doesn't detect users with pid-sandbox
+ kitty_tests/utmp.py
+ # may fail/hang depending on environment and shell initialization
+ kitty_tests/{shell_integration,ssh}.py
+ # relies on /proc/self/fd and gets confused when ran from here
+ tools/utils/tpmfile_test.go
+ )
+ use !test || rm "${skiptests[@]}" || die
+}
+
+src_compile() {
+ tc-export CC
+ local -x GOFLAGS="-buildmode=pie -v -x"
+ local -x PKGCONFIG_EXE=$(tc-getPKG_CONFIG)
+
+ local conf=(
+ --disable-link-time-optimization
+ --ignore-compiler-warnings
+ --libdir-name=$(get_libdir)
+ --shell-integration="enabled no-rc"
+ --update-check-interval=0
+ --verbose
+ )
+
+ edo "${EPYTHON}" setup.py linux-package "${conf[@]}"
+ use test && edo "${EPYTHON}" setup.py build-launcher "${conf[@]}"
+
+ [[ ${PV} == 9999 ]] || mv linux-package/share/doc/{${PN},${PF}} || die
+ rm -r linux-package/share/terminfo || die
+}
+
+src_test() {
+ KITTY_CONFIG_DIRECTORY=${T} ./test.py || die # shebang is kitty
+}
+
+src_install() {
+ insinto /usr
+ doins -r linux-package/.
+
+ local execbit
+ mapfile -t execbit < <(find linux-package -type f -perm /+x -printf '/usr/%P\n' || die)
+ fperms +x "${execbit[@]}"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature "audio-based terminal bell support" media-libs/libcanberra
+ optfeature "opening links from the terminal" x11-misc/xdg-utils
+}