summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-07-02 17:16:02 +0200
committerPacho Ramos <pacho@gentoo.org>2016-07-02 19:10:28 +0200
commit2c1efcb5aca8d4baea7a7331e43ce5711f69664a (patch)
tree4759f321c78bf641c72d198df5e080becee95d52
parentmedia-libs/gegl: Version bump (diff)
downloadgentoo-2c1efcb5aca8d4baea7a7331e43ce5711f69664a.tar.gz
gentoo-2c1efcb5aca8d4baea7a7331e43ce5711f69664a.tar.bz2
gentoo-2c1efcb5aca8d4baea7a7331e43ce5711f69664a.zip
media-gfx/gnome-photos: Version bump
Package-Manager: portage-2.3.0_rc1
-rw-r--r--media-gfx/gnome-photos/Manifest1
-rw-r--r--media-gfx/gnome-photos/gnome-photos-3.20.2.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/media-gfx/gnome-photos/Manifest b/media-gfx/gnome-photos/Manifest
index 90d60cc6de58..714972026303 100644
--- a/media-gfx/gnome-photos/Manifest
+++ b/media-gfx/gnome-photos/Manifest
@@ -1 +1,2 @@
DIST gnome-photos-3.18.3.tar.xz 776220 SHA256 cb0b0573b2b473257a41024de7b99986a10a67af07cbdead5bf266291e9ed167 SHA512 e7e2f7251fb6a5dae0994cb45f363508481f2f30922a6ec966f1ad5767643ba0ff554ebf3d4108ca90ef63cf22a0cdb8b069b558f9547320e694bc872122aaf5 WHIRLPOOL 16f73b96b4cf0de391b990a64f28e8ddc26aca7b1545cad44ff0a17e32a64e7ff5d6c7d7dfa6afbca1eadbcec3f9397e7a561bc74776abffd6bfc2bf4e35b13d
+DIST gnome-photos-3.20.2.tar.xz 927128 SHA256 ec6b95ad1c4aeeb065a65d2d48335036c0750761c7f6762bafcf874791272b46 SHA512 14022afa3480366f92579a233b04a3d094ceda3e65089351be62166ade6a92ec22cee62ae89d7e51543d48ca83fc9d76afb1ef21ce8b1c8c2d252098b717fb4d WHIRLPOOL e3b779e1cdbeb4bccae54e747e22639117d75db426eec843bd0a1d3e69ee9ba8ce34d6a6d0cf777d61a80fb2ccfac7b71222eb6d9c7f52245332c3bb348411dd
diff --git a/media-gfx/gnome-photos/gnome-photos-3.20.2.ebuild b/media-gfx/gnome-photos/gnome-photos-3.20.2.ebuild
new file mode 100644
index 000000000000..b32632582ddc
--- /dev/null
+++ b/media-gfx/gnome-photos/gnome-photos-3.20.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2 python-any-r1 virtualx
+
+DESCRIPTION="Access, organize and share your photos on GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Photos"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=app-misc/tracker-1:=[miner-fs]
+ >=dev-libs/glib-2.39.3:2
+ gnome-base/gnome-desktop:3=
+ >=dev-libs/libgdata-0.15.2:0=[gnome-online-accounts]
+ media-libs/babl
+ >=media-libs/gegl-0.3.5:0.3
+ >=media-libs/grilo-0.3.0:0.3=
+ >=media-libs/libpng-1.6:0=
+ >=media-plugins/grilo-plugins-0.2.6:0.2[upnp-av]
+ >=net-libs/gnome-online-accounts-3.8:=
+ >=net-libs/libgfbgraph-0.2.1:0.2
+ >=x11-libs/cairo-1.14
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.19.1:3
+"
+DEPEND="${RDEPEND}
+ dev-util/desktop-file-utils
+ >=dev-util/intltool-0.50.1
+ dev-util/itstool
+ virtual/pkgconfig
+ test? ( dev-util/dogtail )
+"
+# eautoreconf
+# app-text/yelp-tools
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable test dogtail)
+}
+
+src_test() {
+ virtx emake check
+}