summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2020-03-01 19:34:07 -0500
committerCraig Andrews <candrews@gentoo.org>2020-03-01 19:39:07 -0500
commit2c941595ab9c0a41d1b2e0ebde0fd3cdb731a82f (patch)
tree0596923c6db1c49b9af9f7ce190f1515fe42e8e3
parentdev-libs/rocm-device-libs: 3.1.0 version bump (diff)
downloadgentoo-2c941595ab9c0a41d1b2e0ebde0fd3cdb731a82f.tar.gz
gentoo-2c941595ab9c0a41d1b2e0ebde0fd3cdb731a82f.tar.bz2
gentoo-2c941595ab9c0a41d1b2e0ebde0fd3cdb731a82f.zip
dev-libs/rocm-comgr: 3.1.0 version bump
Closes: https://bugs.gentoo.org/711006 Package-Manager: Portage-2.3.90, Repoman-2.3.20 Signed-off-by: Craig Andrews <candrews@gentoo.org>
-rw-r--r--dev-libs/rocm-comgr/Manifest1
-rw-r--r--dev-libs/rocm-comgr/files/rocm-comgr-3.1.0-dependencies.patch52
-rw-r--r--dev-libs/rocm-comgr/rocm-comgr-3.1.0.ebuild41
3 files changed, 94 insertions, 0 deletions
diff --git a/dev-libs/rocm-comgr/Manifest b/dev-libs/rocm-comgr/Manifest
index 6ed802333f8f..12383981b194 100644
--- a/dev-libs/rocm-comgr/Manifest
+++ b/dev-libs/rocm-comgr/Manifest
@@ -1 +1,2 @@
DIST rocm-comgr-3.0.0.tar.gz 88594 BLAKE2B d3fb356962ba6a9ffc7aa295f1582f6587d55d1f4f2a9a978f5c189f4a0597a9cb3f9806a1f2f43f14e262bc19964e06f41df3c7f45ac3c1579511fe235cc940 SHA512 ffa250c44388b1985ec0dac68bf0dd27820933fe7579f7fc6b35d783852cd03fb02919b5e800b01d536c36eb3c5bff96d1a38f5c8ab6380d6584b2e6d19a25fc
+DIST rocm-comgr-3.1.0.tar.gz 88654 BLAKE2B 2b74fcde11a9fdd815526cb6fae81c1844aed5d73e961c437c9d3585b8cbd538983a9b06a5130eb75e5ac272d0a833f459053436f48116eb430c742de532ce65 SHA512 be148e92c84aacfc11724b0bfb54fab0e8cec2474eb943b1df4841517d47a3995b179afafcaa0730ddb9fadf891ca4797ce6613afac1f6f018dcc5b030a32e98
diff --git a/dev-libs/rocm-comgr/files/rocm-comgr-3.1.0-dependencies.patch b/dev-libs/rocm-comgr/files/rocm-comgr-3.1.0-dependencies.patch
new file mode 100644
index 000000000000..d70ed4957002
--- /dev/null
+++ b/dev-libs/rocm-comgr/files/rocm-comgr-3.1.0-dependencies.patch
@@ -0,0 +1,52 @@
+https://github.com/RadeonOpenCompute/ROCm-CompilerSupport/pull/25
+
+From c65cba2e73f9118e128b9ab7e655ee0f8a7798e7 Mon Sep 17 00:00:00 2001
+From: Craig Andrews <candrews@integralblue.com>
+Date: Sun, 1 Mar 2020 19:24:22 -0500
+Subject: [PATCH] Link additional required LLVM libraries
+
+Without these additional required dependencies, linking fails with errors such as:
+`undefined reference to llvm::errs()'`
+---
+ CMakeLists.txt | 20 ++++++++++++++++++--
+ 1 file changed, 18 insertions(+), 2 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 1794a07..c7b852a 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -207,7 +207,11 @@ install(FILES
+ DESTINATION "${AMD_COMGR_PACKAGE_PREFIX}")
+
+ set(CLANG_LIBS
+- clangFrontendTool)
++ clangFrontendTool
++ clangFrontend
++ clangBasic
++ clangDriver
++ clangSerialization)
+
+ set(LLD_LIBS
+ lldELF
+@@ -218,8 +222,20 @@ if (LLVM_LINK_LLVM_DYLIB)
+ else()
+ llvm_map_components_to_libnames(LLVM_LIBS
+ ${LLVM_TARGETS_TO_BUILD}
++ Option
+ DebugInfoDWARF
+- Symbolize)
++ Symbolize
++ Support
++ Object
++ BitWriter
++ MC
++ MCParser
++ MCDisassembler
++ Core
++ IRReader
++ CodeGen
++ Linker
++ BinaryFormat)
+ endif()
+
+ target_link_libraries(amd_comgr
diff --git a/dev-libs/rocm-comgr/rocm-comgr-3.1.0.ebuild b/dev-libs/rocm-comgr/rocm-comgr-3.1.0.ebuild
new file mode 100644
index 000000000000..96891e698554
--- /dev/null
+++ b/dev-libs/rocm-comgr/rocm-comgr-3.1.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/RadeonOpenCompute/ROCm-CompilerSupport/"
+ inherit git-r3
+ S="${WORKDIR}/${P}/lib/comgr"
+else
+ SRC_URI="https://github.com/RadeonOpenCompute/ROCm-CompilerSupport/archive/roc-${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/ROCm-CompilerSupport-roc-${PV}/lib/comgr"
+ KEYWORDS="~amd64"
+fi
+PATCHES=(
+ "${FILESDIR}/${PN}-2.6.0-find-clang.patch"
+ "${FILESDIR}/${PN}-2.6.0-find-lld-includes.patch"
+ "${FILESDIR}/${PN}-3.1.0-dependencies.patch"
+)
+
+DESCRIPTION="Radeon Open Compute Code Object Manager"
+HOMEPAGE="https://github.com/RadeonOpenCompute/ROCm-CompilerSupport"
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+
+RDEPEND=">=dev-libs/rocm-device-libs-${PV}
+ >=sys-devel/llvm-roc-${PV}:="
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DLLVM_DIR="${EPREFIX}/usr/lib/llvm/roc/"
+ )
+ cmake_src_configure
+}