summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-12-27 00:30:03 -0600
committerTim Harder <radhermit@gentoo.org>2018-12-27 00:57:49 -0600
commit2d0a354c39e2a5611481cf3c98b25f333aa1b7d6 (patch)
treeb5af461c2c04ccfa9c9d8dab5a688125715a8ae4
parentdev-python/pyte: remove old (diff)
downloadgentoo-2d0a354c39e2a5611481cf3c98b25f333aa1b7d6.tar.gz
gentoo-2d0a354c39e2a5611481cf3c98b25f333aa1b7d6.tar.bz2
gentoo-2d0a354c39e2a5611481cf3c98b25f333aa1b7d6.zip
dev-python/pytest-runner: version bump to 4.2
Signed-off-by: Tim Harder <radhermit@gentoo.org>
-rw-r--r--dev-python/pytest-runner/Manifest1
-rw-r--r--dev-python/pytest-runner/pytest-runner-4.2.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/pytest-runner/Manifest b/dev-python/pytest-runner/Manifest
index ead06770abd0..c9065c2f3808 100644
--- a/dev-python/pytest-runner/Manifest
+++ b/dev-python/pytest-runner/Manifest
@@ -1,3 +1,4 @@
DIST pytest-runner-2.11.1.tar.gz 9661 BLAKE2B 300b63de61ef36c299a95c60af469b071c27ae483f641c7cad594f7b6f582d9e1e076192f9fd5019850cf9227af183e9f80b4049719d074a180e72c25521bc14 SHA512 5249e0a368bab21bb034a9b0121edbcda635f559cc22ba79c87565dcbc070056bfed47a69c16f4733403f61ea5b73adfd1ccf945700116043cbf3940d37d4067
DIST pytest-runner-2.6.2.tar.gz 6379 BLAKE2B 4f676a4cd59309cdd0e6462c83718482622817781d302ed95a2b7cb9d92a0b0f38b411c1172ecce9003f5781cdb168338bce6f446b1c91069a2024fb75574bfc SHA512 6a993e8729d5e203986f2526d46e96b7ac19e65fc26493a55a98e858304ecde0c47576476864a0ee1817ea1a7b02cfda952fc03f79b84fff249021f140f3d00d
DIST pytest-runner-4.0.tar.gz 11401 BLAKE2B 3be4527e68b8c1ae7e1bb5bad111367e459a07cf20de1f3b2d8ab993a7e016f9656618075bf515f576fef457aa86f99990f7dcc4c20a04166703bf9272c395c1 SHA512 a7f3defcc698f43b3b6ceec3f59dbd0e00c651167ddc76a9d1a093d722a013c9ffd2bad3438e49170688d503166cb6d8bf55bbaf7bc6f9e6d80eff049c202b08
+DIST pytest-runner-4.2.tar.gz 11947 BLAKE2B 97495bead800a81d879659f1ee522822f76fe8ac80579537d43e21e663323d7c10be8d2da7d05ffdb0931145149d8c10ef7c72b3ab4da2ce856d44d3f00a724e SHA512 278da7add27f77134e63470747ffd9fe663d93ab8e7cebfbae98902bb1d5ffba45277574107f958255251cb9e499b85a0db3e8173f9f10fb31d1561ca709a379
diff --git a/dev-python/pytest-runner/pytest-runner-4.2.ebuild b/dev-python/pytest-runner/pytest-runner-4.2.ebuild
new file mode 100644
index 000000000000..07a5f1fde57b
--- /dev/null
+++ b/dev-python/pytest-runner/pytest-runner-4.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Adds support for tests during installation of setup.py files"
+HOMEPAGE="https://pypi.org/project/pytest-runner/ https://github.com/pytest-dev/pytest-runner"
+SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd"
+SLOT="0"
+IUSE="doc test"
+
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/rst-linker[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+ test? ( ${RDEPEND} )
+"
+
+# Tests require network access to download packages
+RESTRICT="test"
+
+python_compile_all() {
+ if use doc; then
+ esetup.py build_sphinx
+ HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
+ fi
+}
+
+python_test() {
+ esetup.py pytest
+}