summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-05-25 22:47:28 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-05-25 22:54:42 +0200
commit2d186767c14469a19ff4920e6344f034d6cee0f5 (patch)
treeb6372dcd5225df4ab2081d2279d55e372c59000e
parentapp-misc/mx5000tools: add missing dependencies (diff)
downloadgentoo-2d186767c14469a19ff4920e6344f034d6cee0f5.tar.gz
gentoo-2d186767c14469a19ff4920e6344f034d6cee0f5.tar.bz2
gentoo-2d186767c14469a19ff4920e6344f034d6cee0f5.zip
media-sound/qsynth: 0.5.6 version bump
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--media-sound/qsynth/Manifest1
-rw-r--r--media-sound/qsynth/qsynth-0.5.6.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/media-sound/qsynth/Manifest b/media-sound/qsynth/Manifest
index 6f2bd9a124c9..0f74fd13dd53 100644
--- a/media-sound/qsynth/Manifest
+++ b/media-sound/qsynth/Manifest
@@ -1 +1,2 @@
DIST qsynth-0.5.5.tar.gz 269061 BLAKE2B e17bb0ced40764c5bef9ae7c793f7ba1ebfe4edd761f434ad129f338d30384c639f27d697ecfdaa93d7fff52c38bed0a3b95cf51fbdad25e13c14abe795d49dd SHA512 4e90b38d428c6b49a78b648ac9604e683f32623898205abe3a98c4136c5b29ab27c101cf63207dbbfdcba105913de2dcb5cc7669a6433def71d071f39cf68429
+DIST qsynth-0.5.6.tar.gz 269583 BLAKE2B 9b06f7be1aa39addebd0b088eff885bce39c6bc245461b64fe45243306afae8879d4b516bd46c30c2a8074e580e412c38a3c264d647a35ff5c81301703731067 SHA512 752b3ac7e478594ef873b2d1c9fcb1a1dcdd1fb33f34cab5f588f628d1f11f01ecd150c9d51021a41040794b68f0538ad6979751773d5c537f53a1f227b3bf88
diff --git a/media-sound/qsynth/qsynth-0.5.6.ebuild b/media-sound/qsynth/qsynth-0.5.6.ebuild
new file mode 100644
index 000000000000..e4f0b6bb00dc
--- /dev/null
+++ b/media-sound/qsynth/qsynth-0.5.6.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop flag-o-matic qmake-utils
+
+DESCRIPTION="A Qt application to control FluidSynth"
+HOMEPAGE="http://qsynth.sourceforge.net/"
+SRC_URI="mirror://sourceforge/qsynth/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+alsa debug jack pulseaudio"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+"
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ media-sound/fluidsynth:=[jack?,alsa?,pulseaudio?]
+"
+RDEPEND="${DEPEND}"
+
+REQUIRED_USE="|| ( alsa jack pulseaudio )"
+
+PATCHES=( "${FILESDIR}/${PN}-0.4.0-qt5-tagging.patch" )
+
+src_configure() {
+ append-cxxflags -std=c++11
+ sed -e "/@gzip.*mandir)\/man1/d" -i Makefile.in || die
+ econf \
+ $(use_enable debug)
+
+ eqmake5 ${PN}.pro -o ${PN}.mak
+}
+
+src_install () {
+ emake DESTDIR="${D}" INSTALL_ROOT="${D}" install
+ einstalldocs
+
+ # The desktop file is invalid, and we also change the command
+ # depending on useflags
+ rm "${ED}/usr/share/applications/qsynth.desktop" || die
+
+ local cmd
+ if use jack; then
+ cmd="qsynth"
+ elif use pulseaudio; then
+ cmd="qsynth -a pulseaudio"
+ elif use alsa; then
+ cmd="qsynth -a alsa"
+ else
+ cmd="qsynth -a oss"
+ fi
+
+ make_desktop_entry "${cmd}" Qsynth qsynth
+}