summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-01-21 22:50:51 +0100
committerDavid Seifert <soap@gentoo.org>2020-01-21 22:50:51 +0100
commit2d782708992f33dfeb0aeb9c44a65cb4bc60019e (patch)
treefeea7137d676a8de37975c185994339be48b5366
parentapp-text/expander: Port to EAPI 7 (diff)
downloadgentoo-2d782708992f33dfeb0aeb9c44a65cb4bc60019e.tar.gz
gentoo-2d782708992f33dfeb0aeb9c44a65cb4bc60019e.tar.bz2
gentoo-2d782708992f33dfeb0aeb9c44a65cb4bc60019e.zip
app-text/libxmlpatch: Port to EAPI 7
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--app-text/libxmlpatch/libxmlpatch-0.3.3.ebuild27
1 files changed, 15 insertions, 12 deletions
diff --git a/app-text/libxmlpatch/libxmlpatch-0.3.3.ebuild b/app-text/libxmlpatch/libxmlpatch-0.3.3.ebuild
index 51ae4624c90c..d38ce9c286df 100644
--- a/app-text/libxmlpatch/libxmlpatch-0.3.3.ebuild
+++ b/app-text/libxmlpatch/libxmlpatch-0.3.3.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
-inherit eutils autotools
+inherit autotools
DESCRIPTION="A set of tools to create and apply patch to XML files using XPath"
HOMEPAGE="http://xmlpatch.sourceforge.net/"
@@ -12,30 +12,33 @@ SRC_URI="mirror://sourceforge/${PN/lib}/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64"
-IUSE="test static-libs"
+IUSE="test"
RESTRICT="!test? ( test )"
-RDEPEND="dev-libs/glib:2
+RDEPEND="
+ dev-libs/glib:2
dev-libs/libxml2"
DEPEND="${RDEPEND}
- test? ( dev-libs/check )
- virtual/pkgconfig"
+ test? ( dev-libs/check )"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
src_prepare() {
- epatch "${FILESDIR}"/${P}-gentoo.patch
+ default
+ mv configure.{in,ac} || die
eautoreconf
}
src_configure() {
econf \
- $(use_enable static-libs static) \
+ --disable-static \
$(use_with test check)
}
-DOCS=( LEGAL_NOTICE README TODO ChangeLog )
-
src_install() {
default
- find "${D}" -name '*.la' -delete
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
}