summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-11 06:38:31 +0000
committerSam James <sam@gentoo.org>2021-06-11 06:38:31 +0000
commit2dee3213eab1d7a589a42c99297a98de5846a0ee (patch)
tree2af26ea31d8665d90ba66cb1c6f8e0b8f54a6988
parentdev-util/txt2regex: add github upstream metadata (diff)
downloadgentoo-2dee3213.tar.gz
gentoo-2dee3213.tar.bz2
gentoo-2dee3213.zip
app-misc/detox: drop 1.2.0-r3
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-misc/detox/Manifest1
-rw-r--r--app-misc/detox/detox-1.2.0-r3.ebuild50
-rw-r--r--app-misc/detox/files/detox-1.2.0-LDFLAGS.patch18
-rw-r--r--app-misc/detox/files/detox-1.2.0-change-default-sequence-to-use-utf8-table.patch17
-rw-r--r--app-misc/detox/files/detox-1.2.0-format-security.patch72
-rw-r--r--app-misc/detox/files/detox-1.2.0-install-missing-file.patch18
-rw-r--r--app-misc/detox/files/detox-1.2.0-parallel.patch29
7 files changed, 0 insertions, 205 deletions
diff --git a/app-misc/detox/Manifest b/app-misc/detox/Manifest
index e820c4d29cc9..85d09041d8d2 100644
--- a/app-misc/detox/Manifest
+++ b/app-misc/detox/Manifest
@@ -1,3 +1,2 @@
-DIST detox-1.2.0.tar.bz2 86118 BLAKE2B 2dbde6ebd98b59c18c60f99006731484dcbc698ab77b56991f2af94f4ad45da141046975af47b66242ff42d4e3a8bb3b515d4b70ba30f12cb1b8ceea5832f52a SHA512 48c0060ed0538c26aeba444bf327f1e52ea47d0e696577deeb43304dfb960ee5abe984651948bfc67c51d7f15f9051df2a208acfe53a5778a7471460e87f639a
DIST detox-1.4.0.tar.gz 106361 BLAKE2B 5993ded30282a16a81481885cdee41fe0b1c2ac34e5f389b53981e098d13acdfe367c7de462436fe3a4ee8ff86220f4c69d54a47c1122a0f39bde12c4d6ec908 SHA512 9486056b3b58dbb5ae16bc461586a997f8990ddb6e0db5ba561df862c16dfe926911fd09f065ef2578d39c3e3f1a267be201f865cf3f6b576c01910bda39cecb
DIST detox-1.4.2.tar.gz 106736 BLAKE2B a27f9d93bf6f6c1634517c0f193affe576b2eec6be4b8fc38e91ef75a6f1a01a4376684d5a9b109b3971d0e311b64faeba020a3b7660ff130086956a7ebe92bd SHA512 ca1327e127cf1ba1803d8931aa119c9d11fc5b998f45ad5f7c339cea7f7928a5a6a45f90db9a51a7ccf6d4ee268cd316461c621db62dcc7182cd0255e74a1481
diff --git a/app-misc/detox/detox-1.2.0-r3.ebuild b/app-misc/detox/detox-1.2.0-r3.ebuild
deleted file mode 100644
index 2ec1846e2a59..000000000000
--- a/app-misc/detox/detox-1.2.0-r3.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit epatch
-
-MY_P="${PN}-${PV/_/-}"
-
-DESCRIPTION="Safely remove spaces and strange characters from filenames"
-HOMEPAGE="http://detox.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~hppa ~mips ppc x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-S="${WORKDIR}"/${MY_P}
-
-RDEPEND="
- dev-libs/popt
- !dev-python/detox"
-
-DEPEND="
- ${RDEPEND}
- sys-devel/flex
- sys-devel/bison"
-
-PATCHES=(
- "${FILESDIR}"/${P}-parallel.patch
- "${FILESDIR}"/${P}-LDFLAGS.patch
- "${FILESDIR}"/${P}-change-default-sequence-to-use-utf8-table.patch
- "${FILESDIR}"/${P}-install-missing-file.patch
- "${FILESDIR}"/${P}-format-security.patch
- )
-
-src_prepare() {
- sed \
- -e 's:Fl c Ar:Fl f Ar:g' \
- -i ${PN}.1 || die
- epatch "${PATCHES[@]}"
- sed \
- -e '/detoxrc.sample/d' \
- -i Makefile.in || die
-}
-
-src_configure() {
- econf --with-popt="${EPREFIX}/usr"
-}
diff --git a/app-misc/detox/files/detox-1.2.0-LDFLAGS.patch b/app-misc/detox/files/detox-1.2.0-LDFLAGS.patch
deleted file mode 100644
index 3f0daa088010..000000000000
--- a/app-misc/detox/files/detox-1.2.0-LDFLAGS.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-https://sourceforge.net/tracker/index.php?func=detail&aid=2166388&group_id=101612&atid=630105
-
---- Makefile.in 2008-10-14 16:37:22 +0000
-+++ Makefile.in 2008-10-14 16:38:17 +0000
-@@ -70,10 +70,10 @@
- #
-
- detox: ${detoxOBJS}
-- ${CC} -o detox ${detoxOBJS} ${L_OPT}
-+ ${CC} ${LDFLAGS} -o detox ${detoxOBJS} ${L_OPT}
-
- inline-detox: ${inline-detoxOBJS}
-- ${CC} -o inline-detox ${inline-detoxOBJS} ${L_OPT}
-+ ${CC} ${LDFLAGS} -o inline-detox ${inline-detoxOBJS} ${L_OPT}
-
- #
- # Special Source Compiles
-
diff --git a/app-misc/detox/files/detox-1.2.0-change-default-sequence-to-use-utf8-table.patch b/app-misc/detox/files/detox-1.2.0-change-default-sequence-to-use-utf8-table.patch
deleted file mode 100644
index 2e54642f45b9..000000000000
--- a/app-misc/detox/files/detox-1.2.0-change-default-sequence-to-use-utf8-table.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-# Patch from Teemu Likonen <tlikonen@iki.fi>
-# to change the default sequence to use utf8 instead of iso8859-1
---- detox-1.2.0/detoxrc~ 2006-07-03 19:45:54.000000000 +0300
-+++ detox-1.2.0/detoxrc 2009-05-28 15:34:26.497832449 +0300
-@@ -32,10 +32,10 @@
- #
-
- #
--# Basically just ISO8859_1
-+# Basically just utf_8
- #
- sequence default {
-- iso8859_1;
-+ utf_8;
- safe;
- wipeup;
- };
diff --git a/app-misc/detox/files/detox-1.2.0-format-security.patch b/app-misc/detox/files/detox-1.2.0-format-security.patch
deleted file mode 100644
index c03a98aa046c..000000000000
--- a/app-misc/detox/files/detox-1.2.0-format-security.patch
+++ /dev/null
@@ -1,72 +0,0 @@
- parse_options_getopt.c | 8 ++++----
- parse_options_popt.c | 8 ++++----
- 2 files changed, 8 insertions(+), 8 deletions(-)
-
-diff --git a/parse_options_getopt.c b/parse_options_getopt.c
-index 1f80966..ea2b266 100644
---- a/parse_options_getopt.c
-+++ b/parse_options_getopt.c
-@@ -98,9 +98,9 @@ struct detox_options *parse_options_getopt(int argc, char **argv)
- #endif
- switch (optcode) {
- case 'h':
-- printf(usage_message);
-+ printf("%s", usage_message);
- printf("\n");
-- printf(help_message);
-+ printf("%s", help_message);
- exit(EXIT_SUCCESS);
-
- case 'f':
-@@ -138,7 +138,7 @@ struct detox_options *parse_options_getopt(int argc, char **argv)
- exit(EXIT_SUCCESS);
-
- case '?':
-- printf(usage_message);
-+ printf("%s", usage_message);
- exit(EXIT_SUCCESS);
-
- case 0:
-@@ -195,7 +195,7 @@ struct detox_options *parse_options_getopt(int argc, char **argv)
- }
- else {
- #ifndef INLINE_MODE
-- printf(usage_message);
-+ printf("%s", usage_message);
- exit(EXIT_FAILURE);
- #endif
- }
-diff --git a/parse_options_popt.c b/parse_options_popt.c
-index 60dad7a..370c3cc 100644
---- a/parse_options_popt.c
-+++ b/parse_options_popt.c
-@@ -94,9 +94,9 @@ struct detox_options *parse_options_popt(int argc, const char **argv)
- while ((c = poptGetNextOpt(optCon)) >= 0) {
- switch (c) {
- case 'h':
-- printf(usage_message);
-+ printf("%s", usage_message);
- printf("\n");
-- printf(help_message);
-+ printf("%s", help_message);
- exit(EXIT_SUCCESS);
-
- case 'f':
-@@ -142,7 +142,7 @@ struct detox_options *parse_options_popt(int argc, const char **argv)
- break;
-
- case '?':
-- printf(usage_message);
-+ printf("%s", usage_message);
- exit(EXIT_SUCCESS);
-
- }
-@@ -177,7 +177,7 @@ struct detox_options *parse_options_popt(int argc, const char **argv)
-
- #ifndef INLINE_MODE
- if (i == 0) {
-- fprintf(stderr, usage_message);
-+ fprintf(stderr, "%s", usage_message);
- exit(EXIT_FAILURE);
- }
- #endif
diff --git a/app-misc/detox/files/detox-1.2.0-install-missing-file.patch b/app-misc/detox/files/detox-1.2.0-install-missing-file.patch
deleted file mode 100644
index 97863268bc48..000000000000
--- a/app-misc/detox/files/detox-1.2.0-install-missing-file.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-# Patch by Nelson A. de Oliveira <naoliv@debian.org>
-#
-# Patch upstream Makefile to install missing safe.tbl (#566785)
-
---- detox-1.2.0/Makefile.in 2010-06-20 23:41:34.000000000 -0300
-+++ detox-1.2.0/Makefile.in 2010-06-20 23:42:34.000000000 -0300
-@@ -147,6 +147,11 @@
- else \
- echo "${DESTDIR}${datadir}/detox/unicode.tbl exists, skipping"; \
- fi
-+ @if [ ! -f ${DESTDIR}${datadir}/detox/safe.tbl ]; then \
-+ ${INSTALL} -m 644 safe.tbl ${DESTDIR}${datadir}/detox; \
-+ else \
-+ echo "${DESTDIR}${datadir}/detox/safe.tbl exists, skipping"; \
-+ fi
-
- install-unsafe-config: install-base
- ${INSTALL} -m 644 detoxrc ${DESTDIR}${sysconfdir}
diff --git a/app-misc/detox/files/detox-1.2.0-parallel.patch b/app-misc/detox/files/detox-1.2.0-parallel.patch
deleted file mode 100644
index 73abd73d61b3..000000000000
--- a/app-misc/detox/files/detox-1.2.0-parallel.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-https://sourceforge.net/tracker/index.php?func=detail&aid=2166387&group_id=101612&atid=630105
-
---- Makefile.in 2008-10-14 16:39:34 +0000
-+++ Makefile.in 2008-10-14 16:38:51 +0000
-@@ -131,7 +131,7 @@
- ${INSTALL} -m 644 detox.1 ${DESTDIR}${mandir}/man1
- ${INSTALL} -m 644 detoxrc.5 detox.tbl.5 ${DESTDIR}${mandir}/man5
-
--install-safe-config:
-+install-safe-config: install-base
- @if [ ! -f ${DESTDIR}${sysconfdir}/detoxrc ]; then \
- ${INSTALL} -m 644 detoxrc ${DESTDIR}${sysconfdir}; \
- else \
-@@ -148,12 +148,12 @@
- echo "${DESTDIR}${datadir}/detox/unicode.tbl exists, skipping"; \
- fi
-
--install-unsafe-config:
-+install-unsafe-config: install-base
- ${INSTALL} -m 644 detoxrc ${DESTDIR}${sysconfdir}
- ${INSTALL} -m 644 iso8859_1.tbl ${DESTDIR}${datadir}/detox
- ${INSTALL} -m 644 unicode.tbl ${DESTDIR}${datadir}/detox
-
--install-sample-config:
-+install-sample-config: install-base
- ${INSTALL} -m 644 detoxrc ${DESTDIR}${sysconfdir}/detoxrc.sample
- ${INSTALL} -m 644 iso8859_1.tbl ${DESTDIR}${datadir}/detox/iso8859_1.tbl.sample
- ${INSTALL} -m 644 unicode.tbl ${DESTDIR}${datadir}/detox/unicode.tbl.sample
-