summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-14 06:37:16 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-14 08:05:08 +0200
commit2e1b5e296438558374ccfab1f02e7385812cd4e9 (patch)
tree81eaab8d88ff641c334cd4208a88bfce5aab9c9f
parentdev-python/botocore: Bump to 1.34.160 (diff)
downloadgentoo-2e1b5e296438558374ccfab1f02e7385812cd4e9.tar.gz
gentoo-2e1b5e296438558374ccfab1f02e7385812cd4e9.tar.bz2
gentoo-2e1b5e296438558374ccfab1f02e7385812cd4e9.zip
dev-python/boto3: Bump to 1.34.160
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.34.160.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index e507ff864a35..4dda3aff738a 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -2,3 +2,4 @@ DIST boto3-1.34.149.gh.tar.gz 845064 BLAKE2B 25e77483b8ac8a52e7f5586794839dcab69
DIST boto3-1.34.153.gh.tar.gz 847038 BLAKE2B f29aec887fd57d2bc4b6be125787384438e0dba65dd01effcc91016b9301be2fdde315a2fbdc8f122350ae52f904ba1c281aee9a5dc52994ddd11b45ead3f8a3 SHA512 a8d8f75ef48ad8418aafddbdea4fb021f64b041e7beabf68a0c2f6c461c3aa0b3f2f20c33122ac87d57296fd0d14ee8834b96257085c522b556f6aa1d99ea0d1
DIST boto3-1.34.158.gh.tar.gz 848930 BLAKE2B 5db04b9eee08f5418a595e736f075fbe22b92adada9219e8a8cf2299c723d09e2edf88e5ebb3d09c1613a01e5d0d5c837e9545c6ee3110c430c521da10fa2bde SHA512 03f532e78a1a2b8ec01396f0b7f7bae7059165e35440eda47f4393e99d2a8ded229470cf3269a71c746b8a66dccd8626444f1e429e561df1dc1ec0f6b8653272
DIST boto3-1.34.159.gh.tar.gz 849599 BLAKE2B e21979dd33413d63dfb905cdde8351a89fb3a431ee0873ffc3cbb8e9681c207842c5d2c288622736c0ac7516ef0d607d6ee5caea9877c1b7f177c0cae7125f9c SHA512 6fe6528240b0f1ed78e1b4ccba104c238075d8daff3b2224f03912a48f9278d1d92d8caf13951128e25e19d49e895492e463dc8aaa3d903982ebbacbbf727b21
+DIST boto3-1.34.160.gh.tar.gz 850214 BLAKE2B 74e8bfecc23086301750ec55e265c57d9085ca292ed9155948e46deb2531860b01336ab341371421333b041f6ba4f4a9114926969d39620b2ba508541ee0fc90 SHA512 ad443616bb4a04fc9e3cceee462d4f06c17c5096853b69e4ccaf1c319bb48fd0bd0131cb3de496b7d05f194818e36c8a165578c5afc3304a7d628936ddc478c9
diff --git a/dev-python/boto3/boto3-1.34.160.ebuild b/dev-python/boto3/boto3-1.34.160.ebuild
new file mode 100644
index 000000000000..8cba6d95740e
--- /dev/null
+++ b/dev-python/boto3/boto3-1.34.160.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/botocore-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}